summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-10-04 14:25:38 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-10-04 14:25:38 +0000
commit271bec2a1badfc5a12a331823dbb7439b24a3147 (patch)
tree9d0560b6305831c33fcc43bcce9c31eeff4015ed /dev-java/sun-jdk
parentamd64 stable, security bug 194278 (diff)
downloadgentoo-2-271bec2a1badfc5a12a331823dbb7439b24a3147.tar.gz
gentoo-2-271bec2a1badfc5a12a331823dbb7439b24a3147.tar.bz2
gentoo-2-271bec2a1badfc5a12a331823dbb7439b24a3147.zip
Version bump for security bug #194711.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-java/sun-jdk')
-rw-r--r--dev-java/sun-jdk/ChangeLog8
-rw-r--r--dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.166
-rw-r--r--dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild178
3 files changed, 191 insertions, 1 deletions
diff --git a/dev-java/sun-jdk/ChangeLog b/dev-java/sun-jdk/ChangeLog
index a38aa261341c..60a4cf87c821 100644
--- a/dev-java/sun-jdk/ChangeLog
+++ b/dev-java/sun-jdk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/sun-jdk
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.213 2007/09/27 16:57:21 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/ChangeLog,v 1.214 2007/10/04 14:25:37 betelgeuse Exp $
+
+*sun-jdk-1.4.2.16 (04 Oct 2007)
+
+ 04 Oct 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +sun-jdk-1.4.2.16.ebuild:
+ Version bump for security bug #194711.
*sun-jdk-1.6.0.03 (27 Sep 2007)
*sun-jdk-1.5.0.13 (27 Sep 2007)
diff --git a/dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.16 b/dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.16
new file mode 100644
index 000000000000..84224891b566
--- /dev/null
+++ b/dev-java/sun-jdk/files/digest-sun-jdk-1.4.2.16
@@ -0,0 +1,6 @@
+MD5 0978f40fcd6f1a790a58f5e2b77f978a j2sdk-1_4_2_16-linux-i586.bin 36397216
+RMD160 01652579112db12b431940da39bbd4a6ea4748f0 j2sdk-1_4_2_16-linux-i586.bin 36397216
+SHA256 0c1a60da479675e1b5054becc3df1c2604ef421ca8b2a4c353c00b333da0d144 j2sdk-1_4_2_16-linux-i586.bin 36397216
+MD5 ff961c5f5326191c5ac2e4624d756f7e jce_policy-1_4_2.zip 12195
+RMD160 323340fa8a96f315a35b0ebc918731e6fe56c370 jce_policy-1_4_2.zip 12195
+SHA256 7bf6d683602686321affc0071ad2fc3890c19cf5bb5cc16a963052e17588c097 jce_policy-1_4_2.zip 12195
diff --git a/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild b/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild
new file mode 100644
index 000000000000..96bf3eb37b92
--- /dev/null
+++ b/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jdk/sun-jdk-1.4.2.16.ebuild,v 1.1 2007/10/04 14:25:37 betelgeuse Exp $
+
+JAVA_SUPPORTS_GENERATION_1="true"
+inherit pax-utils java-vm-2 eutils
+
+MY_PV=${PV%.*}_${PV##*.}
+MY_P=j2sdk${MY_PV}
+MY_PVB=${PV%.*}
+
+At="j2sdk-${PV//./_}-linux-i586.bin"
+jce_policy="jce_policy-${MY_PVB//./_}.zip"
+
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Sun's J2SE Development Kit"
+HOMEPAGE="http://java.sun.com/j2se/1.4.2/"
+SRC_URI="x86? ( ${At} )
+ jce? ( ${jce_policy} )"
+SLOT="1.4"
+LICENSE="sun-bcla-java-vm"
+KEYWORDS="~x86"
+# files are prestripped
+RESTRICT="fetch strip"
+IUSE="X alsa doc examples nsplugin jce"
+
+DEPEND="sys-apps/sed
+ app-arch/unzip"
+
+RDEPEND="alsa? ( media-libs/alsa-lib )
+ doc? ( =dev-java/java-sdk-docs-1.4.2* )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )"
+
+JAVA_PROVIDE="jdbc-stdext"
+
+DOWNLOAD_URL="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=j2sdk-${MY_PV}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+DOWNLOAD_URL_JCE="http://javashoplm.sun.com/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=7503-jce-${MY_PVB}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/libawt.so
+ opt/${P}/jre/plugin/i386/ns4/libjavaplugin.so
+ opt/${P}/jre/plugin/i386/ns610/libjavaplugin_oji.so
+ opt/${P}/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so"
+
+pkg_nofetch() {
+ einfo "Please download ${At} from:"
+ einfo ${DOWNLOAD_URL}
+ einfo "(first select 'Accept License', then click on 'self-extracting file'"
+ einfo "under 'Linux Platform - Java(TM) 2 SDK, Standard Edition')"
+ einfo "and move it to ${DISTDIR}"
+ if use jce; then
+ echo
+ einfo "Also download ${jce_policy} from:"
+ einfo ${DOWNLOAD_URL_JCE}
+ einfo "Java(TM) Cryptography Extension (JCE) Unlimited Strength Jurisdiction Policy Files"
+ einfo "and move it to ${DISTDIR}"
+ fi
+}
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${At} ]; then
+ die "cannot read ${At}.bin. Please check the permission and try again."
+ fi
+ if use jce; then
+ if [ ! -r ${DISTDIR}/${jce_policy} ]; then
+ die "cannot read ${jce_policy}. Please check the permission and try again."
+ fi
+ fi
+ #Search for the ELF Header
+ testExp=$(echo -e '\0177\0105\0114\0106\0001\0001\0001')
+ startAt=`grep -aonm 1 ${testExp} ${DISTDIR}/${At} | cut -d: -f1`
+ tail -n +${startAt} ${DISTDIR}/${At} > install.sfx
+ chmod +x install.sfx
+ ./install.sfx || die
+ rm install.sfx
+
+ if [ -f ${S}/lib/unpack ]; then
+ UNPACK_CMD=${S}/lib/unpack
+ chmod +x $UNPACK_CMD
+ sed -i 's#/tmp/unpack.log#/dev/null\x00\x00\x00\x00\x00\x00#g' $UNPACK_CMD
+ local PACKED_JARS="lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar \
+ jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar \
+ jre/javaws/javaws.jar"
+ for i in $PACKED_JARS; do
+ PACK_FILE=${S}/`dirname $i`/`basename $i .jar`.pack
+ if [ -f ${PACK_FILE} ]; then
+ echo " unpacking: $i"
+ $UNPACK_CMD ${PACK_FILE} ${S}/$i
+ rm -f ${PACK_FILE}
+ fi
+ done
+ fi
+}
+
+src_install() {
+ local dirs="bin include jre lib man"
+ dodir /opt/${P}
+
+ cp -dPR ${dirs} "${D}/opt/${P}/"
+
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ pax-mark srpm $(list-paxables "${D}"/opt/${P}/{,/jre}/bin/*)
+
+ dodoc COPYRIGHT README LICENSE THIRDPARTYLICENSEREADME.txt || die
+ dohtml README.html || die
+ if use examples; then
+ cp -pPR demo ${D}/opt/${P}/ || die
+ fi
+
+ cp -pPR src.zip "${D}/opt/${P}/" || die
+
+ if use jce ; then
+ # Using unlimited jce while still retaining the strong jce
+ # May have repercussions when you find you cannot symlink libraries
+ # in classpaths.
+ cd ${D}/opt/${P}/jre/lib/security
+ unzip ${DISTDIR}/${jce_policy}
+ mv jce unlimited-jce
+ dodir /opt/${P}/jre/lib/security/strong-jce
+ mv ${D}/opt/${P}/jre/lib/security/US_export_policy.jar ${D}/opt/${P}/jre/lib/security/strong-jce
+ mv ${D}/opt/${P}/jre/lib/security/local_policy.jar ${D}/opt/${P}/jre/lib/security/strong-jce
+ dosym /opt/${P}/jre/lib/security/unlimited-jce/US_export_policy.jar /opt/${P}/jre/lib/security/
+ dosym /opt/${P}/jre/lib/security/unlimited-jce/local_policy.jar /opt/${P}/jre/lib/security/
+ fi
+
+ if use nsplugin; then
+ local plugin_dir="ns610"
+ if has_version '>=sys-devel/gcc-3.2' ; then
+ plugin_dir="ns610-gcc32"
+ fi
+
+ install_mozilla_plugin /opt/${P}/jre/plugin/i386/${plugin_dir}/libjavaplugin_oji.so
+ fi
+
+ # bug #147259
+ dosym ../jre/javaws/javaws /opt/${P}/bin/javaws
+ dosym ../javaws/javaws /opt/${P}/jre/bin/javaws
+
+ # create dir for system preferences
+ dodir /opt/${P}/.systemPrefs
+ # Create files used as storage for system preferences.
+ touch ${D}/opt/${P}/.systemPrefs/.system.lock
+ chmod 644 ${D}/opt/${P}/.systemPrefs/.system.lock
+ touch ${D}/opt/${P}/.systemPrefs/.systemRootModFile
+ chmod 644 ${D}/opt/${P}/.systemPrefs/.systemRootModFile
+
+ # install control panel for Gnome/KDE
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}\/jre/" \
+ -e "s/\(Name=Java\)/\1 Control Panel ${SLOT}/" \
+ ${D}/opt/${P}/jre/plugin/desktop/sun_java.desktop > \
+ ${T}/sun_java-${SLOT}.desktop
+
+ domenu ${T}/sun_java-${SLOT}.desktop
+
+ set_java_env
+}
+
+pkg_postinst() {
+ # Set as default VM if none exists
+ java-vm-2_pkg_postinst
+
+ if ! use X; then
+ ewarn "Some parts of Sun's JDK require X11 libraries to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+ fi
+ elog "Starting with 1.4.2.14 the src.zip is installed to the standard"
+ elog "location only (/opt/${P}/) and not /opt/${P}/share/"
+ elog "as we used to. See https://bugs.gentoo.org/show_bug.cgi?id=2241 and"
+ elog "http://java.sun.com/j2se/1.4.2/docs/tooldocs/linux/jdkfiles.html"
+ elog "for more details."
+}