summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2008-10-19 10:32:34 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2008-10-19 10:32:34 +0000
commit633de63aa0b7018f37844dc02a5caf50076a1e2e (patch)
tree0f9ff5fa49b539655f809092b90fbaa189726d5a /dev-java/tomcat-native/tomcat-native-1.1.15.ebuild
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-633de63aa0b7018f37844dc02a5caf50076a1e2e.tar.gz
gentoo-2-633de63aa0b7018f37844dc02a5caf50076a1e2e.tar.bz2
gentoo-2-633de63aa0b7018f37844dc02a5caf50076a1e2e.zip
Version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-java/tomcat-native/tomcat-native-1.1.15.ebuild')
-rw-r--r--dev-java/tomcat-native/tomcat-native-1.1.15.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-java/tomcat-native/tomcat-native-1.1.15.ebuild b/dev-java/tomcat-native/tomcat-native-1.1.15.ebuild
new file mode 100644
index 000000000000..bbfb4f173d35
--- /dev/null
+++ b/dev-java/tomcat-native/tomcat-native-1.1.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/tomcat-native/tomcat-native-1.1.15.ebuild,v 1.1 2008/10/19 10:32:34 fordfrog Exp $
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Native APR library for Tomcat"
+
+SLOT="0"
+SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${P}-src.tar.gz"
+HOMEPAGE="http://tomcat.apache.org/"
+KEYWORDS="~amd64 ~x86"
+LICENSE="Apache-2.0"
+IUSE=""
+
+RDEPEND="=dev-libs/apr-1*
+ dev-libs/openssl
+ >=virtual/jre-1.5"
+
+DEPEND=">=virtual/jdk-1.5
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P}-src
+
+src_compile(){
+ cd "${S}"/jni/native
+
+ econf --with-apr=/usr/bin/apr-1-config \
+ --with-ssl=/usr || die "Could not configure native sources"
+ emake || die "Could not build libtcnative-1.so"
+}
+
+src_install() {
+ cd "${S}"/jni/native
+ emake DESTDIR="${D}" install || die "Could not install libtcnative-1.so"
+}
+
+pkg_postinst() {
+ elog
+ elog " APR should be available with Tomcat, for more information"
+ elog " please see http://tomcat.apache.org/tomcat-6.0-doc/apr.html"
+ elog
+ elog " Please report any bugs to http://bugs.gentoo.org/"
+ elog
+}