summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-15 14:21:58 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-15 14:21:58 +0000
commit9db3cc142b61b49e5b0ab00c6f1d6963a3f633e0 (patch)
treecb6827a4bdab8d2e88224d2a67f368a19c9fd477 /dev-java/webgraph
parentVersion bumped. (diff)
downloadgentoo-2-9db3cc142b61b49e5b0ab00c6f1d6963a3f633e0.tar.gz
gentoo-2-9db3cc142b61b49e5b0ab00c6f1d6963a3f633e0.tar.bz2
gentoo-2-9db3cc142b61b49e5b0ab00c6f1d6963a3f633e0.zip
Dep/Style fixes
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/webgraph')
-rw-r--r--dev-java/webgraph/webgraph-1.4.1.ebuild18
-rw-r--r--dev-java/webgraph/webgraph-1.4.ebuild16
2 files changed, 17 insertions, 17 deletions
diff --git a/dev-java/webgraph/webgraph-1.4.1.ebuild b/dev-java/webgraph/webgraph-1.4.1.ebuild
index 54226a370f19..396e786d7708 100644
--- a/dev-java/webgraph/webgraph-1.4.1.ebuild
+++ b/dev-java/webgraph/webgraph-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/webgraph/webgraph-1.4.1.ebuild,v 1.1 2005/04/15 13:12:42 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/webgraph/webgraph-1.4.1.ebuild,v 1.2 2005/07/15 14:21:58 axxo Exp $
inherit eutils java-pkg
@@ -9,18 +9,19 @@ SRC_URI="http://webgraph.dsi.unimi.it/${P}-src.tar.gz"
HOMEPAGE="http://webgraph.dsi.unimi.it"
LICENSE="LGPL-2.1"
SLOT="1.4"
-KEYWORDS="~x86 ~ppc ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc jikes source"
-DEPEND=">=virtual/jdk-1.4
- >=dev-java/jal-20031117
- jikes? ( dev-java/jikes )
- source? ( app-arch/zip )"
RDEPEND=">=virtual/jre-1.4
=dev-java/java-getopt-1.0*
=dev-java/fastutil-4.4*
=dev-java/colt-1.1*
+ >=dev-java/jal-20031117
=dev-java/mg4j-0.9*"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
src_unpack() {
unpack ${A}
@@ -44,11 +45,10 @@ src_compile() {
}
src_install() {
- mv ${P}.jar ${PN}.jar
- java-pkg_dojar ${PN}.jar
+ java-pkg_newjar ${P}.jar ${PN}.jar
if use doc; then
- dodoc CHANGES COPYING
+ dodoc CHANGES
java-pkg_dohtml -r docs/*
fi
use source && java-pkg_dosrc java/it
diff --git a/dev-java/webgraph/webgraph-1.4.ebuild b/dev-java/webgraph/webgraph-1.4.ebuild
index 5373180aaf61..78707977a91d 100644
--- a/dev-java/webgraph/webgraph-1.4.ebuild
+++ b/dev-java/webgraph/webgraph-1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/webgraph/webgraph-1.4.ebuild,v 1.3 2005/04/15 13:12:42 luckyduck Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/webgraph/webgraph-1.4.ebuild,v 1.4 2005/07/15 14:21:58 axxo Exp $
inherit eutils java-pkg
@@ -9,18 +9,19 @@ SRC_URI="http://webgraph.dsi.unimi.it/${P}-src.tar.gz"
HOMEPAGE="http://webgraph.dsi.unimi.it"
LICENSE="LGPL-2.1"
SLOT="1.4"
-KEYWORDS="x86 ~ppc amd64"
+KEYWORDS="amd64 ~ppc x86"
IUSE="doc jikes source"
-DEPEND=">=virtual/jdk-1.4
- >=dev-java/jal-20031117
- jikes? ( dev-java/jikes )
- source? ( app-arch/zip )"
RDEPEND=">=virtual/jre-1.4
=dev-java/java-getopt-1.0*
=dev-java/fastutil-4.3*
=dev-java/colt-1.1*
+ >=dev-java/jal-20031117
=dev-java/mg4j-0.9*"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ jikes? ( dev-java/jikes )
+ source? ( app-arch/zip )"
src_unpack() {
unpack ${A}
@@ -44,8 +45,7 @@ src_compile() {
}
src_install() {
- mv ${P}.jar ${PN}.jar
- java-pkg_dojar ${PN}.jar
+ java-pkg_newjar ${P}.jar ${PN}.jar
if use doc; then
dodoc CHANGES