summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-09-08 05:26:02 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-09-08 05:26:02 +0000
commitdc1393ebeee880213b0881dfedbcedd1f39248d5 (patch)
tree8f28081d9c868dbb31cf8713fac7c5f7afafb5b2 /dev-java/xdoclet
parentStable x86, interesting application (diff)
downloadgentoo-2-dc1393ebeee880213b0881dfedbcedd1f39248d5.tar.gz
gentoo-2-dc1393ebeee880213b0881dfedbcedd1f39248d5.tar.bz2
gentoo-2-dc1393ebeee880213b0881dfedbcedd1f39248d5.zip
Removed inheriting of java-ant-2, because the build.xml files use entities, which the eclass doesn\'t support rewritting of. Applies a patch instead. This addresses bug #144787. Also added missing ant-core and junit jars, which fixes building with java-strict.
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'dev-java/xdoclet')
-rw-r--r--dev-java/xdoclet/ChangeLog9
-rw-r--r--dev-java/xdoclet/files/xdoclet-1.2.3-fix_javac.patch112
-rw-r--r--dev-java/xdoclet/xdoclet-1.2.3.ebuild18
3 files changed, 134 insertions, 5 deletions
diff --git a/dev-java/xdoclet/ChangeLog b/dev-java/xdoclet/ChangeLog
index 7e1318dbbcba..61b873e285cb 100644
--- a/dev-java/xdoclet/ChangeLog
+++ b/dev-java/xdoclet/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/xdoclet
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xdoclet/ChangeLog,v 1.20 2006/07/29 15:49:15 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xdoclet/ChangeLog,v 1.21 2006/09/08 05:26:02 nichoj Exp $
+
+ 08 Sep 2006; Joshua Nichols <nichoj@gentoo.org>
+ +files/xdoclet-1.2.3-fix_javac.patch, xdoclet-1.2.3.ebuild:
+ Removed inheriting of java-ant-2, because the build.xml files use entities,
+ which the eclass doesn't support rewritting of. Applies a patch instead.
+ This addresses bug #144787. Also added missing ant-core and junit jars,
+ which fixes building with java-strict.
29 Jul 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+files/xdoclet-1.2.3-buildfile.patch,
diff --git a/dev-java/xdoclet/files/xdoclet-1.2.3-fix_javac.patch b/dev-java/xdoclet/files/xdoclet-1.2.3-fix_javac.patch
new file mode 100644
index 000000000000..524ca67d0fdc
--- /dev/null
+++ b/dev-java/xdoclet/files/xdoclet-1.2.3-fix_javac.patch
@@ -0,0 +1,112 @@
+Only in xdoclet-1.2.3-patched/core: .build.xml.swp
+diff -ru xdoclet-1.2.3/core/build.xml xdoclet-1.2.3-patched/core/build.xml
+--- xdoclet-1.2.3/core/build.xml 2003-10-08 19:41:29.000000000 -0400
++++ xdoclet-1.2.3-patched/core/build.xml 2006-09-08 01:04:25.000000000 -0400
+@@ -118,6 +118,8 @@
+ <javac
+ destdir="${core.classes.dir}"
+ classpathref="core.class.path"
++ target="1.3"
++ source="1.3"
+ debug="${compile.debug}"
+ deprecation="${compile.deprecation}"
+ optimize="${compile.optimize}"
+diff -ru xdoclet-1.2.3/core/test/build.xml xdoclet-1.2.3-patched/core/test/build.xml
+--- xdoclet-1.2.3/core/test/build.xml 2002-09-08 14:07:11.000000000 -0400
++++ xdoclet-1.2.3-patched/core/test/build.xml 2006-09-08 00:43:31.000000000 -0400
+@@ -156,6 +156,8 @@
+
+ <javac
+ destdir="${ejb.classes.dir}"
++ target="1.3"
++ source="1.3"
+ debug="on">
+
+ <classpath refid="testsuite.class.path" />
+@@ -170,7 +172,11 @@
+ </target>
+
+ <target name="unittest-ejb">
+- <javac destdir="${build.dir}/junit/classes" debug="on">
++ <javac
++ destdir="${build.dir}/junit/classes"
++ target="1.3"
++ source="1.3"
++ debug="on">
+ <classpath refid="testsuite.class.path" />
+ <src path="${java.dir}"/>
+
+@@ -208,7 +214,11 @@
+
+ <target name="test-xdoclet" depends="prepare">
+
+- <javac destdir="${build.dir}/junit/classes" debug="on">
++ <javac
++ destdir="${build.dir}/junit/classes"
++ target="1.3"
++ source="1.3"
++ debug="on">
+ <classpath refid="testsuite.class.path" />
+ <src path="${java.dir}"/>
+
+@@ -316,6 +326,8 @@
+ srcdir="${java.dir};${generated.java.dir}"
+ destdir="${build.dir}/web/WEB-INF/classes"
+ includes="xdoclet/retest/bean/web/*.java"
++ target="1.3"
++ source="1.3"
+ debug="on">
+
+ <classpath refid="testsuite.class.path" />
+@@ -325,6 +337,8 @@
+ srcdir="${java.dir};${generated.java.dir}"
+ destdir="${build.dir}/jmx"
+ includes="xdoclet/retest/bean/jmx/*.java"
++ target="1.3"
++ source="1.3"
+ debug="on">
+
+ <classpath refid="testsuite.class.path" />
+diff -ru xdoclet-1.2.3/modules/mockobjects/build-orig.xml xdoclet-1.2.3-patched/modules/mockobjects/build-orig.xml
+--- xdoclet-1.2.3/modules/mockobjects/build-orig.xml 2003-02-05 20:46:10.000000000 -0500
++++ xdoclet-1.2.3-patched/modules/mockobjects/build-orig.xml 2006-09-08 00:44:14.000000000 -0400
+@@ -30,7 +30,7 @@
+
+ <target name="compile" description="Compile classes">
+ <mkdir dir="target/classes" />
+- <javac srcdir="src/main;src/test" destdir="target/classes" classpathref="classpath" />
++ <javac srcdir="src/main;src/test" destdir="target/classes" classpathref="classpath" source="1.3" target="1.3"/>
+ <copy todir="target/classes">
+ <fileset dir="src/main">
+ <include name="**/*.j"/>
+@@ -62,4 +62,4 @@
+ <delete dir="src/test" />
+ </target>
+
+-</project>
+\ No newline at end of file
++</project>
+diff -ru xdoclet-1.2.3/modules/mockobjects/build.xml xdoclet-1.2.3-patched/modules/mockobjects/build.xml
+--- xdoclet-1.2.3/modules/mockobjects/build.xml 2003-02-05 20:46:10.000000000 -0500
++++ xdoclet-1.2.3-patched/modules/mockobjects/build.xml 2006-09-08 00:43:54.000000000 -0400
+@@ -40,6 +40,8 @@
+
+ <javac srcdir="${mockobjects.sample.src};${mockobjects.src}"
+ destdir="${mockobjects.sample.classes}"
++ source="1.3"
++ target="1.3"
+ classpathref="mockobjects.class.path"/>
+
+ </target>
+diff -ru xdoclet-1.2.3/modules/modules-common.ent xdoclet-1.2.3-patched/modules/modules-common.ent
+--- xdoclet-1.2.3/modules/modules-common.ent 2005-04-15 20:02:14.000000000 -0400
++++ xdoclet-1.2.3-patched/modules/modules-common.ent 2006-09-08 00:44:53.000000000 -0400
+@@ -198,6 +198,8 @@
+ debug="${compile.debug}"
+ deprecation="${compile.deprecation}"
+ optimize="${compile.optimize}"
++ source="1.3"
++ target="1.3"
+ >
+ <src path="${module.src.dir}"/>
+ </javac>
diff --git a/dev-java/xdoclet/xdoclet-1.2.3.ebuild b/dev-java/xdoclet/xdoclet-1.2.3.ebuild
index e74362bbae86..fc54d223ba3a 100644
--- a/dev-java/xdoclet/xdoclet-1.2.3.ebuild
+++ b/dev-java/xdoclet/xdoclet-1.2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xdoclet/xdoclet-1.2.3.ebuild,v 1.1 2006/07/23 09:11:46 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xdoclet/xdoclet-1.2.3.ebuild,v 1.2 2006/09/08 05:26:02 nichoj Exp $
-inherit java-pkg-2 java-ant-2 eutils
+inherit java-pkg-2 eutils
DESCRIPTION="XDoclet is an extended Javadoc Doclet engine."
HOMEPAGE="http://xdoclet.sf.net/"
@@ -19,7 +19,8 @@ RDEPEND=">=virtual/jre-1.3
dev-java/log4j
dev-java/mockobjects
dev-java/velocity
- dev-java/xjavadoc"
+ dev-java/xjavadoc
+ dev-java/junit"
DEPEND=">=virtual/jdk-1.3
${RDEPEND}
dev-java/ant
@@ -31,6 +32,11 @@ src_unpack() {
cd ${S}
epatch ${FILESDIR}/${P}-interface.patch
epatch ${FILESDIR}/${P}-buildfile.patch
+ # Fix javac tasks to have source="1.3" target="1.3"
+ # because using xml-rewrite.py from java-ant-2 breaks the build,
+ # because it doesn't support entities
+ # TODO file upstream. Perhaps cleanup patch to use ant properties.
+ epatch ${FILESDIR}/${P}-fix_javac.patch
cd ${S}/lib && rm -f *.jar
java-pkg_jar-from xjavadoc
@@ -41,11 +47,15 @@ src_unpack() {
java-pkg_jar-from commons-logging
java-pkg_jar-from commons-collections
java-pkg_jar-from velocity
+ java-pkg_jar-from ant-core ant.jar
+ java-pkg_jar-from junit
}
+# TODO investigate why compiling needs junit, ie is build not sane enough to
+# devide building of test classes separate from rest of classes?
src_compile() {
local antflags="core modules maven"
- eant ${antflags} || die "Failed to compile XDoclet core."
+ eant ${antflags}
}
src_install() {