summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-09-18 22:17:53 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-09-18 22:17:53 +0000
commitb222ac9d22a1405c02e65e8ab30a9fae55649c4e (patch)
tree057cd983bc32d814fd48c78643f208536331f3c8 /dev-java/xmlgraphics-commons
parentgpodder version bump (diff)
downloadgentoo-2-b222ac9d22a1405c02e65e8ab30a9fae55649c4e.tar.gz
gentoo-2-b222ac9d22a1405c02e65e8ab30a9fae55649c4e.tar.bz2
gentoo-2-b222ac9d22a1405c02e65e8ab30a9fae55649c4e.zip
Version bump.
(Portage version: 2.1.3.7)
Diffstat (limited to 'dev-java/xmlgraphics-commons')
-rw-r--r--dev-java/xmlgraphics-commons/ChangeLog8
-rw-r--r--dev-java/xmlgraphics-commons/files/digest-xmlgraphics-commons-1.23
-rw-r--r--dev-java/xmlgraphics-commons/xmlgraphics-commons-1.2.ebuild81
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-java/xmlgraphics-commons/ChangeLog b/dev-java/xmlgraphics-commons/ChangeLog
index d612a1ac45a8..fe1039a22f79 100644
--- a/dev-java/xmlgraphics-commons/ChangeLog
+++ b/dev-java/xmlgraphics-commons/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/xmlgraphics-commons
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/ChangeLog,v 1.7 2007/08/21 05:08:26 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/ChangeLog,v 1.8 2007/09/18 22:17:53 betelgeuse Exp $
+
+*xmlgraphics-commons-1.2 (18 Sep 2007)
+
+ 18 Sep 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +xmlgraphics-commons-1.2.ebuild:
+ Version bump.
21 Aug 2007; William L. Thomson Jr. <wltjr@gentoo.org>
xmlgraphics-commons-1.1.ebuild:
diff --git a/dev-java/xmlgraphics-commons/files/digest-xmlgraphics-commons-1.2 b/dev-java/xmlgraphics-commons/files/digest-xmlgraphics-commons-1.2
new file mode 100644
index 000000000000..91db0893bb23
--- /dev/null
+++ b/dev-java/xmlgraphics-commons/files/digest-xmlgraphics-commons-1.2
@@ -0,0 +1,3 @@
+MD5 d3cf738e3ef890bb1a1b1668ad4054ff xmlgraphics-commons-1.2-src.tar.gz 430083
+RMD160 d04f39242d95f9fd3ef307d8c483bcec35bdc2dd xmlgraphics-commons-1.2-src.tar.gz 430083
+SHA256 1588fe182e62d3f3cf7c2acb7d0989b7134b94c95580256e4fe1b9c5e3a38663 xmlgraphics-commons-1.2-src.tar.gz 430083
diff --git a/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.2.ebuild b/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.2.ebuild
new file mode 100644
index 000000000000..ad3660b1d78c
--- /dev/null
+++ b/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.2.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlgraphics-commons/xmlgraphics-commons-1.2.ebuild,v 1.1 2007/09/18 22:17:53 betelgeuse Exp $
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A library of several reusable components used by Apache Batik and Apache FOP."
+HOMEPAGE="http://xmlgraphics.apache.org/commons/index.html"
+SRC_URI="mirror://apache/xmlgraphics/commons/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="jpeg"
+
+# fails connect to X even tho it sets java.awt.headless
+RESTRICT="test"
+CDEPEND=">=dev-java/commons-io-1"
+DEPEND=">=virtual/jdk-1.4
+ jpeg? (
+ || (
+ >=dev-java/sun-jdk-1.4
+ >=dev-java/blackdown-jdk-1.4
+ >=dev-java/ibm-jdk-bin-1.4
+ >=dev-java/jrockit-jdk-bin-1.4
+ )
+ )
+ test? (
+ dev-java/ant-junit
+ )
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.4
+ ${CDEPEND}"
+
+# TODO investigate producing .net libraries
+# stratigies for non sun jdk's/jre's
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ if use jpeg && java-pkg_current-vm-matches kaffe; then
+ eerror "Sun-private JPEG support cannot be built with kaffe."
+ eerror "Please set your build VM to Sun, Blackdown, IBM or JRockit JDK."
+ eerror "See http://www.gentoo.org/doc/en/java.xml for details."
+ eerror "Alternatively, install this package with USE=-jpeg"
+ die "Cannot build with USE=jpeg and kaffe."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # automagic bad
+ java-ant_ignore-system-classes || die
+
+ cd ${S}/lib || die
+ rm -v *.jar || die
+
+ java-pkg_jarfrom commons-io-1
+}
+
+src_compile() {
+ local af="-Djdk14.present=true"
+ use jpeg && af="${af} -Dsun.jpeg.present=true"
+ eant ${af} jar-main $(use_doc javadocs)
+}
+
+src_test() {
+ java-pkg_jarfrom --into lib junit
+ # probably needs ${af} from src_compile, doesn't work anyway
+ ANT_TASKS="ant-junit" eant -Djunit.present=true junit
+}
+
+src_install(){
+ java-pkg_newjar build/${P}.jar
+ use source && java-pkg_dosrc src/java/org src/java-1.4/org
+ use doc && java-pkg_dojavadoc build/javadocs
+}