summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2007-02-09 23:27:50 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2007-02-09 23:27:50 +0000
commitc67d7238fef21c42bdacb2059ccb196fdd89cc54 (patch)
tree7dc42e54054b0f3ce0021c42832441687d2c390e /dev-java/xmlunit
parentAdded ~x86-fbsd keyword. (diff)
downloadgentoo-2-c67d7238fef21c42bdacb2059ccb196fdd89cc54.tar.gz
gentoo-2-c67d7238fef21c42bdacb2059ccb196fdd89cc54.tar.bz2
gentoo-2-c67d7238fef21c42bdacb2059ccb196fdd89cc54.zip
Migrated to generation-2.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'dev-java/xmlunit')
-rw-r--r--dev-java/xmlunit/ChangeLog8
-rw-r--r--dev-java/xmlunit/files/digest-xmlunit-1.0-r23
-rw-r--r--dev-java/xmlunit/files/xmlunit-1.0-r2-build.xml.patch22
-rw-r--r--dev-java/xmlunit/xmlunit-1.0-r2.ebuild56
4 files changed, 88 insertions, 1 deletions
diff --git a/dev-java/xmlunit/ChangeLog b/dev-java/xmlunit/ChangeLog
index 79723b26165d..e238711640ef 100644
--- a/dev-java/xmlunit/ChangeLog
+++ b/dev-java/xmlunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/xmlunit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlunit/ChangeLog,v 1.7 2007/02/09 02:14:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlunit/ChangeLog,v 1.8 2007/02/09 23:27:50 fordfrog Exp $
+
+*xmlunit-1.0-r2 (09 Feb 2007)
+
+ 09 Feb 2007; Miroslav Šulc <fordfrog@gentoo.org>
+ +files/xmlunit-1.0-r2-build.xml.patch, +xmlunit-1.0-r2.ebuild:
+ Migrated to generation-2.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/dev-java/xmlunit/files/digest-xmlunit-1.0-r2 b/dev-java/xmlunit/files/digest-xmlunit-1.0-r2
new file mode 100644
index 000000000000..2889bf7befbe
--- /dev/null
+++ b/dev-java/xmlunit/files/digest-xmlunit-1.0-r2
@@ -0,0 +1,3 @@
+MD5 4f03206acc9ed18bc6cc23fd38b4fc82 xmlunit1.0.zip 421131
+RMD160 1cac117a5fb857f052d90731e110ce56f2bf78a1 xmlunit1.0.zip 421131
+SHA256 da85e544011fa0499b74ae9363a5130cc34c27a92349521bc4b6f25832ddee81 xmlunit1.0.zip 421131
diff --git a/dev-java/xmlunit/files/xmlunit-1.0-r2-build.xml.patch b/dev-java/xmlunit/files/xmlunit-1.0-r2-build.xml.patch
new file mode 100644
index 000000000000..c3875cd15d1d
--- /dev/null
+++ b/dev-java/xmlunit/files/xmlunit-1.0-r2-build.xml.patch
@@ -0,0 +1,22 @@
+--- build.xml.original 2007-01-30 14:55:01.000000000 +0100
++++ build.xml 2007-01-30 20:12:02.000000000 +0100
+@@ -34,9 +34,9 @@
+ </javac>
+ </target>
+
+- <target name="test" depends="clean,compile">
++ <target name="test" depends="compile">
+ <mkdir dir="${test.report.dir}"/>
+- <junit printsummary="yes" haltonfailure="no" fork="yes">
++ <junit printsummary="yes" haltonfailure="yes" fork="yes">
+ <sysproperty key="basedir" value="${basedir}"/>
+ <sysproperty key="user.dir" value="${basedir}"/>
+ <!--
+@@ -78,7 +78,6 @@
+ <mkdir dir="${docs.dir}"/>
+ <delete includeEmptyDirs="true" dir="${docs.dir}/org"/>
+ <javadoc destdir="${docs.dir}"
+- overview="${src.dir}/java/overview.html"
+ windowtitle="XMLUnit Documentation"
+ footer="&lt;p&gt;&lt;a href=&quot;http://xmlunit.sourceforge.net/&quot;&gt;XMLUnit&lt;/a&gt; is hosted by sourceforge.net&lt;/p&gt;">
+ <group title="XMLUnit v${xmlunit.version}"
diff --git a/dev-java/xmlunit/xmlunit-1.0-r2.ebuild b/dev-java/xmlunit/xmlunit-1.0-r2.ebuild
new file mode 100644
index 000000000000..1830457b84b6
--- /dev/null
+++ b/dev-java/xmlunit/xmlunit-1.0-r2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xmlunit/xmlunit-1.0-r2.ebuild,v 1.1 2007/02/09 23:27:50 fordfrog Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="XMLUnit extends JUnit and NUnit to enable unit testing of XML."
+SRC_URI="mirror://sourceforge/${PN}/${P/-/}.zip"
+HOMEPAGE="http://xmlunit.sourceforge.net/"
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+# We depend on jdk-1.4 as tests fail with jdk > 1.4
+# see http://sourceforge.net/tracker/index.php?func=detail&aid=1614984&group_id=23187&atid=377768
+# Also docs cannot be built with jdk > 1.5
+DEPEND="=virtual/jdk-1.4*
+ >=app-arch/unzip-5.50-r1
+ test? (
+ >=dev-java/ant-1.6
+ =dev-java/junit-3.8*
+ dev-java/xalan
+ )
+ !test? ( >=dev-java/ant-core-1.6 )
+ source? ( app-arch/zip )"
+RDEPEND="=virtual/jre-1.4*"
+EANT_BUILD_TARGET="jar"
+EANT_DOC_TARGET="docs"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-${PVR}-build.xml.patch
+ rm -f ${S}/lib/*.jar
+}
+
+src_test() {
+ eant test
+}
+
+src_install() {
+ java-pkg_newjar lib/${PN}${PV}.jar ${PN}.jar
+
+ dodoc README.txt
+ use doc && java-pkg_dojavadoc doc
+ use source && java-pkg_dosrc src/java/*
+}
+
+pkg_postinst() {
+ elog "Please note that ${PN} has some problems with JDKs > 1.4. For details see:"
+ elog "http://sourceforge.net/tracker/index.php?func=detail&aid=1614984&group_id=23187&atid=377768"
+}