summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSerkan Kaba <serkan@gentoo.org>2011-09-25 09:21:35 +0000
committerSerkan Kaba <serkan@gentoo.org>2011-09-25 09:21:35 +0000
commit1e06f2be10f0c8df06b765ab7f74786b5d3d98c5 (patch)
tree36d87f0d7d10c640f7221c2dc49d7bac709435c6 /dev-java
parentFixed for Prefix, marked ~ppc-macos and ~x86-macos (diff)
downloadgentoo-2-1e06f2be10f0c8df06b765ab7f74786b5d3d98c5.tar.gz
gentoo-2-1e06f2be10f0c8df06b765ab7f74786b5d3d98c5.tar.bz2
gentoo-2-1e06f2be10f0c8df06b765ab7f74786b5d3d98c5.zip
Rename date tagged version as a pre and version bump
(Portage version: 2.2.0_alpha58/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/json-simple/ChangeLog13
-rw-r--r--dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch48
-rw-r--r--dev-java/json-simple/json-simple-1.0_pre20080420.ebuild (renamed from dev-java/json-simple/json-simple-20080420.ebuild)5
-rw-r--r--dev-java/json-simple/json-simple-1.1.ebuild48
4 files changed, 110 insertions, 4 deletions
diff --git a/dev-java/json-simple/ChangeLog b/dev-java/json-simple/ChangeLog
index 155551ab5a8c..df22e9343e4a 100644
--- a/dev-java/json-simple/ChangeLog
+++ b/dev-java/json-simple/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-java/json-simple
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/json-simple/ChangeLog,v 1.9 2009/03/20 19:47:00 josejx Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/json-simple/ChangeLog,v 1.10 2011/09/25 09:21:35 serkan Exp $
+
+*json-simple-1.1 (25 Sep 2011)
+*json-simple-1.0_pre20080420 (25 Sep 2011)
+
+ 25 Sep 2011; Serkan Kaba <serkan@gentoo.org>
+ +json-simple-1.0_pre20080420.ebuild, +json-simple-1.1.ebuild,
+ +files/json-simple-1.1-extra-constructors-from-azureus.patch,
+ -json-simple-20080420.ebuild:
+ Rename date tagged version as a pre and version bump
20 Mar 2009; Joseph Jezak <josejx@gentoo.org> json-simple-20080420.ebuild:
Marked ppc stable.
diff --git a/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch b/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch
new file mode 100644
index 000000000000..5b45a973e41d
--- /dev/null
+++ b/dev-java/json-simple/files/json-simple-1.1-extra-constructors-from-azureus.patch
@@ -0,0 +1,48 @@
+diff -Nur json_simple-1.1-all/src/org/json/simple/JSONArray.java json_simple-1.1-all_patched//src/org/json/simple/JSONArray.java
+--- json_simple-1.1-all/src/org/json/simple/JSONArray.java 2009-02-01 12:45:34.000000000 +0200
++++ json_simple-1.1-all_patched//src/org/json/simple/JSONArray.java 2011-09-25 11:23:37.398818358 +0300
+@@ -19,6 +19,18 @@
+ public class JSONArray extends ArrayList implements List, JSONAware, JSONStreamAware {
+ private static final long serialVersionUID = 3957988303675231981L;
+
++ public JSONArray() {
++ super();
++ }
++
++ public JSONArray(java.util.Collection arg0) {
++ super(arg0);
++ }
++
++ public JSONArray(int initialCapacity) {
++ super(initialCapacity);
++ }
++
+ /**
+ * Encode a list into JSON text and write it to out.
+ * If this list is also a JSONStreamAware or a JSONAware, JSONStreamAware and JSONAware specific behaviours will be ignored at this top level.
+diff -Nur json_simple-1.1-all/src/org/json/simple/JSONObject.java json_simple-1.1-all_patched//src/org/json/simple/JSONObject.java
+--- json_simple-1.1-all/src/org/json/simple/JSONObject.java 2009-02-01 12:45:34.000000000 +0200
++++ json_simple-1.1-all_patched//src/org/json/simple/JSONObject.java 2011-09-25 11:24:34.815103065 +0300
+@@ -18,6 +18,22 @@
+ public class JSONObject extends HashMap implements Map, JSONAware, JSONStreamAware{
+ private static final long serialVersionUID = -503443796854799292L;
+
++ public JSONObject() {
++ super();
++ }
++
++ public JSONObject(int initialCapacity, float loadFactor) {
++ super(initialCapacity, loadFactor);
++ }
++
++ public JSONObject(int initialCapacity) {
++ super(initialCapacity);
++ }
++
++ public JSONObject(Map arg0) {
++ super(arg0);
++ }
++
+ /**
+ * Encode a map into JSON text and write it to out.
+ * If this map is also a JSONAware or JSONStreamAware, JSONAware or JSONStreamAware specific behaviours will be ignored at this top level.
diff --git a/dev-java/json-simple/json-simple-20080420.ebuild b/dev-java/json-simple/json-simple-1.0_pre20080420.ebuild
index 80b5e73b5118..15f9e2d60207 100644
--- a/dev-java/json-simple/json-simple-20080420.ebuild
+++ b/dev-java/json-simple/json-simple-1.0_pre20080420.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/json-simple/json-simple-20080420.ebuild,v 1.7 2009/03/20 19:47:00 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/json-simple/json-simple-1.0_pre20080420.ebuild,v 1.1 2011/09/25 09:21:35 serkan Exp $
JAVA_PKG_IUSE="doc source"
@@ -17,6 +17,7 @@ SRC_URI="mirror://gentoo/${MY_PN}-20080420.zip"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
DEPEND=">=virtual/jdk-1.4
app-arch/unzip"
diff --git a/dev-java/json-simple/json-simple-1.1.ebuild b/dev-java/json-simple/json-simple-1.1.ebuild
new file mode 100644
index 000000000000..9e3c88bef68d
--- /dev/null
+++ b/dev-java/json-simple/json-simple-1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/json-simple/json-simple-1.1.ebuild,v 1.1 2011/09/25 09:21:35 serkan Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Simple Java toolkit for JSON"
+HOMEPAGE="http://www.json.org"
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}-all"
+SRC_URI="http://json-simple.googlecode.com/files/${MY_P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit )
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.4"
+
+S="${WORKDIR}/${MY_P}"
+
+java_prepare() {
+ epatch "${FILESDIR}/${P}-extra-constructors-from-azureus.patch"
+ rm -rv build lib || die
+}
+
+#JAVA_ANT_ENCODING="ISO-8859-1"
+#EANT_BUILD_TARGET="dist"
+
+JAVA_PKG_BSFIX_NAME+=" test.xml"
+
+src_test() {
+ java-pkg_jar-from --into lib junit
+ ANT_TASKS="ant-junit" eant -f test.xml
+}
+
+src_install() {
+ java-pkg_newjar lib/${MY_P/-all/}.jar ${PN}.jar
+ dodoc README.txt AUTHORS.txt ChangeLog.txt || die
+ use source && java-pkg_dosrc src/org
+}