summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-03-28 13:20:38 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-03-28 13:20:38 +0000
commit1f820aafa803befd35037cf9d3c2a3f7a1ef6207 (patch)
tree3cb03171a3de440f19c87aba1fb062b4c1d12025 /dev-java
parentVersion bump. (diff)
downloadgentoo-2-1f820aafa803befd35037cf9d3c2a3f7a1ef6207.tar.gz
gentoo-2-1f820aafa803befd35037cf9d3c2a3f7a1ef6207.tar.bz2
gentoo-2-1f820aafa803befd35037cf9d3c2a3f7a1ef6207.zip
Version bump to 1.8.0.0; for bug #505040, reported by wevrn5, contribution by Krzysztof Miksa, reviewed and adjusted.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/java-sdk-docs/ChangeLog8
-rw-r--r--dev-java/java-sdk-docs/java-sdk-docs-1.8.0.0.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-java/java-sdk-docs/ChangeLog b/dev-java/java-sdk-docs/ChangeLog
index 29f38aa533aa..75a1c222ddd6 100644
--- a/dev-java/java-sdk-docs/ChangeLog
+++ b/dev-java/java-sdk-docs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/java-sdk-docs
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.96 2014/02/26 17:27:08 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/ChangeLog,v 1.97 2014/03/28 13:20:38 tomwij Exp $
+
+*java-sdk-docs-1.8.0.0 (28 Mar 2014)
+
+ 28 Mar 2014; Tom Wijsman <TomWij@gentoo.org> +java-sdk-docs-1.8.0.0.ebuild:
+ Version bump to 1.8.0.0; for bug #505040, reported by wevrn5, contribution by
+ Krzysztof Miksa, reviewed and adjusted.
*java-sdk-docs-1.7.0.51 (26 Feb 2014)
diff --git a/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.0.ebuild b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.0.ebuild
new file mode 100644
index 000000000000..4c3490857227
--- /dev/null
+++ b/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-sdk-docs/java-sdk-docs-1.8.0.0.ebuild,v 1.1 2014/03/28 13:20:38 tomwij Exp $
+
+EAPI="5"
+
+inherit versionator
+
+DOWNLOAD_URL="http://www.oracle.com/technetwork/java/javase/documentation/jdk8-doc-downloads-2133158.html"
+
+[[ "$(get_version_component_range 4)" == 0 ]] \
+ || MY_PV_EXT="u$(get_version_component_range 4)"
+
+MY_PV="$(get_version_component_range 2)${MY_PV_EXT}"
+ORIG_NAME="jdk-${MY_PV}-apidocs.zip"
+
+DESCRIPTION="Oracle's documentation bundle (including API) for Java SE"
+HOMEPAGE="http://download.oracle.com/javase/8/docs/"
+SRC_URI="${ORIG_NAME}"
+
+LICENSE="oracle-java-documentation-8"
+SLOT="1.8"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="app-arch/unzip:0"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/docs"
+
+pkg_nofetch() {
+ einfo "Please download ${ORIG_NAME} from "
+ einfo "${DOWNLOAD_URL}"
+ einfo "(agree to the license) and place it in ${DISTDIR}"
+
+ einfo "If you find the file on the download page replaced with a higher"
+ einfo "version, please report to the bug 67266 (link below)."
+ einfo "If emerge fails because of a checksum error it is possible that"
+ einfo "the upstream release changed without renaming. Try downloading the file"
+ einfo "again (or a newer revision if available). Otherwise report this to"
+ einfo "http://bugs.gentoo.org/67266 and we will make a new revision."
+}
+
+src_install(){
+ insinto /usr/share/doc/${P}/html
+ doins index.html
+
+ for i in *; do
+ [[ -d $i ]] && doins -r $i
+ done
+}