summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2012-10-14 14:28:48 +0000
committerRalph Sennhauser <sera@gentoo.org>2012-10-14 14:28:48 +0000
commit436a45a5b7498ed8da562e36b7865ff313d5d167 (patch)
treefd416f2788d05f70507db2abc915b4bb36208fc4 /dev-java
parentdev-tcltk/tkXwin: Export AR and RANLIB as well, thanks Vicente Olivert Riera (diff)
downloadgentoo-2-436a45a5b7498ed8da562e36b7865ff313d5d167.tar.gz
gentoo-2-436a45a5b7498ed8da562e36b7865ff313d5d167.tar.bz2
gentoo-2-436a45a5b7498ed8da562e36b7865ff313d5d167.zip
EAPI and version bump by Ivan Baidakou <the.dmol@gmail.com> with some changes by me. #426384
(Portage version: 2.1.11.23/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jaxen/ChangeLog9
-rw-r--r--dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml201
-rw-r--r--dev-java/jaxen/jaxen-1.1.4.ebuild48
3 files changed, 257 insertions, 1 deletions
diff --git a/dev-java/jaxen/ChangeLog b/dev-java/jaxen/ChangeLog
index 4de7d2cba96b..f0ea54d30b75 100644
--- a/dev-java/jaxen/ChangeLog
+++ b/dev-java/jaxen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/jaxen
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jaxen/ChangeLog,v 1.54 2012/04/15 18:41:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jaxen/ChangeLog,v 1.55 2012/10/14 14:28:48 sera Exp $
+
+*jaxen-1.1.4 (14 Oct 2012)
+
+ 14 Oct 2012; Ralph Sennhauser <sera@gentoo.org> +jaxen-1.1.4.ebuild,
+ +files/jaxen-1.1.4_maven1-build.xml:
+ EAPI and version bump by Ivan Baidakou <the.dmol@gmail.com> with some changes
+ by me. #426384
15 Apr 2012; Mike Frysinger <vapier@gentoo.org> jaxen-1.1.1.ebuild:
Add back ia64 love #349020 by Dennis Schridde.
diff --git a/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
new file mode 100644
index 000000000000..ab658736c463
--- /dev/null
+++ b/dev-java/jaxen/files/jaxen-1.1.4_maven1-build.xml
@@ -0,0 +1,201 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!--build.xml generated by maven from project.xml version 1.1.4
+ on date October 14 2012, time 0755-->
+<project default="jar" name="jaxen" basedir=".">
+ <!--Load local and user build preferences-->
+ <property file="build.properties"></property>
+ <property file="${user.home}/build.properties"></property>
+ <!--Build properties-->
+ <property name="defaulttargetdir" value="${basedir}/target"></property>
+ <property name="libdir" value="${user.home}/.maven/repository"></property>
+ <property name="classesdir" value="${basedir}/target/classes"></property>
+ <property name="testclassesdir" value="${basedir}/target/test-classes"></property>
+ <property name="testreportdir" value="${basedir}/target/test-reports"></property>
+ <property name="distdir" value="${basedir}/dist"></property>
+ <property name="javadocdir" value="${basedir}/dist/docs/api"></property>
+ <property name="final.name" value="jaxen-1.1.4"></property>
+ <property name="proxy.host" value=""></property>
+ <property name="proxy.port" value=""></property>
+ <property name="proxy.username" value=""></property>
+ <property name="proxy.password" value=""></property>
+ <path id="build.classpath">
+ <pathelement location="${libdir}/dom4j/jars/dom4j-1.6.1.jar"></pathelement>
+ <pathelement location="${libdir}/jdom/jars/jdom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar"></pathelement>
+ <pathelement location="${libdir}/xerces/jars/xercesImpl-2.6.2.jar"></pathelement>
+ <pathelement location="${libdir}/xom/jars/xom-1.0.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></pathelement>
+ <pathelement location="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></pathelement>
+ </path>
+ <target name="init" description="o Initializes some properties">
+ <mkdir dir="${libdir}"></mkdir>
+ <condition property="noget">
+ <equals arg2="only" arg1="${build.sysclasspath}"></equals>
+ </condition>
+ <!--Test if JUNIT is present in ANT classpath-->
+ <available property="Junit.present" classname="junit.framework.Test"></available>
+ <!--Test if user defined a proxy-->
+ <condition property="useProxy">
+ <and>
+ <isset property="proxy.host"></isset>
+ <not>
+ <equals trim="true" arg2="" arg1="${proxy.host}"></equals>
+ </not>
+ </and>
+ </condition>
+ </target>
+ <target name="compile" description="o Compile the code" depends="get-deps">
+ <mkdir dir="${classesdir}"></mkdir>
+ <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/main"></pathelement>
+ </src>
+ <classpath refid="build.classpath"></classpath>
+ </javac>
+ </target>
+ <target name="jar" description="o Create the jar" depends="compile,test">
+ <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}"></jar>
+ </target>
+ <target name="clean" description="o Clean up the generated directories">
+ <delete dir="${defaulttargetdir}"></delete>
+ <delete dir="${distdir}"></delete>
+ </target>
+ <target name="dist" description="o Create a distribution" depends="jar, javadoc">
+ <mkdir dir="dist"></mkdir>
+ <copy todir="dist">
+ <fileset dir="${defaulttargetdir}" includes="*.jar"></fileset>
+ <fileset dir="${basedir}" includes="LICENSE*, README*"></fileset>
+ </copy>
+ </target>
+ <target name="test" description="o Run the test cases" if="test.failure" depends="internal-test">
+ <fail message="There were test failures."></fail>
+ </target>
+ <target name="internal-test" if="Junit.present" depends="junit-present,compile-tests">
+ <mkdir dir="${testreportdir}"></mkdir>
+ <junit dir="${basedir}" failureproperty="test.failure" printSummary="yes" fork="true" haltonerror="true">
+ <sysproperty key="basedir" value="."></sysproperty>
+ <formatter type="xml"></formatter>
+ <formatter usefile="false" type="plain"></formatter>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${testclassesdir}"></pathelement>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ <batchtest todir="${testreportdir}">
+ <fileset dir="${basedir}/src/java/test">
+ <include name="**/*Test.java"></include>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+ <target name="junit-present" unless="Junit.present" depends="init">
+ <echo>================================= WARNING ================================</echo>
+ <echo>Junit isn't present in your ${ANT_HOME}/lib directory. Tests not executed.</echo>
+ <echo>==========================================================================</echo>
+ </target>
+ <target name="compile-tests" if="Junit.present" depends="junit-present,compile">
+ <mkdir dir="${testclassesdir}"></mkdir>
+ <javac destdir="${testclassesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
+ <src>
+ <pathelement location="${basedir}/src/java/test"></pathelement>
+ </src>
+ <classpath>
+ <path refid="build.classpath"></path>
+ <pathelement path="${classesdir}"></pathelement>
+ </classpath>
+ </javac>
+ </target>
+ <target name="javadoc" description="o Generate javadoc" depends="get-deps">
+ <mkdir dir="${javadocdir}"></mkdir>
+ <tstamp>
+ <format pattern="2001-yyyy" property="year"></format>
+ </tstamp>
+ <property name="copyright" value="Copyright &amp;copy; Codehaus. All Rights Reserved."></property>
+ <property name="title" value="jaxen 1.1.4 API"></property>
+ <javadoc use="true" private="true" destdir="${javadocdir}" author="true" version="true" sourcepath="${basedir}/src/java/main" packagenames="org.jaxen.*">
+ <classpath>
+ <path refid="build.classpath"></path>
+ </classpath>
+ </javadoc>
+ </target>
+ <target name="get-dep-dom4j.jar" description="o Download the dependency : dom4j.jar" unless="dom4j.jar" depends="init,setProxy,noProxy,get-custom-dep-dom4j.jar">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/dom4j/jars/dom4j-1.6.1.jar"></get>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//dom4j/jars/dom4j-1.6.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-dom4j.jar" if="dom4j.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/dom4j/jars/"></mkdir>
+ <get dest="${libdir}/dom4j/jars/dom4j-1.6.1.jar" usetimestamp="true" ignoreerrors="true" src="${dom4j.jar}"></get>
+ </target>
+ <target name="get-dep-jdom.jar" description="o Download the dependency : jdom.jar" unless="jdom.jar" depends="init,setProxy,noProxy,get-custom-dep-jdom.jar">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/jdom/jars/jdom-1.0.jar"></get>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//jdom/jars/jdom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-jdom.jar" if="jdom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/jdom/jars/"></mkdir>
+ <get dest="${libdir}/jdom/jars/jdom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${jdom.jar}"></get>
+ </target>
+ <target name="get-dep-xml-apis.jar" description="o Download the dependency : xml-apis.jar" unless="xml-apis.jar" depends="init,setProxy,noProxy,get-custom-dep-xml-apis.jar">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xml-apis/jars/xml-apis-1.3.02.jar"></get>
+ </target>
+ <target name="get-custom-dep-xml-apis.jar" if="xml-apis.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xml-apis/jars/"></mkdir>
+ <get dest="${libdir}/xml-apis/jars/xml-apis-1.3.02.jar" usetimestamp="true" ignoreerrors="true" src="${xml-apis.jar}"></get>
+ </target>
+ <target name="get-dep-xercesImpl.jar" description="o Download the dependency : xercesImpl.jar" unless="xercesImpl.jar" depends="init,setProxy,noProxy,get-custom-dep-xercesImpl.jar">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xerces/jars/xercesImpl-2.6.2.jar"></get>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xerces/jars/xercesImpl-2.6.2.jar"></get>
+ </target>
+ <target name="get-custom-dep-xercesImpl.jar" if="xercesImpl.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xerces/jars/"></mkdir>
+ <get dest="${libdir}/xerces/jars/xercesImpl-2.6.2.jar" usetimestamp="true" ignoreerrors="true" src="${xercesImpl.jar}"></get>
+ </target>
+ <target name="get-dep-xom.jar" description="o Download the dependency : xom.jar" unless="xom.jar" depends="init,setProxy,noProxy,get-custom-dep-xom.jar">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/xom/jars/xom-1.0.jar"></get>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//xom/jars/xom-1.0.jar"></get>
+ </target>
+ <target name="get-custom-dep-xom.jar" if="xom.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/xom/jars/"></mkdir>
+ <get dest="${libdir}/xom/jars/xom-1.0.jar" usetimestamp="true" ignoreerrors="true" src="${xom.jar}"></get>
+ </target>
+ <target name="get-dep-maven-cobertura-plugin.jar" description="o Download the dependency : maven-cobertura-plugin.jar" unless="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-cobertura-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-cobertura-plugin-1.3.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-cobertura-plugin.jar" if="maven-cobertura-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-cobertura-plugin-1.3.jar" usetimestamp="true" ignoreerrors="true" src="${maven-cobertura-plugin.jar}"></get>
+ </target>
+ <target name="get-dep-maven-findbugs-plugin.jar" description="o Download the dependency : maven-findbugs-plugin.jar" unless="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy,get-custom-dep-maven-findbugs-plugin.jar">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://repo1.maven.org/maven/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="http://dist.codehaus.org//maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar"></get>
+ </target>
+ <target name="get-custom-dep-maven-findbugs-plugin.jar" if="maven-findbugs-plugin.jar" depends="init,setProxy,noProxy">
+ <mkdir dir="${libdir}/maven-plugins/plugins/"></mkdir>
+ <get dest="${libdir}/maven-plugins/plugins/maven-findbugs-plugin-1.3.1.jar" usetimestamp="true" ignoreerrors="true" src="${maven-findbugs-plugin.jar}"></get>
+ </target>
+ <target name="get-deps" unless="noget"></target>
+ <target name="setProxy" if="useProxy" depends="init">
+ <!--Proxy settings works only with a JDK 1.2 and higher.-->
+ <echo>Proxy used :</echo>
+ <echo>Proxy host [${proxy.host}]</echo>
+ <echo>Proxy port [${proxy.port}]</echo>
+ <echo>Proxy user [${proxy.username}]</echo>
+ <setproxy proxyuser="${proxy.username}" proxyport="${proxy.port}" proxypassword="${proxy.password}" proxyhost="${proxy.host}"></setproxy>
+ </target>
+ <target name="noProxy" unless="useProxy" depends="init">
+ <echo>Proxy not used.</echo>
+ </target>
+ <target name="install-maven">
+ <get dest="${user.home}/maven-install-latest.jar" usetimestamp="true" src="${repo}/maven/maven-install-latest.jar"></get>
+ <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar"></unjar>
+ </target>
+</project> \ No newline at end of file
diff --git a/dev-java/jaxen/jaxen-1.1.4.ebuild b/dev-java/jaxen/jaxen-1.1.4.ebuild
new file mode 100644
index 000000000000..8bcafaad1d61
--- /dev/null
+++ b/dev-java/jaxen/jaxen-1.1.4.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jaxen/jaxen-1.1.4.ebuild,v 1.1 2012/10/14 14:28:48 sera Exp $
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A Java XPath Engine"
+HOMEPAGE="http://jaxen.codehaus.org/"
+SRC_URI="http://dist.codehaus.org/${PN}/distributions/${P}-src.tar.gz"
+
+LICENSE="jaxen"
+SLOT="1.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+COMMON_DEP="
+ dev-java/dom4j:1
+ dev-java/jdom:1.0
+ dev-java/xom:0"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ test? ( dev-java/ant-junit:0 )
+ ${COMMON_DEP}"
+
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+EANT_GENTOO_CLASSPATH="dom4j-1,jdom-1.0,xom"
+EANT_TEST_EXTRA_ARGS="-DJunit.present=true"
+
+java_prepare() {
+ cp -v "${FILESDIR}"/${P}_maven1-build.xml build.xml || die
+}
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use examples && java-pkg_doexamples src/java/samples
+ use source && java-pkg_dosrc src/java/main/*
+}