summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-05-16 19:11:21 +0000
committerVlastimil Babka <caster@gentoo.org>2009-05-16 19:11:21 +0000
commit8e1ff53081fa3c26c33010ab180f96f23d615aa6 (patch)
tree2982113b2fc6161c0ca6dc521ecb9c63908f798d /dev-java
parentThere is no TODO file in this version, stop trying to install it. (diff)
downloadgentoo-2-8e1ff53081fa3c26c33010ab180f96f23d615aa6.tar.gz
gentoo-2-8e1ff53081fa3c26c33010ab180f96f23d615aa6.tar.bz2
gentoo-2-8e1ff53081fa3c26c33010ab180f96f23d615aa6.zip
Version bump, bug #256242.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/icu4j/ChangeLog8
-rw-r--r--dev-java/icu4j/files/icu4j-3.6.1-manifest21
-rw-r--r--dev-java/icu4j/icu4j-4.0.1.ebuild75
3 files changed, 82 insertions, 22 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index 60f016c2e3d6..9480ea9ecca7 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icu4j
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.29 2009/02/04 12:25:53 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.30 2009/05/16 19:11:20 caster Exp $
+
+*icu4j-4.0.1 (16 May 2009)
+
+ 16 May 2009; Vlastimil Babka <caster@gentoo.org>
+ -files/icu4j-3.6.1-manifest, +icu4j-4.0.1.ebuild:
+ Version bump, bug #256242.
04 Feb 2009; Petteri Räty <betelgeuse@gentoo.org> -icu4j-3.0-r1.ebuild,
-icu4j-3.6.1.ebuild, -icu4j-3.6.1-r1.ebuild:
diff --git a/dev-java/icu4j/files/icu4j-3.6.1-manifest b/dev-java/icu4j/files/icu4j-3.6.1-manifest
deleted file mode 100644
index 43e8275c73c0..000000000000
--- a/dev-java/icu4j/files/icu4j-3.6.1-manifest
+++ /dev/null
@@ -1,21 +0,0 @@
-Manifest-Version: 1.0
-Bundle-ManifestVersion: 2
-Bundle-Name: %bundleName
-Bundle-Vendor: %vendorName
-Bundle-SymbolicName: com.ibm.icu; singleton:=true
-Bundle-Version: 3.6.1
-Bundle-Localization: plugin
-Export-Package: com.ibm.icu.lang;version="3.6.1",
- com.ibm.icu.math;version="3.6.1",
- com.ibm.icu.text;version="3.6.1",
- com.ibm.icu.util;version="3.6.1",
- com.ibm.icu.impl;x-internal:=true,
- com.ibm.icu.impl.data;x-internal:=true,
- com.ibm.icu.impl.data.icudt36b;x-internal:=true,
- com.ibm.icu.impl.data.icudt36b.brkitr;x-internal:=true,
- com.ibm.icu.impl.data.icudt36b.coll;x-internal:=true,
- com.ibm.icu.impl.data.icudt36b.rbnf;x-internal:=true,
- com.ibm.icu.impl.data.icudt36b.translit;x-internal:=true
-Eclipse-LazyStart: true
-Bundle-ClassPath: icu-jse4.jar,icu-data.jar,.
-Eclipse-ExtensibleAPI: true
diff --git a/dev-java/icu4j/icu4j-4.0.1.ebuild b/dev-java/icu4j/icu4j-4.0.1.ebuild
new file mode 100644
index 000000000000..fb9b36881b23
--- /dev/null
+++ b/dev-java/icu4j/icu4j-4.0.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-4.0.1.ebuild,v 1.1 2009/05/16 19:11:20 caster Exp $
+
+EAPI=2
+
+# We currently download the Javadoc documentation.
+# It could optionally be built using the Ant build file.
+# testdata.jar and icudata.jar do not contain *.class files but *.res files
+# These *.res data files are needed to built the final jar
+# They do not need to be installed however as they will already be present in icu4j.jar
+
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="A set of Java libraries providing Unicode and Globalization support."
+MY_PV=${PV//./_}
+
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-src.jar
+ doc? ( http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-docs.jar )"
+
+HOMEPAGE="http://www.icu-project.org/"
+LICENSE="icu"
+SLOT="4"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+
+# build.xml does file version detection that fails for 1.7
+# http://bugs.gentoo.org/show_bug.cgi?id=213555
+DEPEND="test? ( =virtual/jdk-1.6* )
+ !test? ( || ( =virtual/jdk-1.6* =virtual/jdk-1.5* =virtual/jdk-1.4* ) )
+ app-arch/unzip"
+
+RESTRICT="ia64? ( test )
+ x86-fbsd? ( test )"
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-src.jar" || die "Failed to unpack"
+
+ if use doc; then
+ mkdir docs; cd docs
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-docs.jar" || die "Failed to unpack docs"
+ fi
+}
+
+src_compile() {
+ # Classes extending CharsetICU not implementing Comparable
+ # Breaks with ecj on jdk 1.5+, javac doesn't mind - Sun's hack?
+ # Restricting to javac (didn't even care to try jikes) is better
+ # than forcing 1.4
+ java-pkg_force-compiler javac
+ eant jar || die "Compile failed"
+}
+
+src_install() {
+ java-osgi_newjar-fromfile "${PN}.jar" "${FILESDIR}/icu4j-4.0-manifest" \
+ "International Components for Unicode for Java (ICU4J)"
+ java-pkg_dojar "${PN}-charsets.jar"
+
+ use doc && dohtml -r readme.html docs/*
+ use source && java-pkg_dosrc src/*
+}
+
+# Tests only work with JDK-1.6, severe out of memory problems appear with 1.5
+
+src_test() {
+ eant check
+}