summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-02-06 13:59:08 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-02-06 13:59:08 +0000
commitc199fb5efbce7767bb3c5379bdc82854e199d246 (patch)
tree1a0b19d61a616f0a73cf4baf82957a4a28839d58 /dev-java
parentVersion bump to 1.50. (diff)
downloadgentoo-2-c199fb5efbce7767bb3c5379bdc82854e199d246.tar.gz
gentoo-2-c199fb5efbce7767bb3c5379bdc82854e199d246.tar.bz2
gentoo-2-c199fb5efbce7767bb3c5379bdc82854e199d246.zip
Version bump to 1.50.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/bcmail/ChangeLog9
-rw-r--r--dev-java/bcmail/bcmail-1.50.ebuild82
2 files changed, 89 insertions, 2 deletions
diff --git a/dev-java/bcmail/ChangeLog b/dev-java/bcmail/ChangeLog
index 9c010c8669b8..c4cb73cc6497 100644
--- a/dev-java/bcmail/ChangeLog
+++ b/dev-java/bcmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/bcmail
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bcmail/ChangeLog,v 1.41 2013/09/05 22:34:27 tomwij Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcmail/ChangeLog,v 1.42 2014/02/06 13:59:08 tomwij Exp $
+
+*bcmail-1.50 (06 Feb 2014)
+
+ 06 Feb 2014; Tom Wijsman <TomWij@gentoo.org> +bcmail-1.50.ebuild:
+ Version bump to 1.50.
*bcmail-1.38-r3 (05 Sep 2013)
diff --git a/dev-java/bcmail/bcmail-1.50.ebuild b/dev-java/bcmail/bcmail-1.50.ebuild
new file mode 100644
index 000000000000..99b4e162ffb1
--- /dev/null
+++ b/dev-java/bcmail/bcmail-1.50.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bcmail/bcmail-1.50.ebuild,v 1.1 2014/02/06 13:59:08 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}-jdk15on-${PV/./}"
+
+DESCRIPTION="Java cryptography APIs"
+HOMEPAGE="http://www.bouncycastle.org/java.html"
+SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
+
+COMMON_DEPEND=">=dev-java/bcprov-${PV}:0[test?]
+ ~dev-java/bcpkix-${PV}:0[test?]
+ dev-java/sun-jaf:0
+ java-virtuals/javamail:0"
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ test? ( dev-java/junit:0 )
+ ${COMMON_DEPEND}"
+
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# Package can't be build with test as bcprov and bcpkix can't be built with test.
+RESTRICT="test"
+
+src_unpack() {
+ default
+ cd "${S}"
+ unpack ./src.zip
+}
+
+java_prepare() {
+ mkdir "${S}"/classes
+
+ if use test ; then
+ java-pkg_jar-from --build-only junit
+ fi
+}
+
+src_compile() {
+ find org -name "*.java" > "${T}"/src.list
+
+ local cp="$(java-pkg_getjars bcprov,bcpkix,sun-jaf,javamail)"
+ if use test ; then
+ cp="${cp}:junit.jar"
+ else
+ sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
+ fi
+
+ ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
+
+ cd "${S}"/classes
+ jar -cf "${S}"/${PN}.jar * || die "failed to create jar"
+}
+
+src_test() {
+ local cp="${PN}.jar:bcprov.jar:bcpkix.jar:junit.jar"
+
+ java -cp ${cp} org.bouncycastle.mail.smime.test.AllTests | tee mail.tests
+
+ grep -q FAILURES *.tests && die "Tests failed."
+}
+
+src_install() {
+ java-pkg_dojar "${S}"/${PN}.jar
+
+ use source && java-pkg_dosrc org
+ use doc && java-pkg_dojavadoc docs
+}