summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-22 17:25:49 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-22 17:25:49 +0000
commitaa6e104eec88841fea67f9100af3e82ba9f3cf98 (patch)
treec6f5cf831ce0ace03b55525d0e35dfe898b94c6a /dev-lang/R
parentStable for HPPA (bug #349045). (diff)
downloadgentoo-2-aa6e104eec88841fea67f9100af3e82ba9f3cf98.tar.gz
gentoo-2-aa6e104eec88841fea67f9100af3e82ba9f3cf98.tar.bz2
gentoo-2-aa6e104eec88841fea67f9100af3e82ba9f3cf98.zip
Version bump. This fix some test failures as well
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/R')
-rw-r--r--dev-lang/R/ChangeLog8
-rw-r--r--dev-lang/R/R-2.12.1.ebuild (renamed from dev-lang/R/R-2.12.0.ebuild)8
-rw-r--r--dev-lang/R/files/R-2.12.1-ldflags.patch11
3 files changed, 24 insertions, 3 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index a16e2db68c51..32624100a962 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/R
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.180 2010/11/08 18:44:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.181 2010/12/22 17:25:49 bicatali Exp $
+
+*R-2.12.1 (22 Dec 2010)
+
+ 22 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org> -R-2.12.0.ebuild,
+ +R-2.12.1.ebuild, +files/R-2.12.1-ldflags.patch:
+ Version bump. This fix some test failures as well
08 Nov 2010; Kacper Kowalik <xarthisius@gentoo.org> R-2.10.1.ebuild,
-R-2.11.1.ebuild, R-2.12.0.ebuild:
diff --git a/dev-lang/R/R-2.12.0.ebuild b/dev-lang/R/R-2.12.1.ebuild
index 987827f5433a..378adb18fde2 100644
--- a/dev-lang/R/R-2.12.0.ebuild
+++ b/dev-lang/R/R-2.12.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.12.0.ebuild,v 1.2 2010/11/08 18:44:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.12.1.ebuild,v 1.1 2010/12/22 17:25:49 bicatali Exp $
EAPI=2
inherit eutils flag-o-matic bash-completion versionator
@@ -14,7 +14,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="doc java jpeg lapack minimal nls perl png readline threads tk X cairo"
+IUSE="doc java jpeg lapack minimal nls perl png readline static-libs threads tk X cairo"
# common depends
CDEPEND="dev-libs/libpcre
@@ -55,6 +55,8 @@ pkg_setup() {
src_prepare() {
# fix ocasional failure with parallel install (bug #322965)
epatch "${FILESDIR}"/${PN}-2.11.1-parallel.patch
+ # respect ldflags on rscript
+ epatch "${FILESDIR}"/${PN}-2.12.1-ldflags.patch
# fix packages.html for doc (bug #205103)
# check in later versions if fixed
@@ -95,6 +97,8 @@ src_configure() {
--docdir=/usr/share/doc/${PF} \
rdocdir=/usr/share/doc/${PF} \
$(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable static-libs R-static-lib) \
$(use_enable threads) \
$(use_with lapack) \
$(use_with tk tcltk) \
diff --git a/dev-lang/R/files/R-2.12.1-ldflags.patch b/dev-lang/R/files/R-2.12.1-ldflags.patch
new file mode 100644
index 000000000000..6296d0330c7a
--- /dev/null
+++ b/dev-lang/R/files/R-2.12.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- src/unix/Makefile.in.orig 2010-12-22 16:58:19.000000000 +0000
++++ src/unix/Makefile.in 2010-12-22 16:54:16.000000000 +0000
+@@ -66,7 +66,7 @@
+
+ ## we need to build at install time to capture the correct 'rhome'
+ install-Rscript:
+- $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) -DR_HOME='"$(rhome)"' -o Rscript \
++ $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) $(LDFLAGS) -DR_HOME='"$(rhome)"' -o Rscript \
+ $(srcdir)/Rscript.c
+ @$(MKINSTALLDIRS) "$(DESTDIR)$(Rexecbindir)"
+ @$(INSTALL_PROGRAM) Rscript "$(DESTDIR)$(Rexecbindir)/Rscript"