summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-12 19:54:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-12 19:54:56 +0000
commit8b4e26a712599687c0d8d9153466461b6bd0ada1 (patch)
tree2c3ae2e95972415c8f0cea702be47f382e56fa46 /dev-lang/blassic/blassic-0.10.0.ebuild
parentstabilize (diff)
downloadgentoo-2-8b4e26a712599687c0d8d9153466461b6bd0ada1.tar.gz
gentoo-2-8b4e26a712599687c0d8d9153466461b6bd0ada1.tar.bz2
gentoo-2-8b4e26a712599687c0d8d9153466461b6bd0ada1.zip
version bump (bug #81760)
(Portage version: 2.0.51-r15)
Diffstat (limited to 'dev-lang/blassic/blassic-0.10.0.ebuild')
-rw-r--r--dev-lang/blassic/blassic-0.10.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-lang/blassic/blassic-0.10.0.ebuild b/dev-lang/blassic/blassic-0.10.0.ebuild
new file mode 100644
index 000000000000..b197cdba82fb
--- /dev/null
+++ b/dev-lang/blassic/blassic-0.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/blassic/blassic-0.10.0.ebuild,v 1.1 2005/02/12 19:54:56 mr_bones_ Exp $
+
+DESCRIPTION="classic Basic interpreter"
+HOMEPAGE="http://www.blassic.org"
+SRC_URI="http://www.blassic.org/bin/${P}.tgz"
+
+LICENSE="GPL-2"
+KEYWORDS="~hppa ~ppc ~x86"
+SLOT="0"
+IUSE="svga X"
+
+DEPEND="virtual/libc
+ X? ( virtual/x11 )
+ sys-libs/ncurses
+ svga? ( media-libs/svgalib )"
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_with X x) \
+ $(use_enable svga svgalib) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README THANKS TODO
+}