summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-02-16 17:42:20 +0000
committerJulian Ospald <hasufell@gentoo.org>2015-02-16 17:42:20 +0000
commit3da19bcd60c5cbdbbdbebb5a2cbdaf10caefcee6 (patch)
tree0f1dfdc6799099e91cf882ff96507fa7cf450ac2 /dev-lang/elixir
parentAdd in configuration file for 7.3 (diff)
downloadgentoo-2-3da19bcd60c5cbdbbdbebb5a2cbdaf10caefcee6.tar.gz
gentoo-2-3da19bcd60c5cbdbbdbebb5a2cbdaf10caefcee6.tar.bz2
gentoo-2-3da19bcd60c5cbdbbdbebb5a2cbdaf10caefcee6.zip
version bump
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-lang/elixir')
-rw-r--r--dev-lang/elixir/ChangeLog9
-rw-r--r--dev-lang/elixir/elixir-1.0.3.ebuild28
2 files changed, 35 insertions, 2 deletions
diff --git a/dev-lang/elixir/ChangeLog b/dev-lang/elixir/ChangeLog
index 00bb141a3a4a..2be2654b411e 100644
--- a/dev-lang/elixir/ChangeLog
+++ b/dev-lang/elixir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/elixir
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/elixir/ChangeLog,v 1.24 2014/10/29 13:35:51 hasufell Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/elixir/ChangeLog,v 1.25 2015/02/16 17:42:20 hasufell Exp $
+
+*elixir-1.0.3 (16 Feb 2015)
+
+ 16 Feb 2015; Julian Ospald <hasufell@gentoo.org> +elixir-1.0.3.ebuild:
+ version bump
*elixir-1.0.2 (29 Oct 2014)
diff --git a/dev-lang/elixir/elixir-1.0.3.ebuild b/dev-lang/elixir/elixir-1.0.3.ebuild
new file mode 100644
index 000000000000..d7e025c92634
--- /dev/null
+++ b/dev-lang/elixir/elixir-1.0.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/elixir/elixir-1.0.3.ebuild,v 1.1 2015/02/16 17:42:20 hasufell Exp $
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Elixir programming language"
+HOMEPAGE="http://elixir-lang.org"
+SRC_URI="https://github.com/elixir-lang/elixir/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 ErlPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/erlang-17"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake Q=""
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" PREFIX="/usr" install
+ dodoc README.md CHANGELOG.md CONTRIBUTING.md
+}