summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-04-29 00:06:05 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-04-29 00:06:05 +0000
commit1c23871a4c8053aac14f29e05fb7cb4b39741898 (patch)
treeabe30911f8980ef9124f05ad187b538cff2dd9bf /dev-lang/erlang
parentVersion bump (diff)
downloadgentoo-2-1c23871a4c8053aac14f29e05fb7cb4b39741898.tar.gz
gentoo-2-1c23871a4c8053aac14f29e05fb7cb4b39741898.tar.bz2
gentoo-2-1c23871a4c8053aac14f29e05fb7cb4b39741898.zip
make building with --as-needed possible, patch provided by pva in bug 203157
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-lang/erlang')
-rw-r--r--dev-lang/erlang/ChangeLog6
-rw-r--r--dev-lang/erlang/erlang-12.2.2.ebuild14
-rw-r--r--dev-lang/erlang/files/erlang-12.2.2-as-needed.patch22
3 files changed, 31 insertions, 11 deletions
diff --git a/dev-lang/erlang/ChangeLog b/dev-lang/erlang/ChangeLog
index 018739ed5eae..bd046c22b132 100644
--- a/dev-lang/erlang/ChangeLog
+++ b/dev-lang/erlang/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/erlang
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.111 2008/04/28 23:03:28 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/ChangeLog,v 1.112 2008/04/29 00:06:04 opfer Exp $
+
+ 29 Apr 2008; Christian Faulhammer <opfer@gentoo.org>
+ +files/erlang-12.2.2-as-needed.patch, erlang-12.2.2.ebuild:
+ make building with --as-needed possible, patch provided by pva in bug 203157
28 Apr 2008; Christian Faulhammer <opfer@gentoo.org> erlang-12.2.2.ebuild:
use variable instead of fixed string so I won't continually forget to adjust
diff --git a/dev-lang/erlang/erlang-12.2.2.ebuild b/dev-lang/erlang/erlang-12.2.2.ebuild
index 53074c1620da..ecfe1fbca6e9 100644
--- a/dev-lang/erlang/erlang-12.2.2.ebuild
+++ b/dev-lang/erlang/erlang-12.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.2.ebuild,v 1.2 2008/04/28 23:03:28 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/erlang/erlang-12.2.2.ebuild,v 1.3 2008/04/29 00:06:04 opfer Exp $
inherit elisp-common eutils flag-o-matic multilib versionator
@@ -40,21 +40,15 @@ S="${WORKDIR}/${MY_P}"
SITEFILE=50erlang-gentoo.el
-pkg_setup() {
- if use ssl; then
- if is-ldflag --as-needed || is-flag --as-needed; then
- eerror "Don't use --as-needed in your LDFLAGS or CFLAGS for SSL support, this will fail."
- die
- fi
- fi
-}
-
src_unpack() {
unpack ${A}
cd "${S}"
use odbc || sed -i 's: odbc : :' lib/Makefile
+ # fix builds with --as-needed LDFLAGS, bug 203157
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+
# make sure we only link ssl dynamically
# will not be integrated by upstream for various reasons
sed -i '/SSL_DYNAMIC_ONLY=/s:no:yes:' erts/configure #184419
diff --git a/dev-lang/erlang/files/erlang-12.2.2-as-needed.patch b/dev-lang/erlang/files/erlang-12.2.2-as-needed.patch
new file mode 100644
index 000000000000..863e89c9400f
--- /dev/null
+++ b/dev-lang/erlang/files/erlang-12.2.2-as-needed.patch
@@ -0,0 +1,22 @@
+--- erts/configure.in.orig 2008-04-24 23:16:09.000000000 +0400
++++ erts/configure.in 2008-04-24 23:17:05.000000000 +0400
+@@ -2874,8 +2874,10 @@
+ else
+ saveCFLAGS="$CFLAGS"
+ saveLDFLAGS="$LDFLAGS"
++ saveLIBS="$LIBS"
+ CFLAGS="$CFLAGS $SSL_INCLUDE"
+- LDFLAGS="$LDFLAGS -L$SSL_LIBDIR -lcrypto"
++ LDFLAGS="$LDFLAGS -L$SSL_LIBDIR"
++ LIBS="-lcrypto"
+ AC_TRY_LINK([
+ #include <stdio.h>
+ #include <openssl/hmac.h>],
+@@ -2887,6 +2889,7 @@
+ [ssl_linkable=no])
+ CFLAGS="$saveCFLAGS"
+ LDFLAGS="$saveLDFLAGS"
++ LIBS="$saveLIBS"
+ fi
+ fi
+ if test "x$ssl_found" = "xyes" -a "x$ssl_linkable" = "xyes" ; then