summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-10-18 01:31:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-10-18 01:31:52 +0000
commita6e229bdaab6b790585a33964dec7d835671a829 (patch)
tree0fdcede5641fb337f66b7ddfe9e15a6afa7c08ab /dev-lang/hy
parentDon't build bogus tests (bug 525612). (diff)
downloadgentoo-2-a6e229bdaab6b790585a33964dec7d835671a829.tar.gz
gentoo-2-a6e229bdaab6b790585a33964dec7d835671a829.tar.bz2
gentoo-2-a6e229bdaab6b790585a33964dec7d835671a829.zip
Bump
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/hy')
-rw-r--r--dev-lang/hy/ChangeLog7
-rw-r--r--dev-lang/hy/hy-0.10.1.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-lang/hy/ChangeLog b/dev-lang/hy/ChangeLog
index 18370808b349..ea9dd27e281e 100644
--- a/dev-lang/hy/ChangeLog
+++ b/dev-lang/hy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/hy
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/hy/ChangeLog,v 1.5 2014/09/23 19:12:49 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hy/ChangeLog,v 1.6 2014/10/18 01:31:52 patrick Exp $
+
+*hy-0.10.1 (18 Oct 2014)
+
+ 18 Oct 2014; Patrick Lauer <patrick@gentoo.org> +hy-0.10.1.ebuild:
+ Bump
23 Sep 2014; Dirkjan Ochtman <djc@gentoo.org> metadata.xml:
Remove python, not a python library
diff --git a/dev-lang/hy/hy-0.10.1.ebuild b/dev-lang/hy/hy-0.10.1.ebuild
new file mode 100644
index 000000000000..795897cc701b
--- /dev/null
+++ b/dev-lang/hy/hy-0.10.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/hy/hy-0.10.1.ebuild,v 1.1 2014/10/18 01:31:52 patrick Exp $
+
+EAPI=5
+
+RESTRICT="test" # needs some pointy sticks. Seriously.
+PYTHON_COMPAT=(python2_7 python3_3)
+
+inherit distutils-r1
+DESCRIPTION="A LISP dialect running in python"
+HOMEPAGE="http://hylang.org/"
+SRC_URI="https://github.com/hylang/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]
+ >=dev-python/rply-0.7.0[${PYTHON_USEDEP}]
+ dev-python/astor[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/tox[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests || die "Tests failed under ${EPYTHON}"
+}