summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2008-10-15 20:52:34 +0000
committerHarald van Dijk <truedfx@gentoo.org>2008-10-15 20:52:34 +0000
commitc9798b4acd64439643bd8bae595c85ef8fc07d67 (patch)
tree21f7d7705edd4507c4c8c9cf8a3201e58a92cb65 /dev-lang/lazarus
parentallow /var/log/messages to be missing (patch from Edoceo via bug #242260) (diff)
downloadgentoo-2-c9798b4acd64439643bd8bae595c85ef8fc07d67.tar.gz
gentoo-2-c9798b4acd64439643bd8bae595c85ef8fc07d67.tar.bz2
gentoo-2-c9798b4acd64439643bd8bae595c85ef8fc07d67.zip
Version bump (#242200 by Renato Caldas)
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-gentoo x86_64)
Diffstat (limited to 'dev-lang/lazarus')
-rw-r--r--dev-lang/lazarus/ChangeLog8
-rw-r--r--dev-lang/lazarus/files/lazarus-0.9.26-fpcsrc.patch13
-rw-r--r--dev-lang/lazarus/lazarus-0.9.26.ebuild80
3 files changed, 100 insertions, 1 deletions
diff --git a/dev-lang/lazarus/ChangeLog b/dev-lang/lazarus/ChangeLog
index 5018ad75ad93..3d775104ed75 100644
--- a/dev-lang/lazarus/ChangeLog
+++ b/dev-lang/lazarus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/lazarus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.20 2008/02/29 17:57:18 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/ChangeLog,v 1.21 2008/10/15 20:52:34 truedfx Exp $
+
+*lazarus-0.9.26 (15 Oct 2008)
+
+ 15 Oct 2008; Harald van Dijk <truedfx@gentoo.org>
+ +files/lazarus-0.9.26-fpcsrc.patch, +lazarus-0.9.26.ebuild:
+ Version bump (#242200 by Renato Caldas)
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> lazarus-0.9.22-r1.ebuild,
lazarus-0.9.24.ebuild:
diff --git a/dev-lang/lazarus/files/lazarus-0.9.26-fpcsrc.patch b/dev-lang/lazarus/files/lazarus-0.9.26-fpcsrc.patch
new file mode 100644
index 000000000000..8f9aee3fa42a
--- /dev/null
+++ b/dev-lang/lazarus/files/lazarus-0.9.26-fpcsrc.patch
@@ -0,0 +1,13 @@
+--- lazarus/ide/include/unix/lazbaseconf.inc
++++ lazarus/ide/include/unix/lazbaseconf.inc
+@@ -24,8 +24,9 @@
+ }
+
+ const
+- DefaultFPCSrcDirs: array[1..15] of string = (
++ DefaultFPCSrcDirs: array[1..16] of string = (
+ // search first for sources with right version
++ '/usr/lib/fpc/$(FPCVer)/source',
+ '/usr/share/fpcsrc/$(FPCVer)',
+ // then search for global paths
+ '/usr/share/fpcsrc',
diff --git a/dev-lang/lazarus/lazarus-0.9.26.ebuild b/dev-lang/lazarus/lazarus-0.9.26.ebuild
new file mode 100644
index 000000000000..4bddf936b6e4
--- /dev/null
+++ b/dev-lang/lazarus/lazarus-0.9.26.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lazarus/lazarus-0.9.26.ebuild,v 1.1 2008/10/15 20:52:34 truedfx Exp $
+
+inherit eutils
+
+# bug #183604
+RESTRICT="strip"
+
+FPCVER="2.2.2"
+
+SLOT="0" # Note: Slotting Lazarus needs slotting fpc, see DEPEND.
+LICENSE="GPL-2 LGPL-2.1 LGPL-2.1-linking-exception"
+KEYWORDS="~amd64 ~ppc ~x86"
+DESCRIPTION="Lazarus IDE is a feature rich visual programming environment emulating Delphi."
+HOMEPAGE="http://www.lazarus.freepascal.org/"
+IUSE=""
+SRC_URI="mirror://sourceforge/lazarus/${P}-0.tgz"
+
+DEPEND="~dev-lang/fpc-${FPCVER}
+ net-misc/rsync
+ >=x11-libs/gtk+-2.0"
+RDEPEND="${DEPEND}
+ !=gnome-base/librsvg-2.16.1"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ if ! built_with_use "dev-lang/fpc" source; then
+ eerror "You need to build dev-lang/fpc with the 'source' USE flag"
+ eerror "in order for lazarus to work properly."
+ die "lazarus needs fpc built with the 'source' USE to work."
+ fi
+}
+
+src_unpack() {
+ # check for broken fpc.cfg
+ # don't check in pkg_setup since it won't harm binpkgs
+ if grep -q '^[ ]*-Fu.*/lcl$' /etc/fpc.cfg
+ then
+ eerror "Your /etc/fpc.cfg automatically adds a LCL directory"
+ eerror "to the list of unit directories. This will break the"
+ eerror "build of lazarus."
+ die "don't set the LCL path in /etc/fpc.cfg"
+ fi
+
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fpcsrc.patch
+}
+
+src_compile() {
+ LCL_PLATFORM=gtk2 emake -j1 || die "make failed!"
+}
+
+src_install() {
+ diropts -m0755
+ dodir /usr/share
+ # Using rsync to avoid unnecessary copies and cleaning...
+ # Note: *.o and *.ppu are needed
+ rsync -a \
+ --exclude="CVS" --exclude=".cvsignore" \
+ --exclude="*.ppw" --exclude="*.ppl" \
+ --exclude="*.ow" --exclude="*.a"\
+ --exclude="*.rst" --exclude=".#*" \
+ --exclude="*.~*" --exclude="*.bak" \
+ --exclude="*.orig" --exclude="*.rej" \
+ --exclude=".xvpics" --exclude="*.compiled" \
+ --exclude="killme*" --exclude=".gdb_hist*" \
+ --exclude="debian" --exclude="COPYING*" \
+ --exclude="*.app" \
+ "${S}" "${D}"usr/share \
+ || die "Unable to copy files!"
+
+ dosym ../share/lazarus/startlazarus /usr/bin/startlazarus
+ dosym ../lazarus/images/mainicon.xpm /usr/share/pixmaps/lazarus.xpm
+
+ make_desktop_entry startlazarus "Lazarus IDE" "lazarus" || die "Failed making desktop entry!"
+}