summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-06-25 16:55:35 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-06-25 16:55:35 +0000
commit55c5e5aedba18888ab2f9efb0b99b77e14d23a75 (patch)
treef328f6fdae2c80a0a15709611f6f1467647e6ac4 /dev-lang/lua
parentstable amd64 (diff)
downloadgentoo-2-55c5e5aedba18888ab2f9efb0b99b77e14d23a75.tar.gz
gentoo-2-55c5e5aedba18888ab2f9efb0b99b77e14d23a75.tar.bz2
gentoo-2-55c5e5aedba18888ab2f9efb0b99b77e14d23a75.zip
as-needed patch thanks to TGL <degrenier@easyconnect.fr> in bug 122128 from Benjamin Schindler <config@gentoo.org>
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'dev-lang/lua')
-rw-r--r--dev-lang/lua/ChangeLog7
-rw-r--r--dev-lang/lua/files/digest-lua-5.0.22
-rw-r--r--dev-lang/lua/files/digest-lua-5.0.2-r12
-rw-r--r--dev-lang/lua/files/lua-5.0.2-LDFLAGS_and_as-needed.patch47
-rw-r--r--dev-lang/lua/lua-5.0.2.ebuild6
5 files changed, 61 insertions, 3 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index 812008ba09da..6e778d2888e5 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.42 2006/03/01 19:24:55 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.43 2006/06/25 16:55:35 genstef Exp $
+
+ 25 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/lua-5.0.2-LDFLAGS_and_as-needed.patch, lua-5.0.2.ebuild:
+ as-needed patch thanks to TGL <degrenier@easyconnect.fr> in bug 122128 from
+ Benjamin Schindler <config@gentoo.org>
01 Mar 2006; Tom Payne <twp@gentoo.org> -lua-4.0.ebuild, -lua-5.0.ebuild,
-lua-5.0.1_beta20031003-r2.ebuild:
diff --git a/dev-lang/lua/files/digest-lua-5.0.2 b/dev-lang/lua/files/digest-lua-5.0.2
index 519f9921e608..a362628bd431 100644
--- a/dev-lang/lua/files/digest-lua-5.0.2
+++ b/dev-lang/lua/files/digest-lua-5.0.2
@@ -1 +1,3 @@
MD5 dea74646b7e5c621fef7174df83c34b1 lua-5.0.2.tar.gz 190442
+RMD160 5f1a1cf5802e38b3c4dcfc9f3cd0dc33bfdc0a30 lua-5.0.2.tar.gz 190442
+SHA256 a6c85d85f912e1c321723084389d63dee7660b81b8292452b190ea7190dd73bc lua-5.0.2.tar.gz 190442
diff --git a/dev-lang/lua/files/digest-lua-5.0.2-r1 b/dev-lang/lua/files/digest-lua-5.0.2-r1
index 519f9921e608..a362628bd431 100644
--- a/dev-lang/lua/files/digest-lua-5.0.2-r1
+++ b/dev-lang/lua/files/digest-lua-5.0.2-r1
@@ -1 +1,3 @@
MD5 dea74646b7e5c621fef7174df83c34b1 lua-5.0.2.tar.gz 190442
+RMD160 5f1a1cf5802e38b3c4dcfc9f3cd0dc33bfdc0a30 lua-5.0.2.tar.gz 190442
+SHA256 a6c85d85f912e1c321723084389d63dee7660b81b8292452b190ea7190dd73bc lua-5.0.2.tar.gz 190442
diff --git a/dev-lang/lua/files/lua-5.0.2-LDFLAGS_and_as-needed.patch b/dev-lang/lua/files/lua-5.0.2-LDFLAGS_and_as-needed.patch
new file mode 100644
index 000000000000..c0bd1378bcdc
--- /dev/null
+++ b/dev-lang/lua/files/lua-5.0.2-LDFLAGS_and_as-needed.patch
@@ -0,0 +1,47 @@
+--- lua-5.0.2/config.orig 2006-05-07 17:22:47.000000000 +0200
++++ lua-5.0.2/config 2006-05-07 17:25:35.000000000 +0200
+@@ -35,6 +35,9 @@
+ #
+ #MYLDFLAGS= -Wl,-E
+ #
++# Gentoo addition: this ones will be used for both the binaries and the libs.
++#LDFLAGS=
++#
+ # On Windows systems. support for dynamic loading is enabled by default.
+ # To disable this support, uncomment the next line.
+ #
+--- lua-5.0.2/src/lua/Makefile.orig 2006-05-07 17:30:09.000000000 +0200
++++ lua-5.0.2/src/lua/Makefile 2006-05-07 17:30:32.000000000 +0200
+@@ -13,7 +13,7 @@
+ all: $T
+
+ $T: $(OBJS) $(LIB)/liblua.a $(LIB)/liblualib.a
+- $(CC) -o $@ $(MYLDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
++ $(CC) -o $@ $(MYLDFLAGS) $(LDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
+
+ $(LIB)/liblua.a:
+ cd ..; $(MAKE)
+--- lua-5.0.2/src/luac/Makefile.orig 2006-05-07 17:37:19.000000000 +0200
++++ lua-5.0.2/src/luac/Makefile 2006-05-07 17:37:41.000000000 +0200
+@@ -13,7 +13,7 @@
+ all: $T
+
+ $T: $(OBJS) $(LIB)/liblua.a $(LIB)/liblualib.a
+- $(CC) -o $@ $(MYLDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
++ $(CC) -o $@ $(MYLDFLAGS) $(LDFLAGS) $(OBJS) -L$(LIB) -llua -llualib $(EXTRA_LIBS) $(DLLIB)
+
+ # print.c needs opcode names from lopcodes.c
+ lopcodes.o: ../lopcodes.c ../lopcodes.h
+--- lua-5.0.2/Makefile.orig 2006-05-07 16:50:37.000000000 +0200
++++ lua-5.0.2/Makefile 2006-05-07 17:29:45.000000000 +0200
+@@ -38,8 +38,8 @@
+
+ # shared libraries (for Linux)
+ so:
+- gcc -o lib/liblua.so.$V -shared src/*.o
+- gcc -o lib/liblualib.so.$V -shared src/lib/*.o
++ $(CC) -shared $(LDFLAGS) src/*.o -o lib/liblua.so.$V
++ $(CC) -shared $(LDFLAGS) src/lib/*.o -L$(LIB) -llua $(DLLIB) $(EXTRA_LIBS) -o lib/liblualib.so.$V
+ cd lib; ln -fs liblua.so.$V liblua.so; ln -fs liblualib.so.$V liblualib.so
+
+ # binaries using shared libraries
diff --git a/dev-lang/lua/lua-5.0.2.ebuild b/dev-lang/lua/lua-5.0.2.ebuild
index 05d8d4aaf020..701cf58fc91d 100644
--- a/dev-lang/lua/lua-5.0.2.ebuild
+++ b/dev-lang/lua/lua-5.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.2.ebuild,v 1.19 2005/10/17 23:57:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.0.2.ebuild,v 1.20 2006/06/25 16:55:35 genstef Exp $
inherit eutils
@@ -20,6 +20,7 @@ src_unpack() {
unpack ${A}
epatch ${FILESDIR}/lua-${PV}-pic.patch
+ epatch ${FILESDIR}/lua-${PV}-LDFLAGS_and_as-needed.patch
use ppc-macos && epatch ${FILESDIR}/lua-ppc-macos-Makefile.patch
cd ${S}
@@ -29,6 +30,7 @@ src_unpack() {
-e 's:^#\(LOADLIB= -DUSE_DLOPEN=1\):\1:' \
-e 's:^#\(DLLIB= -ldl\):\1:' \
-e 's:^#\(MYLDFLAGS= -Wl,-E\):\1:' \
+ -e "s:^#\(LDFLAGS=\).*:\1 ${LDFLAGS}:" \
-e 's:^#\(POPEN= -DUSE_POPEN=1\)$:\1:' \
-e "s:^\(MYCFLAGS= \)-O2:\1${CFLAGS}:" \
-e 's:^\(INSTALL_ROOT= \)/usr/local:\1$(DESTDIR)/usr:' \