summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-10-22 22:07:20 +0000
committerMatti Bickel <mabi@gentoo.org>2008-10-22 22:07:20 +0000
commit30e77b1f35c6e730e88456f5269bda430437e5aa (patch)
tree59a97c6a321bdffcdbd7cd624ba9a7a18275a889 /dev-lang/luarocks/luarocks-1.0.ebuild
parentBump to 0.24.1, updated icons and translations. (diff)
downloadgentoo-2-30e77b1f35c6e730e88456f5269bda430437e5aa.tar.gz
gentoo-2-30e77b1f35c6e730e88456f5269bda430437e5aa.tar.bz2
gentoo-2-30e77b1f35c6e730e88456f5269bda430437e5aa.zip
initial rev
(Portage version: 2.2_rc12/cvs/Linux 2.6.23-gentoo-r3-20080120 ppc)
Diffstat (limited to 'dev-lang/luarocks/luarocks-1.0.ebuild')
-rw-r--r--dev-lang/luarocks/luarocks-1.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-lang/luarocks/luarocks-1.0.ebuild b/dev-lang/luarocks/luarocks-1.0.ebuild
new file mode 100644
index 000000000000..57ff169081f2
--- /dev/null
+++ b/dev-lang/luarocks/luarocks-1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/luarocks/luarocks-1.0.ebuild,v 1.1 2008/10/22 22:07:20 mabi Exp $
+
+inherit eutils
+
+DESCRIPTION="A deployment and management system for Lua modules"
+HOMEPAGE="http://www.luarocks.org"
+SRC_URI="http://luaforge.net/frs/download.php/3727/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE="curl openssl"
+
+DEPEND="dev-lang/lua
+ curl? ( net-misc/curl )
+ openssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}
+ app-arch/unzip"
+
+src_compile() {
+ USE_MD5="md5sum"
+ USE_FETCH="wget"
+ use openssl && USE_MD5="openssl"
+ use curl && USE_FETCH="curl"
+
+ # econf doesn't work b/c it passes variables the custom configure can't
+ # handle
+ ./configure \
+ --prefix=/usr \
+ --scripts-dir=/usr/bin \
+ --with-lua=/usr \
+ --with-lua-lib=/usr/$(get_libdir) \
+ --rocks-tree=/usr/lib/lua/luarocks \
+ --with-downloader=$USE_FETCH \
+ --with-md5-checker=$USE_MD5 \
+ --force-config || die "configure failed"
+ emake DESTDIR="${D}" || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall"
+}
+
+pkg_preinst() {
+ find "${D}" -type f | xargs sed -i -e "s:${D}::g" || die "sed failed"
+}
+