summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-04-08 00:08:09 +0000
committerPeter Johanson <latexer@gentoo.org>2005-04-08 00:08:09 +0000
commit23bb0271b7c8eb09b3604ba69a22a03ebe71f314 (patch)
tree94c746a4261098a436beb964a51ccde0c99b56ce /dev-lang/mono
parentFinish cross-gdb support thanks to Scott Price #88169. (diff)
downloadgentoo-2-23bb0271b7c8eb09b3604ba69a22a03ebe71f314.tar.gz
gentoo-2-23bb0271b7c8eb09b3604ba69a22a03ebe71f314.tar.bz2
gentoo-2-23bb0271b7c8eb09b3604ba69a22a03ebe71f314.zip
Add an RDEPEND on libgdiplus, so installs of mono have a working System.Drawing (and SWF correspondingly). See bug #86733. Thanks to Scott Paul Robertson <spr5@email.byu.edu> for pointing it out.
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lang/mono')
-rw-r--r--dev-lang/mono/ChangeLog8
-rw-r--r--dev-lang/mono/mono-1.1.4.ebuild5
-rw-r--r--dev-lang/mono/mono-1.1.5-r1.ebuild3
-rw-r--r--dev-lang/mono/mono-1.1.6.ebuild3
4 files changed, 15 insertions, 4 deletions
diff --git a/dev-lang/mono/ChangeLog b/dev-lang/mono/ChangeLog
index 23582cc79257..fc91c3aed78c 100644
--- a/dev-lang/mono/ChangeLog
+++ b/dev-lang/mono/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/mono
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.39 2005/04/07 23:53:28 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/ChangeLog,v 1.40 2005/04/08 00:08:09 latexer Exp $
+
+ 08 Apr 2005; Peter Johanson <latexer@gentoo.org> mono-1.1.4.ebuild,
+ mono-1.1.5-r1.ebuild, mono-1.1.6.ebuild:
+ Add an RDEPEND on libgdiplus, so installs of mono have a working
+ System.Drawing (and SWF correspondingly). See bug #86733. Thanks to Scott
+ Paul Robertson <spr5@email.byu.edu> for pointing it out.
07 Apr 2005; Peter Johanson <latexer@gentoo.org> -mono-1.0.4.ebuild,
-mono-1.0.4-r1.ebuild:
diff --git a/dev-lang/mono/mono-1.1.4.ebuild b/dev-lang/mono/mono-1.1.4.ebuild
index 04ed5e978325..73f2656d599a 100644
--- a/dev-lang/mono/mono-1.1.4.ebuild
+++ b/dev-lang/mono/mono-1.1.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.4.ebuild,v 1.2 2005/03/31 17:46:37 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.4.ebuild,v 1.3 2005/04/08 00:08:09 latexer Exp $
inherit eutils mono flag-o-matic
@@ -23,9 +23,12 @@ DEPEND="virtual/libc
>=sys-libs/glibc-2.3.3_pre20040420
)"
RDEPEND="${DEPEND}
+ >=dev-dotnet/libgdiplus-${PV}
dev-util/pkgconfig
dev-libs/libxml2"
+PDEPEND=">=dev-dotnet/libgdiplus-${PV}"
+
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/dev-lang/mono/mono-1.1.5-r1.ebuild b/dev-lang/mono/mono-1.1.5-r1.ebuild
index 3cd3de6164ee..27909de02a2c 100644
--- a/dev-lang/mono/mono-1.1.5-r1.ebuild
+++ b/dev-lang/mono/mono-1.1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.5-r1.ebuild,v 1.2 2005/03/31 17:46:37 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.5-r1.ebuild,v 1.3 2005/04/08 00:08:09 latexer Exp $
inherit eutils mono flag-o-matic
@@ -23,6 +23,7 @@ DEPEND="virtual/libc
>=sys-libs/glibc-2.3.3_pre20040420
)"
RDEPEND="${DEPEND}
+ >=dev-dotnet/libgdiplus-1.1.4
dev-util/pkgconfig
dev-libs/libxml2"
diff --git a/dev-lang/mono/mono-1.1.6.ebuild b/dev-lang/mono/mono-1.1.6.ebuild
index a502fa71564d..7a657e845d2e 100644
--- a/dev-lang/mono/mono-1.1.6.ebuild
+++ b/dev-lang/mono/mono-1.1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.6.ebuild,v 1.1 2005/03/31 17:46:37 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono/mono-1.1.6.ebuild,v 1.2 2005/04/08 00:08:09 latexer Exp $
inherit eutils mono flag-o-matic
@@ -23,6 +23,7 @@ DEPEND="virtual/libc
>=sys-libs/glibc-2.3.3_pre20040420
)"
RDEPEND="${DEPEND}
+ >=dev-dotnet/libgdiplus-1.1.4
dev-util/pkgconfig
dev-libs/libxml2"