summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-08-28 07:50:36 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-08-28 07:50:36 +0000
commitc73f9795ca11f963a1c9469a5afe43e705a787e9 (patch)
treee88001e1951393f3db6c4a28d3655ad4a7b57a2c /dev-lang/niecza
parentRespect CFLAGS #432204; Convert to EAPI=4 (diff)
downloadgentoo-2-c73f9795ca11f963a1c9469a5afe43e705a787e9.tar.gz
gentoo-2-c73f9795ca11f963a1c9469a5afe43e705a787e9.tar.bz2
gentoo-2-c73f9795ca11f963a1c9469a5afe43e705a787e9.zip
Bump
(Portage version: 2.2.0_alpha123/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/niecza')
-rw-r--r--dev-lang/niecza/ChangeLog8
-rw-r--r--dev-lang/niecza/files/fix-bootstrap-21.patch13
-rw-r--r--dev-lang/niecza/files/fix-bootstrap-9999.patch13
-rw-r--r--dev-lang/niecza/niecza-21.ebuild58
-rw-r--r--dev-lang/niecza/niecza-9999.ebuild8
5 files changed, 96 insertions, 4 deletions
diff --git a/dev-lang/niecza/ChangeLog b/dev-lang/niecza/ChangeLog
index 34414b6f5230..912fb7c5548c 100644
--- a/dev-lang/niecza/ChangeLog
+++ b/dev-lang/niecza/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/niecza
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza/ChangeLog,v 1.3 2012/08/22 03:50:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza/ChangeLog,v 1.4 2012/08/28 07:50:36 patrick Exp $
+
+*niecza-21 (28 Aug 2012)
+
+ 28 Aug 2012; Patrick Lauer <patrick@gentoo.org> +files/fix-bootstrap-21.patch,
+ +files/fix-bootstrap-9999.patch, +niecza-21.ebuild, niecza-9999.ebuild:
+ Bump
*niecza-9999 (22 Aug 2012)
diff --git a/dev-lang/niecza/files/fix-bootstrap-21.patch b/dev-lang/niecza/files/fix-bootstrap-21.patch
new file mode 100644
index 000000000000..91ad5f82fddf
--- /dev/null
+++ b/dev-lang/niecza/files/fix-bootstrap-21.patch
@@ -0,0 +1,13 @@
+--- Makefile 2012-06-25 22:30:16.000000000 +0800
++++ Makefile.new 2012-08-22 10:55:22.879717085 +0800
+@@ -41,10 +41,6 @@
+ $(RUN_CLR) run/Kernel.dll -gen-app Niecza boot/obj
+
+ .fetch-stamp: FETCH_URL
+- -rm -rf boot/
+- mkdir boot
+- $(WGET_O) boot/niecza.zip $$(cat FETCH_URL)
+- cd boot && unzip niecza.zip
+ NIECZA_KEEP_IL=1 $(RUN_CLR) boot/run/Niecza.exe -C $(libunits)
+ $(CP) boot/run/Kernel.dll boot/obj/
+ touch .fetch-stamp
diff --git a/dev-lang/niecza/files/fix-bootstrap-9999.patch b/dev-lang/niecza/files/fix-bootstrap-9999.patch
new file mode 100644
index 000000000000..00f0e997ebd3
--- /dev/null
+++ b/dev-lang/niecza/files/fix-bootstrap-9999.patch
@@ -0,0 +1,13 @@
+--- Makefile 2012-06-25 22:30:16.000000000 +0800
++++ Makefile.new 2012-08-22 10:55:22.879717085 +0800
+@@ -41,10 +41,6 @@
+ $(RUN_CLR) run/Kernel.dll -gen-app Niecza boot/obj
+
+ .fetch-stamp: FETCH_URL
+- -rm -rf boot/
+- mkdir boot
+- $(WGET_O) boot/niecza.zip $$(cat FETCH_URL)
+- cd boot && unzip niecza.zip
+ NIECZA_KEEP_IL=1 $(RUN_CLR) boot/run/Niecza.exe --obj-dir=boot/obj -C $(libunits)
+ $(CP) boot/run/Kernel.dll boot/obj/
+ touch .fetch-stamp
diff --git a/dev-lang/niecza/niecza-21.ebuild b/dev-lang/niecza/niecza-21.ebuild
new file mode 100644
index 000000000000..abd827e0e3de
--- /dev/null
+++ b/dev-lang/niecza/niecza-21.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza/niecza-21.ebuild,v 1.1 2012/08/28 07:50:36 patrick Exp $
+
+EAPI=4
+
+inherit eutils multilib
+
+GITHUB_CRAP="sorear-niecza-50939fa"
+
+DESCRIPTION="A Perl 6 compiler targetting the CLR with an experimental focus on optimizations."
+HOMEPAGE="https://github.com/sorear/niecza"
+SRC_URI="https://github.com/sorear/niecza/zipball/v${PV} -> niecza-${PV}.zip"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono"
+DEPEND="${RDEPEND}
+ || ( dev-lang/niecza-bin dev-lang/niecza )"
+
+S=${WORKDIR}/${GITHUB_CRAP}
+
+src_prepare() {
+ epatch "${FILESDIR}"/fix-bootstrap-${PV}.patch || die "Failed to fix"
+ cd "${S}"
+ # bootstrap only works from git dirs? sigh :)
+ sed -i -e 's:@git describe --tags:echo "v${PV}":' Makefile
+ # silly workaround for stuff trying to write everywhere: copy the installed niecza here (sigh)
+ # since we have different installation paths for the bin version we need to check here
+ mkdir boot -p
+ if has_version dev-lang/niecza; then
+ cp -r /opt/niecza/* boot/
+ else
+ cp -r /opt/niecza-bin/* boot/
+ fi
+ mkdir -p boot/obj
+}
+
+src_configure() { :; }
+
+src_compile() {
+ export XDG_DATA_HOME="${S}"
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ mkdir -p "${D}"/opt/niecza
+ for i in docs lib obj run README.pod; do
+ cp -r "${S}"/$i "${D}"/opt/niecza/ || die "Failed to install"
+ done
+}
diff --git a/dev-lang/niecza/niecza-9999.ebuild b/dev-lang/niecza/niecza-9999.ebuild
index cfe4d81bff56..47d6bbae2796 100644
--- a/dev-lang/niecza/niecza-9999.ebuild
+++ b/dev-lang/niecza/niecza-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza/niecza-9999.ebuild,v 1.1 2012/08/22 03:50:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/niecza/niecza-9999.ebuild,v 1.2 2012/08/28 07:50:36 patrick Exp $
EAPI=4
@@ -23,10 +23,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${GITHUB_CRAP}
src_prepare() {
- epatch "${FILESDIR}"/fix-bootstrap.patch || die "Failed to fix"
+ epatch "${FILESDIR}"/fix-bootstrap-${PV}.patch || die "Failed to fix"
cd "${S}"
# bootstrap only works from git dirs? sigh :)
- sed -i -e 's:@git describe --tags:echo "v19":' Makefile
+ sed -i -e 's:@git describe --tags:echo "v9999":' Makefile
# silly workaround for stuff trying to write everywhere: copy the installed niecza here (sigh)
# since we have different installation paths for the bin version we need to check here
mkdir boot -p
@@ -35,6 +35,7 @@ src_prepare() {
else
cp -r /opt/niecza-bin/* boot/
fi
+ mkdir -p boot/obj
}
src_configure() { :; }
@@ -44,6 +45,7 @@ src_compile() {
}
src_test() {
+ export XDG_DATA_HOME="${S}"
emake -j1 test || die
}