summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-06-27 07:00:03 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-06-27 07:00:03 +0000
commit26fb2c11291fcba2efce2055c25503275ae788b0 (patch)
treeab4160b0306dc8ce1bb813d6c875ea7debd31257 /dev-lang/nqp
parentdev-python/python-exconsole: Fix QA problems (diff)
downloadgentoo-2-26fb2c11291fcba2efce2055c25503275ae788b0.tar.gz
gentoo-2-26fb2c11291fcba2efce2055c25503275ae788b0.tar.bz2
gentoo-2-26fb2c11291fcba2efce2055c25503275ae788b0.zip
Bump, temporarily disable nqp-parrot as it fails to build
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang/nqp')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2014.06.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index bd29b4353434..c223491817a7 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nqp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.47 2014/05/26 05:25:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.48 2014/06/27 07:00:03 patrick Exp $
+
+*nqp-2014.06 (27 Jun 2014)
+
+ 27 Jun 2014; Patrick Lauer <patrick@gentoo.org> +nqp-2014.06.ebuild:
+ Bump, temporarily disable nqp-parrot as it fails to build
26 May 2014; Patrick Lauer <patrick@gentoo.org> nqp-2014.05.ebuild:
Whitespace
diff --git a/dev-lang/nqp/nqp-2014.06.ebuild b/dev-lang/nqp/nqp-2014.06.ebuild
new file mode 100644
index 000000000000..06c82c5bb2a6
--- /dev/null
+++ b/dev-lang/nqp/nqp-2014.06.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2014.06.ebuild,v 1.1 2014/06/27 07:00:03 patrick Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+GITCRAP=7792847
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+#IUSE="doc +parrot java moar"
+# doesn't build with parrot, disable temporarily
+IUSE="doc java +moar"
+REQUIRED_USE="|| ( java moar )"
+
+RDEPEND="java? ( >=virtual/jre-1.7 )
+ moar? ( =dev-lang/moarvm-${PV} )"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.7 )
+ dev-lang/perl"
+
+S=${WORKDIR}/perl6-nqp-${GITCRAP}
+
+src_configure() {
+ use java && myconf+="jvm,"
+ use moar && myconf+="moar,"
+ perl Configure.pl --backend=${myconf} --prefix=/usr || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README.pod || die
+
+ if use doc; then
+ dodoc -r docs/* || die
+ fi
+}