summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-09-02 19:04:29 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-09-02 19:04:29 +0000
commit5f0fb904e3072cca32c696c89da8ed9afea5c3ba (patch)
treeab3c09201180c1041c0c88463236538855169c12 /dev-lang/ocaml/ocaml-3.06.ebuild
parentfew cleanups, unmasked ocaml (diff)
downloadgentoo-2-5f0fb904e3072cca32c696c89da8ed9afea5c3ba.tar.gz
gentoo-2-5f0fb904e3072cca32c696c89da8ed9afea5c3ba.tar.bz2
gentoo-2-5f0fb904e3072cca32c696c89da8ed9afea5c3ba.zip
new version - bugfix release,
more importantly, old version seems to be pulled off already on the server, thus we need this one to make package install again
Diffstat (limited to 'dev-lang/ocaml/ocaml-3.06.ebuild')
-rw-r--r--dev-lang/ocaml/ocaml-3.06.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-lang/ocaml/ocaml-3.06.ebuild b/dev-lang/ocaml/ocaml-3.06.ebuild
new file mode 100644
index 000000000000..b4da60b76c63
--- /dev/null
+++ b/dev-lang/ocaml/ocaml-3.06.ebuild
@@ -0,0 +1,46 @@
+# Copyright 20022 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.1 2002/09/02 19:04:29 george Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
+SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"
+HOMEPAGE="http://www.ocaml.org/"
+
+DEPEND="virtual/glibc
+ tcltk? ( >=dev-lang/tk-3.3.3 )"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="QPL-1.0 LGPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+src_compile()
+{
+ local myconf
+ use tcltk || myconf="-no-tk"
+
+ ./configure -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/lib/ocaml \
+ -mandir /usr/share/man \
+ --with-pthread ${myconf} || die
+
+ make world || die
+ make opt || die
+ make opt.opt || die
+}
+
+src_install ()
+{
+ make BINDIR=${D}/usr/bin \
+ LIBDIR=${D}/usr/lib/ocaml \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ # silly, silly makefiles
+ dosed "s:${D}::g" /usr/lib/ocaml/ld.conf
+
+ # documentation
+ dodoc Changes INSTALL LICENSE README Upgrading
+}