summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2011-01-16 13:15:52 +0000
committerPatrick Lauer <patrick@gentoo.org>2011-01-16 13:15:52 +0000
commit59725c7dcd9c258974967561ed518462492e97a9 (patch)
treea2c3aea859398a179f27ebe905b59f596611ed86 /dev-lang/parrot
parentdev-java/antlr: fixed bug #349678 (diff)
downloadgentoo-2-59725c7dcd9c258974967561ed518462492e97a9.tar.gz
gentoo-2-59725c7dcd9c258974967561ed518462492e97a9.tar.bz2
gentoo-2-59725c7dcd9c258974967561ed518462492e97a9.zip
Bump, still has issues with pcre #349297
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/parrot')
-rw-r--r--dev-lang/parrot/ChangeLog9
-rw-r--r--dev-lang/parrot/parrot-2.11.0.ebuild79
2 files changed, 86 insertions, 2 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index 12f7452ef012..11256add3f18 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/parrot
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.38 2010/11/01 13:38:21 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.39 2011/01/16 13:15:52 patrick Exp $
+
+*parrot-2.11.0 (16 Jan 2011)
+
+ 16 Jan 2011; Patrick Lauer <patrick@gentoo.org> +parrot-2.11.0.ebuild:
+ Bump, still has issues with pcre #349297
*parrot-2.9.1 (01 Nov 2010)
diff --git a/dev-lang/parrot/parrot-2.11.0.ebuild b/dev-lang/parrot/parrot-2.11.0.ebuild
new file mode 100644
index 000000000000..c35fb6edced7
--- /dev/null
+++ b/dev-lang/parrot/parrot-2.11.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-2.11.0.ebuild,v 1.1 2011/01/16 13:15:52 patrick Exp $
+
+EAPI=3
+
+inherit eutils multilib
+
+DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
+HOMEPAGE="http://www.parrot.org/"
+SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.bz2"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
+
+RDEPEND="sys-libs/readline
+ opengl? ( media-libs/freeglut )
+ nls? ( sys-devel/gettext )
+ unicode? ( >=dev-libs/icu-2.6 )
+ gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
+ gmp? ( >=dev-libs/gmp-4.1.4 )
+ ssl? ( dev-libs/openssl )
+ pcre? ( dev-libs/libpcre )"
+
+DEPEND="dev-lang/perl[doc?]
+ ${RDEPEND}"
+
+src_configure() {
+ myconf="--disable-rpath"
+ use unicode || myconf+=" --without-icu"
+ use ssl || myconf+=" --without-crypto"
+ use gdbm || myconf+=" --without-gdbm"
+ use nls || myconf+=" --without-gettext"
+ use gmp || myconf+=" --without-gmp"
+ use opengl || myconf+=" --without-opengl"
+ use pcre || myconf+=" --without-pcre"
+
+ perl Configure.pl \
+ --ccflags="${CFLAGS}" \
+ --linkflags="${LDFLAGS}" \
+ --prefix="${EROOT}"/usr \
+ --libdir="${EROOT}"/usr/$(get_libdir) \
+ --mandir="${EROOT}"/usr/share/man \
+ --sysconfdir="${EROOT}"/etc \
+ --sharedstatedir="${EROOT}"/var/lib/parrot \
+ --pkgconfigdir=pkgconfig \
+ $myconf || die
+}
+
+src_compile() {
+ export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
+ # occasionally dies in parallel make
+ emake -j1 || die
+ if use doc ; then
+ emake -j1 html || die
+ fi
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake -j1 install-dev DESTDIR="${ED}" DOC_DIR="${EROOT}/usr/share/doc/${PF}" || die
+ dodoc CREDITS DEPRECATED.pod DONORS.pod NEWS PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
+ if use examples; then
+ insinto "${EROOT}/usr/share/doc/${PF}/examples"
+ doins -r examples/* || die
+ fi
+ if use doc; then
+ insinto "${EROOT}/usr/share/doc/${PF}/editor"
+ doins -r editor || die
+ cd docs/html
+ dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
+ pmc.html tools.html docs src tools || die
+ fi
+}