summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-27 19:10:52 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-27 19:10:52 +0000
commit0c99b3e59181ec15f0ad384210417693beb59633 (patch)
tree5a8ba18e026327dc989fbfc0df69eb10ec3d11b0 /dev-lang/python
parentVersion bumped. (diff)
downloadgentoo-2-0c99b3e59181ec15f0ad384210417693beb59633.tar.gz
gentoo-2-0c99b3e59181ec15f0ad384210417693beb59633.tar.bz2
gentoo-2-0c99b3e59181ec15f0ad384210417693beb59633.zip
disabling pkg_setup again after testing with stage2
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog5
-rw-r--r--dev-lang/python/python-2.3.3.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ec7598908fe5..41870ce7b4f8 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.74 2004/01/26 12:04:53 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.75 2004/01/27 19:10:52 liquidx Exp $
+
+ 27 Jan 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild:
+ disabling pkg_setup again after testing with stage2
26 Jan 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild:
re-instating pkg_setup() warning/abort message. added apache mime.types to
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index aede86041f46..c80bed8bc48c 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.9 2004/01/26 12:04:53 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.10 2004/01/27 19:10:52 liquidx Exp $
inherit flag-o-matic python
@@ -43,7 +43,10 @@ PROVIDE="virtual/python"
# add portage to DEPENDS otherwise it'll create a circular dependency
# NOTE: we don't need this any more as sys-apps/portage-2.0.49-r18 is
# already stable
-pkg_setup() {
+# NOTE2: OK, the reason this is _now_ disabled is because Gentoo 1.4
+# stage2 should upgrade fine to 2.3.3 even with the presence of
+# an old portage
+pkg_setup_disabled() {
if ! has_version ">=sys-apps/portage-2.0.49-r16"; then
eerror "Dependency Failed! Requires >=sys-apps/portage-2.0.49-r16"
eerror "Please run: emerge portage"