summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-10-03 17:09:20 +0000
committerFabian Groffen <grobian@gentoo.org>2009-10-03 17:09:20 +0000
commit379934ce116ee953e33671400fed0c373c76d1dc (patch)
tree8744d9cc43f9a1194127200d1d8155b938a65f16 /dev-lang/python
parentamd64/x86 stable, bug #287314 (diff)
downloadgentoo-2-379934ce116ee953e33671400fed0c373c76d1dc.tar.gz
gentoo-2-379934ce116ee953e33671400fed0c373c76d1dc.tar.bz2
gentoo-2-379934ce116ee953e33671400fed0c373c76d1dc.zip
Python's _locale module needs libintl, which on non-Linux is in gettext, depend on virtual/libintl for that case
(Portage version: 2.2.00.14475-prefix/cvs/Darwin powerpc, RepoMan options: --force)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog8
-rw-r--r--dev-lang/python/python-2.4.6.ebuild3
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild3
-rw-r--r--dev-lang/python/python-2.6.2-r2.ebuild3
-rw-r--r--dev-lang/python/python-2.6.3.ebuild3
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild3
6 files changed, 17 insertions, 6 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 264661671323..b73b2df2ddc5 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.423 2009/10/02 16:03:27 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.424 2009/10/03 17:09:20 grobian Exp $
+
+ 03 Oct 2009; Fabian Groffen <grobian@gentoo.org> python-2.4.6.ebuild,
+ python-2.5.4-r3.ebuild, python-2.6.2-r2.ebuild, python-2.6.3.ebuild,
+ python-3.1.1-r1.ebuild:
+ Python's _locale module needs libintl, which on non-Linux is in gettext,
+ depend on virtual/libintl for that case
*python-2.6.3 (02 Oct 2009)
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index a71927bbeddb..4fa66924f917 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.19 2009/09/28 14:27:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.20 2009/10/03 17:09:20 grobian Exp $
EAPI="1"
@@ -28,6 +28,7 @@ IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
+ virtual/libintl
!build? (
berkdb? ( || (
sys-libs/db:4.4
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index 9ae4e47962fd..4460383d82c5 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.21 2009/09/28 14:27:53 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.22 2009/10/03 17:09:20 grobian Exp $
EAPI="1"
@@ -31,6 +31,7 @@ IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlit
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
+ virtual/libintl
!build? (
berkdb? ( || (
sys-libs/db:4.5
diff --git a/dev-lang/python/python-2.6.2-r2.ebuild b/dev-lang/python/python-2.6.2-r2.ebuild
index 1cf56891ce9b..ef8115f8c17d 100644
--- a/dev-lang/python/python-2.6.2-r2.ebuild
+++ b/dev-lang/python/python-2.6.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.10 2009/10/02 04:46:17 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.11 2009/10/03 17:09:20 grobian Exp $
EAPI="2"
@@ -31,6 +31,7 @@ IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlit
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
+ virtual/libintl
virtual/libffi
!build? (
berkdb? ( || (
diff --git a/dev-lang/python/python-2.6.3.ebuild b/dev-lang/python/python-2.6.3.ebuild
index 1ab4d13fd524..58e694ce6957 100644
--- a/dev-lang/python/python-2.6.3.ebuild
+++ b/dev-lang/python/python-2.6.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.1 2009/10/02 16:03:27 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.3.ebuild,v 1.2 2009/10/03 17:09:20 grobian Exp $
EAPI="2"
@@ -31,6 +31,7 @@ IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlit
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
+ virtual/libintl
virtual/libffi
!build? (
berkdb? ( || (
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index c09e25ca6b64..0aa4d8112917 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.9 2009/10/02 04:46:17 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.10 2009/10/03 17:09:20 grobian Exp $
EAPI="2"
@@ -28,6 +28,7 @@ IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite ssl +t
RDEPEND=">=app-admin/eselect-python-20090606
>=sys-libs/zlib-1.1.3
+ virtual/libintl
virtual/libffi
!build? (
doc? ( dev-python/python-docs:${SLOT} )