summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-25 17:09:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-25 17:09:38 +0000
commit62fc045b9f0baf7a1275c44c6da0454bf970a228 (patch)
treebc11f14716d5a2a5a892303b14b7e4375bc1baa5 /dev-lang/python
parentRevision bump. Add a patch to fix bug #304153. Thanks Matthew Turnbull for re... (diff)
downloadgentoo-2-62fc045b9f0baf7a1275c44c6da0454bf970a228.tar.gz
gentoo-2-62fc045b9f0baf7a1275c44c6da0454bf970a228.tar.bz2
gentoo-2-62fc045b9f0baf7a1275c44c6da0454bf970a228.zip
Work around bug #321145.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.4.6.ebuild8
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild8
-rw-r--r--dev-lang/python/python-2.6.4-r1.ebuild6
-rw-r--r--dev-lang/python/python-2.6.5-r2.ebuild8
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild8
6 files changed, 25 insertions, 20 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 5c3b4319cad4..c83dc4427e4d 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.470 2010/05/24 13:55:59 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.471 2010/05/25 17:09:38 arfrever Exp $
+
+ 25 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-2.4.6.ebuild, python-2.5.4-r4.ebuild, python-2.6.4-r1.ebuild,
+ python-2.6.5-r2.ebuild, python-3.1.2-r3.ebuild:
+ Work around bug #321145.
24 May 2010; <nixnut@gentoo.org> python-2.6.5-r2.ebuild:
ppc stable #319723
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 709685c6e9b2..b3e16894f21e 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.38 2010/05/23 20:13:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.39 2010/05/25 17:09:38 arfrever Exp $
EAPI="1"
@@ -18,6 +18,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.4"
+PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb bootstrap build +cxx doc elibc_uclibc examples gdbm ipv6 +ncurses +readline +ssl +threads tk +wide-unicode wininst +xml"
@@ -47,8 +48,7 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
- python_set_active_version ${SLOT}
- # python_pkg_setup
+ python_pkg_setup
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
@@ -284,7 +284,7 @@ pkg_postinst() {
eselect_python_update
# Python 2.4 partially doesn't respect $(get_libdir).
- python_mod_optimize -x "/(site-packages|test|tests)/" /usr/lib/python${SLOT}
+ python_mod_optimize -f -x "/(site-packages|test|tests)/" /usr/lib/python${SLOT}
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index d2f81d4b494d..d2963e335bc5 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.20 2010/05/23 20:13:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.21 2010/05/25 17:09:38 arfrever Exp $
EAPI="1"
@@ -18,6 +18,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.5"
+PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -54,8 +55,7 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
- python_set_active_version ${SLOT}
- # python_pkg_setup
+ python_pkg_setup
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
@@ -297,7 +297,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "/(site-packages|test|tests)/" $(python_get_libdir)
+ python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-2.6.4-r1.ebuild b/dev-lang/python/python-2.6.4-r1.ebuild
index 6629e0ed53ef..41d50d9f0cd9 100644
--- a/dev-lang/python/python-2.6.4-r1.ebuild
+++ b/dev-lang/python/python-2.6.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.11 2010/05/20 21:14:09 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.4-r1.ebuild,v 1.12 2010/05/25 17:09:38 arfrever Exp $
EAPI="2"
@@ -18,6 +18,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
+PYTHON_ABI="${SLOT}"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -57,8 +58,7 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
- python_set_active_version ${SLOT}
- # python_pkg_setup
+ python_pkg_setup
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
diff --git a/dev-lang/python/python-2.6.5-r2.ebuild b/dev-lang/python/python-2.6.5-r2.ebuild
index 09dd1b5d670d..69ac8ade712f 100644
--- a/dev-lang/python/python-2.6.5-r2.ebuild
+++ b/dev-lang/python/python-2.6.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.10 2010/05/24 13:55:59 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.11 2010/05/25 17:09:38 arfrever Exp $
EAPI="2"
@@ -18,6 +18,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="2.6"
+PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ~m68k ~mips ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="-berkdb build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -57,8 +58,7 @@ PDEPEND="app-admin/python-updater"
PROVIDE="virtual/python"
pkg_setup() {
- python_set_active_version ${SLOT}
- # python_pkg_setup
+ python_pkg_setup
if use berkdb; then
ewarn "\"bsddb\" module is out-of-date and no longer maintained inside dev-lang/python. It has"
@@ -289,7 +289,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "/(site-packages|test|tests)/" $(python_get_libdir)
+ python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "${python_updater_warning}" == "1" ]]; then
ewarn
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index a19d2442afdd..f5c41589458c 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.8 2010/05/23 20:13:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.9 2010/05/25 17:09:38 arfrever Exp $
EAPI="3"
@@ -18,6 +18,7 @@ SRC_URI="http://www.python.org/ftp/python/${PV}/${MY_P}.tar.bz2
LICENSE="PSF-2.2"
SLOT="3.1"
+PYTHON_ABI="${SLOT}"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="build doc elibc_uclibc examples gdbm ipv6 +ncurses +readline sqlite +ssl +threads tk +wide-unicode wininst +xml"
@@ -50,8 +51,7 @@ PDEPEND=">=app-admin/python-updater-0.8
PROVIDE="virtual/python"
pkg_setup() {
- python_set_active_version ${SLOT}
- # python_pkg_setup
+ python_pkg_setup
}
src_prepare() {
@@ -272,7 +272,7 @@ eselect_python_update() {
pkg_postinst() {
eselect_python_update
- python_mod_optimize -x "/(site-packages|test|tests)/" $(python_get_libdir)
+ python_mod_optimize -f -x "/(site-packages|test|tests)/" $(python_get_libdir)
if [[ "$(eselect python show)" == "python2."* ]]; then
ewarn