summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 21:16:36 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 21:16:36 +0000
commit7dc4fe8bae0c3ce25bc3eca183ad724a4c0f0a1d (patch)
tree3c9452a7b40e96d7f6f330c4d8694f6b3502d8ec /dev-lang/python
parentMarked ~ppc-macos, bug #296981 (diff)
downloadgentoo-2-7dc4fe8bae0c3ce25bc3eca183ad724a4c0f0a1d.tar.gz
gentoo-2-7dc4fe8bae0c3ce25bc3eca183ad724a4c0f0a1d.tar.bz2
gentoo-2-7dc4fe8bae0c3ce25bc3eca183ad724a4c0f0a1d.zip
Use --with-computed-gotos (bug #296574).
(Portage version: 15121-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/python')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-3.1.1-r1.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index ce0ff4ab0aec..c2c286bd1fd3 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.437 2009/12/13 16:34:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.438 2009/12/19 21:16:36 arfrever Exp $
+
+ 19 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-3.1.1-r1.ebuild:
+ Use --with-computed-gotos (bug #296574).
13 Dec 2009; Raúl Porcel <armin76@gentoo.org> python-2.6.4.ebuild,
python-3.1.1-r1.ebuild:
diff --git a/dev-lang/python/python-3.1.1-r1.ebuild b/dev-lang/python/python-3.1.1-r1.ebuild
index 6f5b84782392..6f0fd6b29831 100644
--- a/dev-lang/python/python-3.1.1-r1.ebuild
+++ b/dev-lang/python/python-3.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.20 2009/12/13 16:34:03 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.1-r1.ebuild,v 1.21 2009/12/19 21:16:36 arfrever Exp $
EAPI="2"
@@ -149,9 +149,8 @@ src_configure() {
local dbmliborder
if use gdbm; then
- dbmliborder+=":gdbm"
+ dbmliborder+="${dbmliborder:+:}gdbm"
fi
- dbmliborder="${dbmliborder#:}"
econf \
--with-fpectl \
@@ -161,6 +160,7 @@ src_configure() {
$(use_with wide-unicode) \
--infodir='${prefix}'/share/info \
--mandir='${prefix}'/share/man \
+ --with-computed-gotos \
--with-dbmliborder=${dbmliborder} \
--with-libc='' \
--with-system-ffi