summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2006-08-09 15:38:03 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2006-08-09 15:38:03 +0000
commit9c3bb2e197b0ea493c1cc5c805ae55869b4fc706 (patch)
tree787220966c92a04a9002b937af121bd645e0c8b3 /dev-lang/squeak/squeak-3.9.7.ebuild
parentstable on amd64 (diff)
downloadgentoo-2-9c3bb2e197b0ea493c1cc5c805ae55869b4fc706.tar.gz
gentoo-2-9c3bb2e197b0ea493c1cc5c805ae55869b4fc706.tar.bz2
gentoo-2-9c3bb2e197b0ea493c1cc5c805ae55869b4fc706.zip
Adding new version of squeak. bug #141615
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'dev-lang/squeak/squeak-3.9.7.ebuild')
-rw-r--r--dev-lang/squeak/squeak-3.9.7.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-lang/squeak/squeak-3.9.7.ebuild b/dev-lang/squeak/squeak-3.9.7.ebuild
new file mode 100644
index 000000000000..d9f6a89fe223
--- /dev/null
+++ b/dev-lang/squeak/squeak-3.9.7.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/squeak/squeak-3.9.7.ebuild,v 1.1 2006/08/09 15:38:03 araujo Exp $
+
+inherit base versionator fixheadtails eutils
+
+MY_PV=$(replace_version_separator 2 '-')
+DESCRIPTION="Highly-portable Smalltalk-80 implementation"
+HOMEPAGE="http://www.squeak.org/"
+SRC_URI="http://squeakvm.org/unix/release/Squeak-${MY_PV}.src.tar.gz"
+LICENSE="Apple"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="X mmx threads iconv"
+
+DEPEND="dev-libs/libffi
+ ( || ( ( x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXt )
+ virtual/x11 ) )"
+RDEPEND="${DEPEND}
+ virtual/squeak-image"
+
+S="${WORKDIR}/Squeak-${MY_PV}"
+
+src_unpack() {
+ base_src_unpack
+ cd ${S}
+ ht_fix_all
+}
+
+src_compile() {
+ local myconf=""
+ use X || myconf="--without-x"
+ use mmx && myconf="${myconf} --enable-mpg-mmx"
+ use threads && myconf="${myconf} --enable-mpg-pthread"
+ use iconv || myconf="${myconf} --disable-iconv"
+ cd ${S}
+ mkdir build
+ cd build
+ ../platforms/unix/config/configure \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --with-ffi=x86-sysv \
+ ${myconf} || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ cd ${S}/build
+ make ROOT=${D} docdir=/usr/share/doc/${PF} install || die
+ exeinto /usr/lib/squeak
+ doexe inisqueak
+ dosym /usr/lib/squeak/inisqueak /usr/bin/inisqueak
+}
+
+pkg_postinst() {
+ einfo "Run 'inisqueak' to get a private copy of the squeak image."
+}