summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-05-09 22:44:31 +0000
committerMike Frysinger <vapier@gentoo.org>2014-05-09 22:44:31 +0000
commitdd66c6f530bea869356115073774355ed930fd08 (patch)
treeaa3757e25d1d1ce28cd42e207947eea82bcb011a /dev-lang/yasm
parentRun code generator bootstrap #509592 by Anthony Ryan. (diff)
downloadgentoo-2-dd66c6f530bea869356115073774355ed930fd08.tar.gz
gentoo-2-dd66c6f530bea869356115073774355ed930fd08.tar.bz2
gentoo-2-dd66c6f530bea869356115073774355ed930fd08.zip
Run tests in parallel.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/ChangeLog8
-rw-r--r--dev-lang/yasm/yasm-1.2.0-r1.ebuild8
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild8
3 files changed, 18 insertions, 6 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index a7b8903d9882..d9c779b0925d 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/yasm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.62 2013/06/30 15:09:42 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.63 2014/05/09 22:44:31 vapier Exp $
+
+ 09 May 2014; Mike Frysinger <vapier@gentoo.org> yasm-1.2.0-r1.ebuild,
+ yasm-9999.ebuild:
+ Run tests in parallel.
30 Jun 2013; Justin Lecher <jlec@gentoo.org> yasm-1.2.0-r1.ebuild,
yasm-9999.ebuild, metadata.xml:
diff --git a/dev-lang/yasm/yasm-1.2.0-r1.ebuild b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
index 18afed96e34b..f7087e4064e3 100644
--- a/dev-lang/yasm/yasm-1.2.0-r1.ebuild
+++ b/dev-lang/yasm/yasm-1.2.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.2.0-r1.ebuild,v 1.3 2013/06/30 15:09:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.2.0-r1.ebuild,v 1.4 2014/05/09 22:44:31 vapier Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -45,3 +45,7 @@ src_configure() {
$(use_enable python python-bindings) \
$(use_enable nls)
}
+
+src_test() {
+ emake check
+}
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
index 83c7ab5abd8b..803e424a7c13 100644
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-9999.ebuild,v 1.6 2013/06/30 15:09:42 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-9999.ebuild,v 1.7 2014/05/09 22:44:31 vapier Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -60,3 +60,7 @@ src_configure() {
$(use_enable python python-bindings) \
$(use_enable nls)
}
+
+src_test() {
+ emake check
+}