summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-01-10 18:33:03 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-01-10 18:33:03 +0000
commit102aae8120569cd60fb35be6ba0dfff22eba695e (patch)
tree92bb15c7d34ab04caafb834d701f2db99d1f2f81 /dev-lang
parentBump as per #451222 (diff)
downloadgentoo-2-102aae8120569cd60fb35be6ba0dfff22eba695e.tar.gz
gentoo-2-102aae8120569cd60fb35be6ba0dfff22eba695e.tar.bz2
gentoo-2-102aae8120569cd60fb35be6ba0dfff22eba695e.zip
version bump (fixes bug #450786, thx to upstream)
(Portage version: 2.2.0_alpha150/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/ChangeLog8
-rw-r--r--dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch35
-rw-r--r--dev-lang/ispc/ispc-1.3.1.ebuild (renamed from dev-lang/ispc/ispc-1.3.0.ebuild)7
3 files changed, 10 insertions, 40 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index e29e25486144..e5300e1362c6 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/ispc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.8 2013/01/08 05:43:51 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.9 2013/01/10 18:33:03 ottxor Exp $
+
+*ispc-1.3.1 (10 Jan 2013)
+
+ 10 Jan 2013; Christoph Junghans <ottxor@gentoo.org> +ispc-1.3.1.ebuild,
+ -files/ispc-1.3.0-gcc-4.7.patch, -ispc-1.3.0.ebuild:
+ version bump (fixes bug #450786, thx to upstream)
08 Jan 2013; Christoph Junghans <ottxor@gentoo.org> -ispc-1.2.2.ebuild,
ispc-1.3.0.ebuild:
diff --git a/dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch b/dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch
deleted file mode 100644
index b82bc82860cb..000000000000
--- a/dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -Naur ispc-ispc-c6ec130.orig/ispc.cpp ispc-ispc-c6ec130/ispc.cpp
---- ispc-ispc-c6ec130.orig/ispc.cpp 2012-06-29 09:38:38.000000000 -0600
-+++ ispc-ispc-c6ec130/ispc.cpp 2012-07-20 13:24:38.000000000 -0600
-@@ -40,6 +40,7 @@
- #include "util.h"
- #include "llvmutil.h"
- #include <stdio.h>
-+#include <unistd.h>
- #ifdef ISPC_IS_WINDOWS
- #include <windows.h>
- #include <direct.h>
-diff -Naur ispc-ispc-c6ec130.orig/lex.ll ispc-ispc-c6ec130/lex.ll
---- ispc-ispc-c6ec130.orig/lex.ll 2012-06-29 09:38:38.000000000 -0600
-+++ ispc-ispc-c6ec130/lex.ll 2012-07-20 13:37:15.000000000 -0600
-@@ -41,6 +41,7 @@
- #include "parse.hh"
- #include <stdlib.h>
- #include <stdint.h>
-+#include <unistd.h>
-
- static uint64_t lParseBinary(const char *ptr, SourcePos pos, char **endPtr);
- static int lParseInteger(bool dotdotdot);
-diff -Naur ispc-ispc-c6ec130.orig/main.cpp ispc-ispc-c6ec130/main.cpp
---- ispc-ispc-c6ec130.orig/main.cpp 2012-06-29 09:38:38.000000000 -0600
-+++ ispc-ispc-c6ec130/main.cpp 2012-07-20 13:25:18.000000000 -0600
-@@ -41,6 +41,9 @@
- #include "type.h"
- #include <stdio.h>
- #include <stdlib.h>
-+#include <sys/types.h>
-+#include <unistd.h>
-+
- #ifdef ISPC_IS_WINDOWS
- #include <time.h>
- #endif // ISPC_IS_WINDOWS
diff --git a/dev-lang/ispc/ispc-1.3.0.ebuild b/dev-lang/ispc/ispc-1.3.1.ebuild
index cb1f11e974ea..7f87ae4560dd 100644
--- a/dev-lang/ispc/ispc-1.3.0.ebuild
+++ b/dev-lang/ispc/ispc-1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.4 2013/01/08 05:43:51 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.1.ebuild,v 1.1 2013/01/10 18:33:03 ottxor Exp $
EAPI=4
@@ -17,7 +17,6 @@ if [[ ${PV} = *9999 ]]; then
else
inherit vcs-snapshot
SRC_URI="https://github.com/${PN}/${PN}/tarball/v${PV} -> ${P}.tar.gz"
- PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
fi
LICENSE="BSD BSD-2 UoI-NCSA"
@@ -26,8 +25,8 @@ KEYWORDS="~amd64 ~x86"
IUSE="examples"
RDEPEND="
- || ( =sys-devel/clang-3.0* =sys-devel/clang-3.1* )
- || ( =sys-devel/llvm-3.0* =sys-devel/llvm-3.1* )
+ >=sys-devel/clang-3.0
+ >=sys-devel/llvm-3.0
"
DEPEND="
${RDEPEND}