summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-19 11:50:33 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-19 11:50:33 +0000
commit17ab78748289948949296faa0a5242186c1422ae (patch)
tree2290ee2f6530237f28791eff43314f0ef7e760e2 /dev-lang
parentmark 1.5 stable for x86; version bump for unstable (diff)
downloadgentoo-2-17ab78748289948949296faa0a5242186c1422ae.tar.gz
gentoo-2-17ab78748289948949296faa0a5242186c1422ae.tar.bz2
gentoo-2-17ab78748289948949296faa0a5242186c1422ae.zip
disabling portage check
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/files/digest-python-2.3.2-r21
-rw-r--r--dev-lang/python/python-2.3.2-r2.ebuild172
-rw-r--r--dev-lang/python/python-2.3.3.ebuild6
4 files changed, 10 insertions, 176 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 7566803cb5fd..4b0b15a1a506 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.68 2004/01/18 01:43:57 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.69 2004/01/19 11:50:33 liquidx Exp $
+
+ 19 Jan 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.2-r2.ebuild,
+ python-2.3.3.ebuild:
+ disable portage check because stable portage already is compatible with
+ python-2.3
18 Jan 2004; Alastair Tse <liquidx@gentoo.org> python-2.3.3.ebuild:
make ROOT var more robust during postinst()
diff --git a/dev-lang/python/files/digest-python-2.3.2-r2 b/dev-lang/python/files/digest-python-2.3.2-r2
deleted file mode 100644
index 416c04df6929..000000000000
--- a/dev-lang/python/files/digest-python-2.3.2-r2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f54d7a529d444994b4b33429bbb45479 Python-2.3.2.tgz 8459427
diff --git a/dev-lang/python/python-2.3.2-r2.ebuild b/dev-lang/python/python-2.3.2-r2.ebuild
deleted file mode 100644
index 23da4181f1c1..000000000000
--- a/dev-lang/python/python-2.3.2-r2.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.2-r2.ebuild,v 1.8 2004/01/04 20:42:16 liquidx Exp $
-
-inherit flag-o-matic python
-
-MY_PV=${PV/_rc/c}
-PYVER_MAJOR="`echo ${PV%_*} | cut -d '.' -f 1`"
-PYVER_MINOR="`echo ${PV%_*} | cut -d '.' -f 2`"
-PYVER="${PYVER_MAJOR}.${PYVER_MINOR}"
-
-S="${WORKDIR}/Python-${MY_PV}"
-DESCRIPTION="A really great language"
-SRC_URI="http://www.python.org/ftp/python/${PV%_*}/Python-${MY_PV}.tgz"
-HOMEPAGE="http://www.python.org"
-
-IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2"
-LICENSE="PSF-2.2"
-SLOT="2.3"
-
-KEYWORDS="~x86 ~ppc"
-# "~ppc ~sparc ~alpha ~mips ~hppa ~arm"
-
-DEPEND="virtual/glibc
- >=sys-libs/zlib-1.1.3
- !build? ( tcltk? ( >=dev-lang/tk-8.0 )
- ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
- berkdb? ( >=sys-libs/db-3.1 )
- gdbm? ( sys-libs/gdbm )
- ssl? ( dev-libs/openssl )
- doc? ( =dev-python/python-docs-${PV}* )
- dev-libs/expat
- )"
-
-RDEPEND="${DEPEND} dev-python/python-fchksum"
-
-# The dev-python/python-fchksum RDEPEND is needed to that this python provides
-# the functionality expected from previous pythons.
-
-PROVIDE="virtual/python"
-
-# this is to stop people shooting themselves in the foot. we can't
-# add portage to DEPENDS otherwise it'll create a circular dependency
-pkg_setup() {
- if ! has_version ">=sys-apps/portage-2.0.49-r16"; then
- eerror "Dependency Failed! Requires >=sys-apps/portage-2.0.49-r16"
- eerror "Please run: emerge portage"
- eerror "before proceeding. (NOTE: do not use -u if portage wants you to upgrade python)"
- die "Requires >=sys-apps/portage-2.0.49-r16"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- # adds /usr/lib/portage/pym to sys.path - liquidx (08 Oct 03)
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3-add_portage_search_path.patch
- # adds support for PYTHON_DONTCOMPILE shell environment to
- # supress automatic generation of .pyc and .pyo files - liquidx (08 Oct 03)
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3-gentoo_py_dontcompile.patch
- EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-2.3.2-disable_modules_and_ssl.patch
-}
-
-src_configure() {
- # disable extraneous modules with extra dependencies
- if [ -n "`use build`" ]; then
- export PYTHON_DISABLE_MODULES="readline pyexpat dbm gdbm bsddb _curses _curses_panel _tkinter"
- export PYTHON_DISABLE_SSL=1
- else
- use gdbm \
- || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} gdbm"
- use berkdb \
- || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} dbm bsddb"
- use readline \
- || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} readline"
- use tcltk \
- || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _tkinter"
- use ncurses \
- || PYTHON_DISABLE_MODULES="${PYTHON_DISABLE_MODULES} _curses _curses_panel"
- use ssl \
- || export PYTHON_DISABLE_SSL=1
- export PYTHON_DISABLE_MODULES
- fi
-}
-
-src_compile() {
- filter-flags -malign-double
-
- [ "${ARCH}" = "hppa" ] && append-flags -fPIC
- [ "${ARCH}" = "alpha" ] && append-flags -fPIC
- [ "${ARCH}" = "amd64" ] && append-flags -fPIC
-
- export OPT="${CFLAGS}"
-
- local myconf
- #if we are creating a new build image, we remove the dependency on g++
- if [ "`use build`" -a ! "`use bootstrap`" ]; then
- myconf="--with-cxx=no"
- fi
-
- # super-secret switch. don't use this unless you know what you're
- # doing. enabling UCS2 support will break your existing python
- # modules
- use ucs2 \
- && myconf="${myconf} --enable-unicode=ucs2" \
- || myconf="${myconf} --enable-unicode=ucs4"
-
- src_configure
-
- econf --with-fpectl \
- --enable-shared \
- `use_enable ipv6` \
- --infodir='${prefix}'/share/info \
- --mandir='${prefix}'/share/man \
- --with-threads \
- ${myconf} || die
- emake || die "Parallel make failed"
-}
-
-src_install() {
- dodir /usr
- src_configure
- make DESTDIR="${D}" altinstall || die
-
- # install our own custom python-config
- exeinto /usr/bin
- newexe ${FILESDIR}/python-config-${PYVER} python-config
-
- # The stuff below this line extends from 2.1, and should be deprecated
- # in 2.3, or possibly can wait till 2.4
-
- # seems like the build do not install Makefile.pre.in anymore
- # it probably shouldn't - use DistUtils, people!
- insinto /usr/lib/python${PYVER}/config
- doins ${S}/Makefile.pre.in
-
- # While we're working on the config stuff... Let's fix the OPT var
- # so that it doesn't have any opts listed in it. Prevents the problem
- # with compiling things with conflicting opts later.
- dosed -e 's:^OPT=.*:OPT=-DNDEBUG:' /usr/lib/python${PYVER}/config/Makefile
-
-}
-
-pkg_postrm() {
- python_makesym
- python_mod_cleanup /usr/lib/python2.3
-}
-
-pkg_postinst() {
- python_makesym
- python_mod_optimize
- python_mod_optimize -x site-packages -x test ${ROOT}usr/lib/python${PYVER}
-
- echo
- ewarn
- ewarn "If you have just upgraded from python-2.2.x you will need to run:"
- ewarn
- ewarn "${PORTDIR}/dev-lang/python/files/python-updater"
- ewarn
- ewarn "This will automatically rebuild all the python dependent modules"
- ewarn "to run with python-2.3."
- ewarn
- ewarn "Python 2.2 is still installed and can be accessed via /usr/bin/python2.2."
- ewarn "Portage-2.0.49-r8 and below will continue to use python-2.2.x, so"
- ewarn "think twice about uninstalling it, otherwise your system will break."
- ewarn
- echo -ne "\a"; sleep 1
- echo -ne "\a"; sleep 1
- echo -ne "\a"; sleep 1
- echo -ne "\a"; sleep 1
- echo -ne "\a"; sleep 1
-
-}
diff --git a/dev-lang/python/python-2.3.3.ebuild b/dev-lang/python/python-2.3.3.ebuild
index 5d40138f4140..4c7b2df22044 100644
--- a/dev-lang/python/python-2.3.3.ebuild
+++ b/dev-lang/python/python-2.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.2 2004/01/18 01:43:57 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.3.ebuild,v 1.3 2004/01/19 11:50:33 liquidx Exp $
inherit flag-o-matic python
@@ -41,7 +41,9 @@ PROVIDE="virtual/python"
# this is to stop people shooting themselves in the foot. we can't
# add portage to DEPENDS otherwise it'll create a circular dependency
-pkg_setup() {
+# NOTE: we don't need this any more as sys-apps/portage-2.0.49-r18 is
+# already stable
+pkg_setup_disabled() {
if ! has_version ">=sys-apps/portage-2.0.49-r16"; then
eerror "Dependency Failed! Requires >=sys-apps/portage-2.0.49-r16"
eerror "Please run: emerge portage"