summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-09-30 08:55:53 +0000
committerRichard Brown <rbrown@gentoo.org>2007-09-30 08:55:53 +0000
commit1d481401c1978a693b9fcfe4ea65ab11304a23e7 (patch)
tree5711cd4faeec2697cd02c5e5d86996c1b34532df /dev-lang
parentFix bug #194236. Bump 1.8.6 to p111 as p110-r1. Bump 1.8.5 to p114 as p113, u... (diff)
downloadgentoo-2-1d481401c1978a693b9fcfe4ea65ab11304a23e7.tar.gz
gentoo-2-1d481401c1978a693b9fcfe4ea65ab11304a23e7.tar.bz2
gentoo-2-1d481401c1978a693b9fcfe4ea65ab11304a23e7.zip
Commited wrong ebuilds
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ruby-1.8.5_p113.ebuild16
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild17
2 files changed, 6 insertions, 27 deletions
diff --git a/dev-lang/ruby/ruby-1.8.5_p113.ebuild b/dev-lang/ruby/ruby-1.8.5_p113.ebuild
index b2eb8d241e6f..006aeb2a2311 100644
--- a/dev-lang/ruby/ruby-1.8.5_p113.ebuild
+++ b/dev-lang/ruby/ruby-1.8.5_p113.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5_p113.ebuild,v 1.1 2007/09/30 08:44:50 rbrown Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.5_p113.ebuild,v 1.2 2007/09/30 08:55:53 rbrown Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -22,7 +22,7 @@ SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.gz
LICENSE="Ruby"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="cjk debug doc elibc_glibc examples ipv6 rubytests socks5 threads tk"
+IUSE="cjk debug doc examples ipv6 rubytests socks5 threads tk"
RDEPEND=">=sys-libs/gdbm-1.8.0
>=sys-libs/readline-4.1
@@ -77,22 +77,12 @@ src_compile() {
append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
fi
- # Bug #168939
- # We need to always enable ipv6, use --with-lookup-order-hack=INET
- # when we don't want ipv6 with glibc
- if use elibc_glibc; then
- myconf="--enable-ipv6"
- if ! use ipv6; then
- myconf="${myconf} --with-lookup-order-hack=INET"
- fi
- else
- myconf=$(use_enable ipv6)
- fi
econf --program-suffix=$MY_SUFFIX --enable-shared \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \
$(use_enable threads pthread) \
+ $(use_enable ipv6) \
$(use_enable debug) \
$(use_with tk) \
${myconf} \
diff --git a/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild b/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild
index 94513d46b213..5e58dd7424ef 100644
--- a/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild
+++ b/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild,v 1.1 2007/09/30 08:44:50 rbrown Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p110-r1.ebuild,v 1.2 2007/09/30 08:55:53 rbrown Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -22,7 +22,7 @@ SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.gz
LICENSE="Ruby"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="cjk debug doc elibc_glibc examples ipv6 rubytests socks5 threads tk"
+IUSE="cjk debug doc examples ipv6 rubytests socks5 threads tk"
RDEPEND=">=sys-libs/gdbm-1.8.0
>=sys-libs/readline-4.1
@@ -80,22 +80,11 @@ src_compile() {
append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
fi
- # Bug #168939
- # We need to always enable ipv6, use --with-lookup-order-hack=INET
- # when we don't want ipv6 with glibc
- if use elibc_glibc; then
- myconf="--enable-ipv6"
- if ! use ipv6; then
- myconf="${myconf} --with-lookup-order-hack=INET"
- fi
- else
- myconf=$(use_enable ipv6)
- fi
-
econf --program-suffix=$MY_SUFFIX --enable-shared \
$(use_enable socks5 socks) \
$(use_enable doc install-doc) \
$(use_enable threads pthread) \
+ $(use_enable ipv6) \
$(use_enable debug) \
$(use_with tk) \
${myconf} \