summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-07-31 14:29:09 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-07-31 14:29:09 +0000
commit2ade4d6d890a159104f3f230a37de06956f30227 (patch)
tree36b4100ff6f3f89abb9690a20a9a45e6d034e35d /dev-lang
parentx86 stable wrt bug #512846 (diff)
downloadgentoo-2-2ade4d6d890a159104f3f230a37de06956f30227.tar.gz
gentoo-2-2ade4d6d890a159104f3f230a37de06956f30227.tar.bz2
gentoo-2-2ade4d6d890a159104f3f230a37de06956f30227.zip
add live version, thanks to Heather Cynede for patch
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust/ChangeLog8
-rw-r--r--dev-lang/rust/files/rust-0.12.0-no-ldconfig.patch27
-rw-r--r--dev-lang/rust/rust-9999.ebuild99
3 files changed, 133 insertions, 1 deletions
diff --git a/dev-lang/rust/ChangeLog b/dev-lang/rust/ChangeLog
index 7d25f34f9cdb..cdbde54a4bd2 100644
--- a/dev-lang/rust/ChangeLog
+++ b/dev-lang/rust/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/rust
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.2 2014/07/31 09:52:41 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/ChangeLog,v 1.3 2014/07/31 14:29:09 jauhien Exp $
+
+*rust-9999 (31 Jul 2014)
+
+ 31 Jul 2014; Jauhien Piatlicki <jauhien@gentoo.org>
+ +files/rust-0.12.0-no-ldconfig.patch, +rust-9999.ebuild:
+ add live version, thanks to Heather Cynede for patch
*rust-0.11.0 (31 Jul 2014)
diff --git a/dev-lang/rust/files/rust-0.12.0-no-ldconfig.patch b/dev-lang/rust/files/rust-0.12.0-no-ldconfig.patch
new file mode 100644
index 000000000000..b3b78f990e1f
--- /dev/null
+++ b/dev-lang/rust/files/rust-0.12.0-no-ldconfig.patch
@@ -0,0 +1,27 @@
+Remove ldconfig(1) execution to prevent the installation script from accessing
+outside of a sandbox.
+
+Author: Heather Cynede
+
+diff --git a/src/etc/install.sh b/src/etc/install.sh
+index c949743..7c3daa5 100644
+--- a/src/etc/install.sh
++++ b/src/etc/install.sh
+@@ -466,17 +466,6 @@ while read p; do
+ # The manifest lists all files to install
+ done < "${CFG_SRC_DIR}/${CFG_LIBDIR_RELATIVE}/rustlib/manifest.in"
+
+-# Run ldconfig to make dynamic libraries available to the linker
+-if [ "$CFG_OSTYPE" = "Linux" ]
+- then
+- ldconfig
+- if [ $? -ne 0 ]
+- then
+- warn "failed to run ldconfig."
+- warn "this may happen when not installing as root and may be fine"
+- fi
+-fi
+-
+ # Sanity check: can we run the installed binaries?
+ #
+ # As with the verification above, make sure the right LD_LIBRARY_PATH-equivalent
diff --git a/dev-lang/rust/rust-9999.ebuild b/dev-lang/rust/rust-9999.ebuild
new file mode 100644
index 000000000000..63ae345aac8c
--- /dev/null
+++ b/dev-lang/rust/rust-9999.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/rust/rust-9999.ebuild,v 1.1 2014/07/31 14:29:09 jauhien Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit elisp-common eutils git-r3 python-any-r1
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+EGIT_REPO_URI="git://github.com/rust-lang/rust.git"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="clang debug emacs libcxx vim-syntax zsh-completion"
+REQUIRED_USE="libcxx? ( clang )"
+
+RDEPEND="vim-syntax? ( || ( app-editors/vim app-editors/gvim ) )
+ zsh-completion? ( app-shells/zsh )"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ >=dev-lang/perl-5.0
+ clang? ( sys-devel/clang )
+ emacs? ( virtual/emacs )
+ libcxx? ( sys-libs/libcxx )"
+
+SITEFILE="50${PN}-mode-gentoo.el"
+
+src_unpack() {
+ git-r3_src_unpack
+
+ use amd64 && BUILD_TRIPLE=x86_64-unknown-linux-gnu
+ use x86 && BUILD_TRIPLE=i686-unknown-linux-gnu
+ export CFG_SRC_DIR="${S}" && \
+ cd ${S} && \
+ mkdir -p "${S}/dl" && \
+ mkdir -p "${S}/${BUILD_TRIPLE}/stage0/bin" && \
+ python2 "${S}/src/etc/get-snapshot.py" ${BUILD_TRIPLE} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.12.0-no-ldconfig.patch"
+}
+
+src_configure() {
+ "${ECONF_SOURCE:-.}"/configure \
+ --prefix="${EPREFIX}/usr/" \
+ $(use_enable clang) \
+ $(use_enable debug) \
+ $(use_enable debug llvm-assertions) \
+ $(use_enable !debug optimize) \
+ $(use_enable !debug optimize-cxx) \
+ $(use_enable !debug optimize-llvm) \
+ $(use_enable !debug optimize-tests) \
+ $(use_enable libcxx libcpp) \
+ --disable-manage-submodules \
+ || die
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ cd src/etc/emacs || die
+ elisp-compile *.el
+ elisp-make-autoload-file "${PN}-mode-autoloads.el" .
+ fi
+}
+
+src_install() {
+ default
+
+ if use emacs; then
+ elisp-install ${PN}-mode src/etc/emacs/*.el src/etc/emacs/*.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r src/etc/vim/*
+ fi
+
+ if use zsh-completion; then
+ insinto "/usr/share/zsh/site-functions"
+ doins src/etc/zsh/_rust
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}