summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2010-01-09 14:29:08 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2010-01-09 14:29:08 +0000
commit2c3e07743847f3b0555260aa862f36b1d49472b5 (patch)
treeea80c283aae2f51cf5266388fa8b1b32841a76f0 /dev-lang
parentRemove old revision. (diff)
downloadgentoo-2-2c3e07743847f3b0555260aa862f36b1d49472b5.tar.gz
gentoo-2-2c3e07743847f3b0555260aa862f36b1d49472b5.tar.bz2
gentoo-2-2c3e07743847f3b0555260aa862f36b1d49472b5.zip
Split compiling to multiple ant invocations to lower resources needed to build. Hopefully fixes bug #282023.
(Portage version: 2.2_rc61/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/scala/ChangeLog8
-rw-r--r--dev-lang/scala/scala-2.7.7.ebuild10
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-lang/scala/ChangeLog b/dev-lang/scala/ChangeLog
index a1e11f258a49..a52ef039fea7 100644
--- a/dev-lang/scala/ChangeLog
+++ b/dev-lang/scala/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/scala
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/scala/ChangeLog,v 1.18 2009/11/30 09:16:19 ali_bush Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/scala/ChangeLog,v 1.19 2010/01/09 14:29:08 betelgeuse Exp $
+
+ 09 Jan 2010; Petteri Räty <betelgeuse@gentoo.org> scala-2.7.7.ebuild:
+ Split compiling to multiple ant invocations to lower resources needed to
+ build. Hopefully fixes bug #282023.
*scala-2.7.7 (30 Nov 2009)
diff --git a/dev-lang/scala/scala-2.7.7.ebuild b/dev-lang/scala/scala-2.7.7.ebuild
index f3799ec9cc1a..27eef75e814c 100644
--- a/dev-lang/scala/scala-2.7.7.ebuild
+++ b/dev-lang/scala/scala-2.7.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/scala/scala-2.7.7.ebuild,v 1.1 2009/11/30 09:16:19 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/scala/scala-2.7.7.ebuild,v 1.2 2010/01/09 14:29:08 betelgeuse Exp $
JAVA_PKG_IUSE="doc examples source"
WANT_ANT_TASKS="ant-nodeps"
@@ -78,7 +78,11 @@ src_unpack() {
src_compile() {
if ! use binary; then
- eant all.clean dist.done
+ # reported in bugzilla that multiple launches use less resources
+ # https://bugs.gentoo.org/show_bug.cgi?id=282023
+ eant all.clean
+ eant build
+ eant dist.done
else
einfo "Skipping compilation, USE=binary is set."
fi