summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2012-07-20 19:58:21 +0000
committerChristoph Junghans <ottxor@gentoo.org>2012-07-20 19:58:21 +0000
commit3fe6c1dc44fe13d25444f5e1a7c1e8010751c33b (patch)
treeb1efb6ccec4b2698fbfb13196ad17f336b1d5647 /dev-lang
parentStable ppc, bug #424125 (diff)
downloadgentoo-2-3fe6c1dc44fe13d25444f5e1a7c1e8010751c33b.tar.gz
gentoo-2-3fe6c1dc44fe13d25444f5e1a7c1e8010751c33b.tar.bz2
gentoo-2-3fe6c1dc44fe13d25444f5e1a7c1e8010751c33b.zip
fix build with gcc-4.7 (bug #427376)
(Portage version: 2.2.0_alpha120/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/ChangeLog7
-rw-r--r--dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch35
-rw-r--r--dev-lang/ispc/ispc-1.3.0.ebuild7
3 files changed, 44 insertions, 5 deletions
diff --git a/dev-lang/ispc/ChangeLog b/dev-lang/ispc/ChangeLog
index 9e636c5125c1..c2d418817c5f 100644
--- a/dev-lang/ispc/ChangeLog
+++ b/dev-lang/ispc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ispc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.4 2012/07/07 00:48:30 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ChangeLog,v 1.5 2012/07/20 19:58:21 ottxor Exp $
+
+ 20 Jul 2012; Christoph Junghans <ottxor@gentoo.org>
+ +files/ispc-1.3.0-gcc-4.7.patch, ispc-1.3.0.ebuild:
+ fix build with gcc-4.7 (bug #427376)
*ispc-1.3.0 (07 Jul 2012)
@@ -18,4 +22,3 @@
14 Jun 2012; Christoph Junghans <ottxor@gentoo.org> +ispc-1.2.2.ebuild,
+metadata.xml:
initial commit
-
diff --git a/dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch b/dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch
new file mode 100644
index 000000000000..b82bc82860cb
--- /dev/null
+++ b/dev-lang/ispc/files/ispc-1.3.0-gcc-4.7.patch
@@ -0,0 +1,35 @@
+diff -Naur ispc-ispc-c6ec130.orig/ispc.cpp ispc-ispc-c6ec130/ispc.cpp
+--- ispc-ispc-c6ec130.orig/ispc.cpp 2012-06-29 09:38:38.000000000 -0600
++++ ispc-ispc-c6ec130/ispc.cpp 2012-07-20 13:24:38.000000000 -0600
+@@ -40,6 +40,7 @@
+ #include "util.h"
+ #include "llvmutil.h"
+ #include <stdio.h>
++#include <unistd.h>
+ #ifdef ISPC_IS_WINDOWS
+ #include <windows.h>
+ #include <direct.h>
+diff -Naur ispc-ispc-c6ec130.orig/lex.ll ispc-ispc-c6ec130/lex.ll
+--- ispc-ispc-c6ec130.orig/lex.ll 2012-06-29 09:38:38.000000000 -0600
++++ ispc-ispc-c6ec130/lex.ll 2012-07-20 13:37:15.000000000 -0600
+@@ -41,6 +41,7 @@
+ #include "parse.hh"
+ #include <stdlib.h>
+ #include <stdint.h>
++#include <unistd.h>
+
+ static uint64_t lParseBinary(const char *ptr, SourcePos pos, char **endPtr);
+ static int lParseInteger(bool dotdotdot);
+diff -Naur ispc-ispc-c6ec130.orig/main.cpp ispc-ispc-c6ec130/main.cpp
+--- ispc-ispc-c6ec130.orig/main.cpp 2012-06-29 09:38:38.000000000 -0600
++++ ispc-ispc-c6ec130/main.cpp 2012-07-20 13:25:18.000000000 -0600
+@@ -41,6 +41,9 @@
+ #include "type.h"
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <sys/types.h>
++#include <unistd.h>
++
+ #ifdef ISPC_IS_WINDOWS
+ #include <time.h>
+ #endif // ISPC_IS_WINDOWS
diff --git a/dev-lang/ispc/ispc-1.3.0.ebuild b/dev-lang/ispc/ispc-1.3.0.ebuild
index 521d2d8045d4..737a2ec58149 100644
--- a/dev-lang/ispc/ispc-1.3.0.ebuild
+++ b/dev-lang/ispc/ispc-1.3.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.1 2012/07/07 00:48:30 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ispc/ispc-1.3.0.ebuild,v 1.2 2012/07/20 19:58:21 ottxor Exp $
EAPI=4
-inherit toolchain-funcs
+inherit base toolchain-funcs
DESCRIPTION="Intel SPMD Program Compiler"
HOMEPAGE="http://ispc.github.com/"
@@ -34,7 +34,7 @@ DEPEND="
sys-devel/flex
"
-DOCS=( README.rst )
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
src_compile() {
emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
@@ -42,6 +42,7 @@ src_compile() {
src_install() {
dobin ispc
+ dodoc README.rst
if use examples; then
insinto "/usr/share/doc/${PF}/examples"