summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2006-04-22 23:55:44 +0000
committerKeri Harris <keri@gentoo.org>2006-04-22 23:55:44 +0000
commit56077cfe19ccb7a95368c9bc608decc95a679edb (patch)
treedeccd20dcd0f2b8526cf7244bc39b14dce0a24df /dev-lang
parentrepoman: Trim trailing whitespace (diff)
downloadgentoo-2-56077cfe19ccb7a95368c9bc608decc95a679edb.tar.gz
gentoo-2-56077cfe19ccb7a95368c9bc608decc95a679edb.tar.bz2
gentoo-2-56077cfe19ccb7a95368c9bc608decc95a679edb.zip
Do not run ssl testsuite if threading is disabled. Reported by Krzysiek Pawlik <nelchael@gentoo.org> in bug #130895
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/swi-prolog/ChangeLog8
-rw-r--r--dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch42
-rw-r--r--dev-lang/swi-prolog/files/swi-prolog-packages-test.patch42
3 files changed, 91 insertions, 1 deletions
diff --git a/dev-lang/swi-prolog/ChangeLog b/dev-lang/swi-prolog/ChangeLog
index f42991219ced..16ba706a6c0c 100644
--- a/dev-lang/swi-prolog/ChangeLog
+++ b/dev-lang/swi-prolog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/swi-prolog
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.7 2006/04/19 07:29:27 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/swi-prolog/ChangeLog,v 1.8 2006/04/22 23:55:44 keri Exp $
+
+ 22 Apr 2006; Keri Harris <keri@gentoo.org>
+ files/swi-prolog-packages-test.patch,
+ files/swi-prolog-packages-test-r1.patch:
+ Do not run ssl testsuite if threading is disabled. Reported by Krzysiek
+ Pawlik <nelchael@gentoo.org> in bug #130895
19 Apr 2006; Keri Harris <keri@gentoo.org> swi-prolog-5.6.8.ebuild,
swi-prolog-5.6.9.ebuild, swi-prolog-5.6.10.ebuild,
diff --git a/dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch b/dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch
index 9919dc2029c1..cbb1c7a4f793 100644
--- a/dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch
+++ b/dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch
@@ -73,6 +73,48 @@
+ fi
+--- pl-5.6.4.orig/packages/ssl/configure.in 2006-02-04 04:38:50.000000000 +1300
++++ pl-5.6.4/packages/ssl/configure.in 2006-02-13 23:55:12.000000000 +1300
+@@ -19,13 +19,16 @@
+ AC_SUBST(TARGETS)
+ AC_SUBST(PLTARGETS)
+ AC_SUBST(RUNTEX)
++AC_SUBST(ENABLE_CHECKS)
+
+ AC_ARG_ENABLE(mt, [ --enable-mt Enable Multi-threading],
+ [case "$enableval" in
+ yes) AC_DEFINE([_REENTRANT], 1,
+ [Define to support threads])
++ ENABLE_CHECKS="yes"
++ ;;
++ *) ENABLE_CHECKS="no"
+ ;;
+- *) ;;
+ esac])
+
+ if test -z "$PLINCL"; then
+--- pl-5.6.4.orig/packages/ssl/Makefile.in 2005-05-11 20:45:37.000000000 +1200
++++ pl-5.6.4/packages/ssl/Makefile.in 2006-01-03 16:11:28.000000000 +1300
+@@ -42,6 +42,8 @@
+ LD=@LD@
+ LDFLAGS=@LDSOFLAGS@
+
++ENABLE_CHECKS=@ENABLE_CHECKS@
++
+ INSTALL=@INSTALL@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_DATA=@INSTALL_DATA@
+@@ -128,7 +130,9 @@
+ ################################################################
+
+ check::
+- $(PL) -q -f ssl_test.pl -F none -g test,halt -t 'halt(1)'
++ @if test $(ENABLE_CHECKS) == "yes" ; then \
++ $(PL) -q -f ssl_test.pl -F none -g test,halt -t 'halt(1)' ; \
++ fi
+
+ ################################################################
+ # Clean
--- pl-5.6.9.orig/packages/ssl/ssl_test.pl 2006-02-14 04:27:41.000000000 +1300
+++ pl-5.6.9/packages/ssl/ssl_test.pl 2006-03-27 21:18:14.000000000 +1200
@@ -130,8 +130,8 @@
diff --git a/dev-lang/swi-prolog/files/swi-prolog-packages-test.patch b/dev-lang/swi-prolog/files/swi-prolog-packages-test.patch
index 0327fb79f646..a3da07ed3d74 100644
--- a/dev-lang/swi-prolog/files/swi-prolog-packages-test.patch
+++ b/dev-lang/swi-prolog/files/swi-prolog-packages-test.patch
@@ -73,6 +73,48 @@
+ fi
+--- pl-5.6.8.orig/packages/ssl/configure.in 2006-02-04 04:38:50.000000000 +1300
++++ pl-5.6.8/packages/ssl/configure.in 2006-02-13 23:55:12.000000000 +1300
+@@ -19,13 +19,16 @@
+ AC_SUBST(TARGETS)
+ AC_SUBST(PLTARGETS)
+ AC_SUBST(RUNTEX)
++AC_SUBST(ENABLE_CHECKS)
+
+ AC_ARG_ENABLE(mt, [ --enable-mt Enable Multi-threading],
+ [case "$enableval" in
+ yes) AC_DEFINE([_REENTRANT], 1,
+ [Define to support threads])
++ ENABLE_CHECKS="yes"
++ ;;
++ *) ENABLE_CHECKS="no"
+ ;;
+- *) ;;
+ esac])
+
+ if test -z "$PLINCL"; then
+--- pl-5.6.8.orig/packages/ssl/Makefile.in 2005-05-11 20:45:37.000000000 +1200
++++ pl-5.6.8/packages/ssl/Makefile.in 2006-01-03 16:11:28.000000000 +1300
+@@ -42,6 +42,8 @@
+ LD=@LD@
+ LDFLAGS=@LDSOFLAGS@
+
++ENABLE_CHECKS=@ENABLE_CHECKS@
++
+ INSTALL=@INSTALL@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_DATA=@INSTALL_DATA@
+@@ -128,7 +130,9 @@
+ ################################################################
+
+ check::
+- $(PL) -q -f ssl_test.pl -F none -g test,halt -t 'halt(1)'
++ @if test $(ENABLE_CHECKS) == "yes" ; then \
++ $(PL) -q -f ssl_test.pl -F none -g test,halt -t 'halt(1)' ; \
++ fi
+
+ ################################################################
+ # Clean
--- pl-5.6.4.orig/packages/xpce/src/Makefile.in 2006-02-13 05:44:13.000000000 +1300
+++ pl-5.6.4/packages/xpce/src/Makefile.in 2006-02-13 23:59:59.000000000 +1300
@@ -55,6 +55,7 @@