summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2005-01-05 20:31:16 +0000
committerRob Cakebread <pythonhead@gentoo.org>2005-01-05 20:31:16 +0000
commit5fb8f4113bbcb38e3bd1568a8b6f71b79d237016 (patch)
tree439f962ff34cece0543fadaf83114d9093f681de /dev-lang
parentRemoved old version. Added crypto to maintainers. Version bump. x86 stable to... (diff)
downloadgentoo-2-5fb8f4113bbcb38e3bd1568a8b6f71b79d237016.tar.gz
gentoo-2-5fb8f4113bbcb38e3bd1568a8b6f71b79d237016.tar.bz2
gentoo-2-5fb8f4113bbcb38e3bd1568a8b6f71b79d237016.zip
Fixed lib64 patch
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/files/python-2.4-lib64.patch144
1 files changed, 54 insertions, 90 deletions
diff --git a/dev-lang/python/files/python-2.4-lib64.patch b/dev-lang/python/files/python-2.4-lib64.patch
index c2b37feb4946..c3e2c4ffcca9 100644
--- a/dev-lang/python/files/python-2.4-lib64.patch
+++ b/dev-lang/python/files/python-2.4-lib64.patch
@@ -1,6 +1,6 @@
-diff -Nru Python-2.3.4.old/Lib/distutils/command/install.py Python-2.3.4/Lib/distutils/command/install.py
---- Python-2.3.4.old/Lib/distutils/command/install.py 2004-08-14 21:38:57.318696000 -0400
-+++ Python-2.3.4/Lib/distutils/command/install.py 2004-08-14 21:39:41.285012104 -0400
+diff -Nru Python-2.4.old/Lib/distutils/command/install.py Lib/distutils/command/install.py
+--- Python-2.4.old/Lib/distutils/command/install.py 2004-08-14 21:38:57.318696000 -0400
++++ Lib/distutils/command/install.py 2004-08-14 21:39:41.285012104 -0400
@@ -39,14 +39,14 @@
INSTALL_SCHEMES = {
'unix_prefix': {
@@ -18,9 +18,9 @@ diff -Nru Python-2.3.4.old/Lib/distutils/command/install.py Python-2.3.4/Lib/dis
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -Nru Python-2.3.4.old/Lib/distutils/sysconfig.py Python-2.3.4/Lib/distutils/sysconfig.py
---- Python-2.3.4.old/Lib/distutils/sysconfig.py 2004-08-14 21:38:57.367688552 -0400
-+++ Python-2.3.4/Lib/distutils/sysconfig.py 2004-08-14 21:39:41.300009824 -0400
+diff -Nru Python-2.4.old/Lib/distutils/sysconfig.py Lib/distutils/sysconfig.py
+--- Python-2.4.old/Lib/distutils/sysconfig.py 2004-08-14 21:38:57.367688552 -0400
++++ Lib/distutils/sysconfig.py 2004-08-14 21:39:41.300009824 -0400
@@ -99,8 +99,12 @@
prefix = plat_specific and EXEC_PREFIX or PREFIX
@@ -35,46 +35,27 @@ diff -Nru Python-2.3.4.old/Lib/distutils/sysconfig.py Python-2.3.4/Lib/distutils
if standard_lib:
return libpython
else:
-diff -Nru Python-2.3.4.old/Lib/site.py Python-2.3.4/Lib/site.py
---- Python-2.3.4.old/Lib/site.py 2004-08-14 21:38:57.565658456 -0400
-+++ Python-2.3.4/Lib/site.py 2004-08-14 21:39:41.318007088 -0400
-@@ -166,9 +166,14 @@
- sitedirs = [os.path.join(prefix, "Lib", "site-packages")]
- elif os.sep == '/':
- sitedirs = [os.path.join(prefix,
-+ "lib64",
-+ "python" + sys.version[:3],
-+ "site-packages"),
-+ os.path.join(prefix,
- "lib",
- "python" + sys.version[:3],
- "site-packages"),
-+ os.path.join(prefix, "lib64", "site-python"),
- os.path.join(prefix, "lib", "site-python")]
- else:
- sitedirs = [prefix, os.path.join(prefix, "lib", "site-packages")]
-diff -Nru Python-2.3.4.old/Lib/test/test_re.py Python-2.3.4/Lib/test/test_re.py
---- Python-2.3.4.old/Lib/test/test_re.py 2004-08-14 21:38:56.631800424 -0400
-+++ Python-2.3.4/Lib/test/test_re.py 2004-08-14 21:39:34.240083096 -0400
-@@ -497,6 +497,15 @@
- self.assert_(re.compile('bug_926075') is not
- re.compile(eval("u'bug_926075'")))
-
-+ def test_bug_931848(self):
-+ try:
-+ unicode
-+ except NameError:
-+ pass
-+ pattern = eval('u"[\u002E\u3002\uFF0E\uFF61]"')
-+ self.assertEqual(re.compile(pattern).split("a.b.c"),
-+ ['a','b','c'])
-+
- def run_re_tests():
- from test.re_tests import benchmarks, tests, SUCCEED, FAIL, SYNTAX_ERROR
- if verbose:
-diff -Nru Python-2.3.4.old/Makefile.pre.in Python-2.3.4/Makefile.pre.in
---- Python-2.3.4.old/Makefile.pre.in 2004-08-14 21:39:00.506211424 -0400
-+++ Python-2.3.4/Makefile.pre.in 2004-08-14 21:39:41.341003592 -0400
+diff -Nru Lib/site.py.old Lib/site.py
+--- Lib/site.py.old 2005-01-05 10:50:32.642936080 -0800
++++ Lib/site.py 2005-01-05 10:54:44.698617792 -0800
+@@ -179,9 +179,14 @@
+ sitedirs = [os.path.join(prefix, "Lib", "site-packages")]
+ elif os.sep == '/':
+ sitedirs = [os.path.join(prefix,
++ "lib64",
++ "python" + sys.version[:3],
++ "site-packages"),
++ os.path.join(prefix,
+ "lib",
+ "python" + sys.version[:3],
+ "site-packages"),
++ os.path.join(prefix, "lib64", "site-python"),
+ os.path.join(prefix, "lib", "site-python")]
+ sitedirs = [os.path.join(prefix,"lib","portage","pym")] + sitedirs
+ else:
+diff -Nru Python-2.4.old/Makefile.pre.in Makefile.pre.in
+--- Python-2.4.old/Makefile.pre.in 2004-08-14 21:39:00.506211424 -0400
++++ Makefile.pre.in 2004-08-14 21:39:41.341003592 -0400
@@ -79,11 +79,11 @@
# Expanded directories
@@ -89,19 +70,19 @@ diff -Nru Python-2.3.4.old/Makefile.pre.in Python-2.3.4/Makefile.pre.in
# Detailed destination directories
BINLIBDEST= $(LIBDIR)/python$(VERSION)
-diff -Nru Python-2.3.4.old/Modules/Setup.dist Python-2.3.4/Modules/Setup.dist
---- Python-2.3.4.old/Modules/Setup.dist 2004-08-14 21:39:00.761172664 -0400
-+++ Python-2.3.4/Modules/Setup.dist 2004-08-14 21:42:09.073544832 -0400
-@@ -343,7 +343,7 @@
+diff -Nru Python-2.4.old/Modules/getpath.c Modules/getpath.c
+--- Modules/Setup.dist.old 2005-01-05 11:59:12.421634520 -0800
++++ Modules/Setup.dist 2005-01-05 12:00:58.292539696 -0800
+@@ -325,7 +325,7 @@
# *** Uncomment and edit to reflect your Tcl/Tk versions:
# -ltk8.2 -ltcl8.2 \
# *** Uncomment and edit to reflect where your X11 libraries are:
-# -L/usr/X11R6/lib \
-+ -L/usr/X11R6/lib64 \
++ -L/usr/X11R6/lib64 \
# *** Or uncomment this for Solaris:
# -L/usr/openwin/lib \
# *** Uncomment these for TOGL extension only:
-@@ -417,7 +417,7 @@
+@@ -396,7 +396,7 @@
#DB=/usr/local/BerkeleyDB.4.0
#DBLIBVER=4.0
#DBINC=$(DB)/include
@@ -110,18 +91,17 @@ diff -Nru Python-2.3.4.old/Modules/Setup.dist Python-2.3.4/Modules/Setup.dist
#_bsddb _bsddb.c -I$(DBINC) -L$(DBLIB) -ldb-$(DBLIBVER)
# Historical Berkeley DB 1.85
-@@ -463,7 +463,7 @@
+@@ -442,7 +442,7 @@
# Andrew Kuchling's zlib module.
# This require zlib 1.1.3 (or later).
- # See http://www.cdrom.com/pub/infozip/zlib/
+ # See http://www.gzip.org/zlib/
-#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz
+zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib64 -lz
# Interface to the Expat XML parser
#
-diff -Nru Python-2.3.4.old/Modules/getpath.c Python-2.3.4/Modules/getpath.c
---- Python-2.3.4.old/Modules/getpath.c 2004-08-14 21:39:00.750174336 -0400
-+++ Python-2.3.4/Modules/getpath.c 2004-08-14 21:39:41.319006936 -0400
+--- Python-2.4.old/Modules/getpath.c 2004-08-14 21:39:00.750174336 -0400
++++ Modules/getpath.c 2004-08-14 21:39:41.319006936 -0400
@@ -112,8 +112,8 @@
#endif
@@ -159,29 +139,20 @@ diff -Nru Python-2.3.4.old/Modules/getpath.c Python-2.3.4/Modules/getpath.c
+ joinpath(exec_prefix, "lib64/lib-dynload");
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-
-diff -Nru Python-2.3.4.old/setup.py Python-2.3.4/setup.py
---- Python-2.3.4.old/setup.py 2004-08-14 21:39:00.575200936 -0400
-+++ Python-2.3.4/setup.py 2004-08-14 21:39:41.340003744 -0400
-@@ -241,7 +241,7 @@
-
+
+diff -Nru setup.py.old setup.py
+--- setup.py.old 2005-01-05 12:05:34.809502728 -0800
++++ setup.py 2005-01-05 12:14:29.522214040 -0800
+@@ -247,7 +247,7 @@
def detect_modules(self):
+ global disable_ssl
# Ensure that /usr/local is always used
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib')
+ add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib64')
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
- # fink installs lots of goodies in /sw/... - make sure we
-@@ -264,7 +264,7 @@
- # lib_dirs and inc_dirs are used to search for files;
- # if a file is found in one of those directories, it can
- # be assumed that no additional -I,-L directives are needed.
-- lib_dirs = self.compiler.library_dirs + ['/lib', '/usr/lib']
-+ lib_dirs = self.compiler.library_dirs + ['/lib64', '/usr/lib64']
- inc_dirs = self.compiler.include_dirs + ['/usr/include']
- exts = []
-
-@@ -413,11 +413,11 @@
+ # Add paths to popular package managers on OS X/darwin
+@@ -437,11 +437,11 @@
elif self.compiler.find_library_file(lib_dirs, 'curses'):
readline_libs.append('curses')
elif self.compiler.find_library_file(lib_dirs +
@@ -194,8 +165,8 @@ diff -Nru Python-2.3.4.old/setup.py Python-2.3.4/setup.py
+ library_dirs=['/usr/lib64/termcap'],
libraries=readline_libs) )
if platform not in ['mac']:
- # crypt module.
-@@ -446,8 +446,8 @@
+ # crypt module.
+@@ -470,8 +470,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
@@ -206,7 +177,7 @@ diff -Nru Python-2.3.4.old/setup.py Python-2.3.4/setup.py
] )
if (ssl_incs is not None and
-@@ -481,12 +481,12 @@
+@@ -502,23 +502,23 @@
# order you wish to search - e.g., search for db4 before db3
db_try_this = {
'db4': {'libs': ('db-4.2', 'db42', 'db-4.1', 'db41', 'db-4.0', 'db4',),
@@ -220,35 +191,28 @@ diff -Nru Python-2.3.4.old/setup.py Python-2.3.4/setup.py
+ '/usr/local/lib64',
'/opt/sfw',
- '/sw/lib',
-+ '/sw/lib64',
++ '/sw/libi64',
),
- 'incdirs': ('/usr/local/BerkeleyDB.4.2/include',
- '/usr/local/include/db42',
-@@ -499,12 +499,12 @@
+ 'incdirs': ('/usr/include/db4.2',
+ '/usr/include/db4.1',
'/usr/include/db4',
)},
- 'db3': {'libs': ('db-3.3', 'db-3.2', 'db-3.1', 'db3',),
+ 'db3': {'libs': ('db-3.3', 'db-3.2', 'db3',),
- 'libdirs': ('/usr/local/BerkeleyDB.3.3/lib',
- '/usr/local/BerkeleyDB.3.2/lib',
-- '/usr/local/BerkeleyDB.3.1/lib',
- '/usr/local/lib',
- '/opt/sfw/lib',
- '/sw/lib',
+ 'libdirs': ('/usr/local/BerkeleyDB.3.3/lib64',
+ '/usr/local/BerkeleyDB.3.2/lib64',
-+ '/usr/local/BerkeleyDB.3.1/lib64',
+ '/usr/local/lib64',
+ '/opt/sfw/lib64',
+ '/sw/lib64',
),
'incdirs': ('/usr/local/BerkeleyDB.3.3/include',
'/usr/local/BerkeleyDB.3.2/include',
-@@ -986,14 +986,14 @@
- added_lib_dirs.append('/usr/openwin/lib')
- elif os.path.exists('/usr/X11R6/include'):
- include_dirs.append('/usr/X11R6/include')
-- added_lib_dirs.append('/usr/X11R6/lib')
-+ added_lib_dirs.append('/usr/X11R6/lib64')
+@@ -1000,11 +1000,11 @@
+ added_lib_dirs.append('/usr/X11R6/lib')
elif os.path.exists('/usr/X11R5/include'):
include_dirs.append('/usr/X11R5/include')
- added_lib_dirs.append('/usr/X11R5/lib')