summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2010-04-16 18:48:02 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2010-04-16 18:48:02 +0000
commit7c899601eaf56f538221c5c4c425a9778a62366e (patch)
treee3df6d4b8dd34fc097b91e9adeff476a33d0ba29 /dev-lang
parentStable on amd64 wrt bug #288745 (diff)
downloadgentoo-2-7c899601eaf56f538221c5c4c425a9778a62366e.tar.gz
gentoo-2-7c899601eaf56f538221c5c4c425a9778a62366e.tar.bz2
gentoo-2-7c899601eaf56f538221c5c4c425a9778a62366e.zip
Fixing build time dependencies. Avoiding installation of empty dir /usr/man/man1, see bug #315401.
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tinycobol/ChangeLog7
-rw-r--r--dev-lang/tinycobol/tinycobol-0.64.ebuild6
-rw-r--r--dev-lang/tinycobol/tinycobol-0.65.9.ebuild6
3 files changed, 14 insertions, 5 deletions
diff --git a/dev-lang/tinycobol/ChangeLog b/dev-lang/tinycobol/ChangeLog
index 7fe91a797438..97e03d4c68cf 100644
--- a/dev-lang/tinycobol/ChangeLog
+++ b/dev-lang/tinycobol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/tinycobol
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/ChangeLog,v 1.19 2010/03/10 20:07:05 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/ChangeLog,v 1.20 2010/04/16 18:48:02 phosphan Exp $
+
+ 16 Apr 2010; Patrick Kursawe <phosphan@gentoo.org> tinycobol-0.64.ebuild,
+ tinycobol-0.65.9.ebuild:
+ Fixing build time dependencies. Avoiding installation of empty dir
+ /usr/man/man1, see bug #315401.
*tinycobol-0.65.9 (23 Jan 2010)
diff --git a/dev-lang/tinycobol/tinycobol-0.64.ebuild b/dev-lang/tinycobol/tinycobol-0.64.ebuild
index b7d8a162826b..cf253cf2f484 100644
--- a/dev-lang/tinycobol/tinycobol-0.64.ebuild
+++ b/dev-lang/tinycobol/tinycobol-0.64.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.64.ebuild,v 1.5 2010/03/10 20:07:05 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.64.ebuild,v 1.6 2010/04/16 18:48:02 phosphan Exp $
inherit eutils
@@ -17,7 +17,8 @@ RDEPEND=">=dev-libs/glib-2.0
sys-libs/db"
DEPEND="${RDEPEND}
- sys-devel/flex"
+ sys-devel/flex
+ <sys-devel/bison-2.4"
src_unpack() {
unpack ${A}
@@ -41,4 +42,5 @@ src_install() {
cd lib
emake DESTDIR="${D}" pkgdatadir="/usr/share/htcobol/" install \
install-shared-libs install-static-libs
+ rm -rf "${D}/usr/man" # empty dir, see bug #315401
}
diff --git a/dev-lang/tinycobol/tinycobol-0.65.9.ebuild b/dev-lang/tinycobol/tinycobol-0.65.9.ebuild
index 628e1c8d5085..9fdff45a7760 100644
--- a/dev-lang/tinycobol/tinycobol-0.65.9.ebuild
+++ b/dev-lang/tinycobol/tinycobol-0.65.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.65.9.ebuild,v 1.1 2010/03/10 20:07:05 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tinycobol/tinycobol-0.65.9.ebuild,v 1.2 2010/04/16 18:48:02 phosphan Exp $
inherit eutils
@@ -18,7 +18,8 @@ RDEPEND=">=dev-libs/glib-2.0
dev-db/vbisam"
DEPEND="${RDEPEND}
- sys-devel/flex"
+ sys-devel/flex
+ sys-devel/bison"
src_unpack() {
unpack ${A}
@@ -42,4 +43,5 @@ src_install() {
cd lib
emake DESTDIR="${D}" pkgdatadir="/usr/share/htcobol/" install \
install-shared-libs install-static-libs
+ rm -rf "${D}/usr/man" # empty dir, see bug #315401
}