summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-12-22 09:16:04 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-12-22 09:16:04 +0000
commit9f2353f0097521d463bef37ba9fd55eb438e4d86 (patch)
tree9d8db00c0e23c197ba62a9807421f5cc95d5049f /dev-lang
parentadded -r2 because of wrong directory in ebuild (diff)
downloadgentoo-2-9f2353f0097521d463bef37ba9fd55eb438e4d86.tar.gz
gentoo-2-9f2353f0097521d463bef37ba9fd55eb438e4d86.tar.bz2
gentoo-2-9f2353f0097521d463bef37ba9fd55eb438e4d86.zip
fixed haddock dependency (only if USE=doc is set)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ghc/ChangeLog5
-rw-r--r--dev-lang/ghc/Manifest4
-rw-r--r--dev-lang/ghc/ghc-6.2.ebuild10
3 files changed, 13 insertions, 6 deletions
diff --git a/dev-lang/ghc/ChangeLog b/dev-lang/ghc/ChangeLog
index 8310d9c64a34..da9a7ade84f2 100644
--- a/dev-lang/ghc/ChangeLog
+++ b/dev-lang/ghc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ghc
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.24 2003/12/19 11:31:31 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ChangeLog,v 1.25 2003/12/22 09:15:50 kosmikus Exp $
+
+ 22 Dec 2003; Andres Loeh <kosmikus@gentoo.org> ghc-6.2.ebuild:
+ Haddock got called even with USE=-doc.
19 Dec 2003; Andres Loeh <kosmikus@gentoo.org> ghc-6.2.ebuild:
GHC 6.2 needs haddock-0.6 (bug #36108)
diff --git a/dev-lang/ghc/Manifest b/dev-lang/ghc/Manifest
index b934e4a468d1..90c7d60a4bca 100644
--- a/dev-lang/ghc/Manifest
+++ b/dev-lang/ghc/Manifest
@@ -1,9 +1,9 @@
MD5 53cadcab720c08f0d03fced644adc7ce ghc-5.04.3.ebuild 4536
MD5 70fd3ed422514576f84000daa3c1313b ghc-5.04.3-r1.ebuild 7365
MD5 e6cb655b6e491861cde72bf8695c53eb ghc-6.0.ebuild 4282
-MD5 73b4376fc858fe01bdef6041ee76d685 ghc-6.2.ebuild 4788
+MD5 4232142fe5db54674f3ea62b51cdbd8e ghc-6.2.ebuild 4867
MD5 eb902d291c43516728dc3b4e00834029 ghc-6.0.1.ebuild 4878
-MD5 941c893b8250a4f7a83bc342f74c9de7 ChangeLog 5882
+MD5 bad3f0481f3186e7d3cb89212a967aa2 ChangeLog 5989
MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
MD5 9da9270be8ac4d92d6a5c23fd519cc3c files/lndir.c 8050
MD5 9c184505ec441675c94d47a3110fa754 files/ghc-6.2.documentation.patch 721
diff --git a/dev-lang/ghc/ghc-6.2.ebuild b/dev-lang/ghc/ghc-6.2.ebuild
index c1f02ae897c1..154fac09eb83 100644
--- a/dev-lang/ghc/ghc-6.2.ebuild
+++ b/dev-lang/ghc/ghc-6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.ebuild,v 1.2 2003/12/19 11:31:31 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ghc/ghc-6.2.ebuild,v 1.3 2003/12/22 09:15:50 kosmikus Exp $
#Some explanation of bootstrap logic:
#
@@ -51,7 +51,7 @@ DEPEND="virtual/ghc
>=app-text/sgml-common-0.6.3
=app-text/docbook-sgml-dtd-3.1-r1
>=app-text/docbook-dsssl-stylesheets-1.64
- >=dev-haskell/haddock-0.6
+ >=dev-haskell/haddock-0.6-r2
tetex? ( >=app-text/tetex-1.0.7
>=app-text/jadetex-3.12 ) )
opengl? ( virtual/opengl
@@ -112,10 +112,14 @@ src_compile() {
src_install () {
local mydoc
+ local insttarget
+
+ insttarget="install"
# determine what to do with documentation
if [ `use doc` ]; then
mydoc="html"
+ insttarget="${insttarget} install-docs"
if [ `use tetex` ]; then
mydoc="${mydoc} ps"
fi
@@ -126,7 +130,7 @@ src_install () {
fi
echo SGMLDocWays="${mydoc}" >> mk/build.mk
- make install install-docs \
+ make ${insttarget} \
prefix="${D}/usr" \
datadir="${D}/usr/share/doc/${PF}" \
infodir="${D}/usr/share/info" \