summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-05-08 01:13:59 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-05-08 01:13:59 +0000
commita016b29b6dfd98c950b0defb400f9f38bd5d5c8f (patch)
tree9a0307320731515ff31010791db2466348ce7c1e /dev-lang
parentinitial import #75438 (diff)
downloadgentoo-2-a016b29b6dfd98c950b0defb400f9f38bd5d5c8f.tar.gz
gentoo-2-a016b29b6dfd98c950b0defb400f9f38bd5d5c8f.tar.bz2
gentoo-2-a016b29b6dfd98c950b0defb400f9f38bd5d5c8f.zip
2.0.1 stable on amd64 and x86. Cleaned out old ebuilds, and added new 64 bit detection code to 2.1.0.
(Portage version: 2.0.51.21)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/R/ChangeLog7
-rw-r--r--dev-lang/R/R-1.9.1.ebuild139
-rw-r--r--dev-lang/R/R-2.0.0.ebuild118
-rw-r--r--dev-lang/R/R-2.0.1.ebuild4
-rw-r--r--dev-lang/R/R-2.1.0-r1.ebuild14
-rw-r--r--dev-lang/R/R-2.1.0.ebuild97
-rw-r--r--dev-lang/R/files/digest-R-1.9.11
-rw-r--r--dev-lang/R/files/digest-R-2.0.01
-rw-r--r--dev-lang/R/files/digest-R-2.1.01
9 files changed, 19 insertions, 363 deletions
diff --git a/dev-lang/R/ChangeLog b/dev-lang/R/ChangeLog
index 0ff19a106a13..d5eec3594832 100644
--- a/dev-lang/R/ChangeLog
+++ b/dev-lang/R/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/R
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.42 2005/04/29 18:54:00 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/ChangeLog,v 1.43 2005/05/08 01:13:59 cryos Exp $
+
+ 08 May 2005; Marcus D. Hanwell <cryos@gentoo.org> -R-1.9.1.ebuild,
+ -R-2.0.0.ebuild, R-2.0.1.ebuild, -R-2.1.0.ebuild, R-2.1.0-r1.ebuild:
+ Marked 2.0.1 stable on amd64 and x86, cleaned out old ebuilds. Added new 64
+ bit detection code to 2.1.0-r1 as per bug 91512.
*R-2.1.0-r1 (29 Apr 2005)
diff --git a/dev-lang/R/R-1.9.1.ebuild b/dev-lang/R/R-1.9.1.ebuild
deleted file mode 100644
index ebe9ecbf086d..000000000000
--- a/dev-lang/R/R-1.9.1.ebuild
+++ /dev/null
@@ -1,139 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-1.9.1.ebuild,v 1.5 2005/02/17 21:59:57 kloeri Exp $
-
-inherit 64-bit
-
-IUSE="blas lapack X tcltk gnome zlib bzlib pcre f2c"
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-
-SRC_URI="http://cran.r-project.org/src/base/${P}.tgz"
-
- #There are daily release patches, don't know how to utilize these
- #"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-
-HOMEPAGE="http://www.r-project.org/"
-
-DEPEND="virtual/libc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- zlib? ( >=sys-libs/zlib-1.1.3-r2 )
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- f2c? ( dev-lang/f2c >=dev-libs/libf2c-20021004-r1 )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- pcre? ( dev-libs/libpcre )
- bzlib? ( app-arch/bzip2 )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4
- >=gnome-base/libglade-0.17
- >=dev-libs/libxml-1.8.16
- =gnome-base/orbit-0*
- >=media-libs/imlib-1.9.10
- >=x11-libs/gtk+-1.2.10
- >=dev-libs/glib-1.2.10
- >=media-sound/esound-0.2.23
- >=media-libs/audiofile-0.2.1 )"
-
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc ~ppc ~ppc64 amd64 ~alpha"
-
-pkg_setup() {
- if [ -z "$(which g77 2>/dev/null)" ]; then
- einfo "Couldn't find g77 Fortran Compiler."
- if 64-bit && use f2c; then
- eerror "You can't use f2c for dev-lang/R on 64-bit arches."
- eerror "Please remerge gcc with USE=\"g77\""
- die "dev-lang/R is incompatible with f2c on 64-bit arches."
- fi
- if ! use f2c; then
- eerror "Trying to emerge this packet w/o fortran compiler."
- eerror "Try again with USE=\"f2c\" emerge dev-lang/R."
- die "No fortran compiler, no f2c."
- else
- einfo "Using f2c to translate fortran sources."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed -e 's/^#define NeedFunctionPrototypes 0/#define NeedFunctionPrototypes 1/' \
- -i src/modules/X11/dataentry.c || die "sed failed"
-}
-
-src_compile() {
- addwrite "/var/cache/fonts"
- local myconf="--enable-static --enable-R-profiling --enable-R-shlib --with-readline"
-
- use zlib || myconf="${myconf} --with-zlib" #default disabled
- use bzlib || myconf="${myconf} --with-bzlib" #default disabled
- use pcre || myconf="${myconf} --with-pcre" #default disabled
-
- # Using the blas USE flag now instead atlas, as atlas now
- # has been broken into blas-atlas and lapack-atlas.
- # Danny van Dyk <kugelfang@gentoo.org> 2004/07/11
- use blas || myconf="${myconf} --without-blas" #default enabled
- use lapack && myconf="${myconf} --with-lapack" #default disabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- ./configure \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- emake || die
-
-}
-
-src_install () {
-
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- cp ${D}/usr/lib/R/bin/R ${S}/bin/R.orig
- sed -e '/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/lib/R:' \
- ${S}/bin/R.orig > ${D}/usr/lib/R/bin/R
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-2.0.0.ebuild b/dev-lang/R/R-2.0.0.ebuild
deleted file mode 100644
index 446c26204f9b..000000000000
--- a/dev-lang/R/R-2.0.0.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.0.0.ebuild,v 1.5 2005/02/21 21:46:56 kugelfang Exp $
-
-inherit 64-bit fortran
-
-IUSE="blas lapack X tcltk gnome zlib bzlib pcre"
-
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-SRC_URI="http://cran.r-project.org/src/base/R-2/${P}.tar.gz"
-#There are daily release patches, don't know how to utilize these
-#"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-HOMEPAGE="http://www.r-project.org/"
-DEPEND="virtual/libc
- >=dev-lang/perl-5.6.1-r3
- >=sys-libs/readline-4.1-r3
- zlib? ( >=sys-libs/zlib-1.1.3-r2 )
- >=media-libs/jpeg-6b-r2
- >=media-libs/libpng-1.2.1
- blas? ( virtual/blas )
- lapack? ( virtual/lapack )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- pcre? ( dev-libs/libpcre )
- bzlib? ( app-arch/bzip2 )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4
- >=gnome-base/libglade-0.17
- >=dev-libs/libxml-1.8.16
- =gnome-base/orbit-0*
- >=media-libs/imlib-1.9.10
- >=x11-libs/gtk+-1.2.10
- >=dev-libs/glib-1.2.10
- >=media-sound/esound-0.2.23
- >=media-libs/audiofile-0.2.1 )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc ~ppc ppc64 amd64"
-64-bit || FORTRAN="g77 f2c" # No f2c on 64-bit systems :-/
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- sed \
- -e 's/^#define NeedFunctionPrototypes 0/#define NeedFunctionPrototypes 1/' \
- -i src/modules/X11/dataentry.c \
- || die "sed failed"
-}
-
-src_compile() {
- addwrite "/var/cache/fonts"
- local myconf="--enable-static --enable-R-profiling --enable-R-shlib --with-readline"
-
- use zlib || myconf="${myconf} --with-zlib" #default disabled
- use bzlib || myconf="${myconf} --with-bzlib" #default disabled
- use pcre || myconf="${myconf} --with-pcre" #default disabled
-
- # Using the blas USE flag now instead atlas, as atlas now
- # has been broken into blas-atlas and lapack-atlas.
- use blas || myconf="${myconf} --without-blas" #default enabled
- use lapack && myconf="${myconf} --with-lapack" #default disabled
-
- use X || myconf="${myconf} --without-x" #default enabled
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- use gnome && myconf="${myconf} --with-gnome" #default disabled
-
- econf \
- --host=${CHOST} \
- --prefix=/usr \
- --infodir=/usr/share/info \
- --mandir=/usr/share/man \
- ${myconf} || die "./configure failed"
-
- emake || die
-}
-
-src_install () {
- # rhome=${D} fixes sandbox violation.
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- rhome=${D}/usr/$(get_libdir)/R/ \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- sed \
- -e "s:^R_HOME_DIR=.*:R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed (R_HOME_DIR)!"
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../lib/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ INSTALL *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/R-2.0.1.ebuild b/dev-lang/R/R-2.0.1.ebuild
index 6bcf2632b91d..6760e1d4f2fc 100644
--- a/dev-lang/R/R-2.0.1.ebuild
+++ b/dev-lang/R/R-2.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.0.1.ebuild,v 1.1 2005/02/21 21:46:56 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.0.1.ebuild,v 1.2 2005/05/08 01:13:59 cryos Exp $
inherit 64-bit fortran
@@ -32,7 +32,7 @@ DEPEND="virtual/libc
>=media-libs/audiofile-0.2.1 )"
SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc ~ppc ppc64 ~amd64"
+KEYWORDS="x86 ~sparc ~ppc ppc64 amd64"
64-bit || FORTRAN="g77" # No f2c on 64-bit archs anymore.
src_unpack() {
diff --git a/dev-lang/R/R-2.1.0-r1.ebuild b/dev-lang/R/R-2.1.0-r1.ebuild
index f39106e2728b..e0e16fada8ca 100644
--- a/dev-lang/R/R-2.1.0-r1.ebuild
+++ b/dev-lang/R/R-2.1.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.0-r1.ebuild,v 1.1 2005/04/29 18:54:00 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.0-r1.ebuild,v 1.2 2005/05/08 01:13:59 cryos Exp $
-inherit 64-bit fortran
+inherit fortran toolchain-funcs
IUSE="blas jpeg nls png readline tcltk X"
DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
@@ -21,9 +21,17 @@ DEPEND="virtual/libc
SLOT="0"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="~x86 ~sparc ~ppc ~ppc64 ~amd64"
-64-bit || FORTRAN="g77" # No f2c on 64-bit archs anymore.
src_compile() {
+ # Test for a 64 bit architecture - f2c won't work on 64 bit archs with R.
+ # Thanks to vapier for providing the test.
+ echo 'int main(){}' > test.c
+ $(tc-getCC) -c test.c -o test.o
+ if file test.o | grep -qs 64-bit ; then
+ einfo "64 bit architecture detected, using g77."
+ FORTRAN="g77"
+ fi
+
local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
if use tcltk; then
diff --git a/dev-lang/R/R-2.1.0.ebuild b/dev-lang/R/R-2.1.0.ebuild
deleted file mode 100644
index 79a6af764ede..000000000000
--- a/dev-lang/R/R-2.1.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/R/R-2.1.0.ebuild,v 1.2 2005/04/21 21:02:31 cryos Exp $
-
-inherit 64-bit fortran
-
-IUSE="blas bzlib gnome jpeg nls pcre png readline tcltk X"
-DESCRIPTION="R is GNU S - A language and environment for statistical computing and graphics."
-SRC_URI="http://cran.r-project.org/src/base/R-2/${P}.tar.gz"
-#There are daily release patches, don't know how to utilize these
-#"ftp://ftp.stat.math.ethz.ch/Software/${PN}/${PN}-release.diff.gz"
-HOMEPAGE="http://www.r-project.org/"
-DEPEND="virtual/libc
- >=dev-lang/perl-5.6.1-r3
- readline? (>=sys-libs/readline-4.1-r3)
- zlib? ( >=sys-libs/zlib-1.1.3-r2 )
- jpeg? ( >=media-libs/jpeg-6b-r2 )
- png? ( >=media-libs/libpng-1.2.1 )
- blas? ( virtual/blas )
- X? ( virtual/x11 )
- tcltk? ( dev-lang/tk )
- pcre? ( dev-libs/libpcre )
- bzlib? ( app-arch/bzip2 )
- gnome? ( >=gnome-base/gnome-libs-1.4.1.4
- >=gnome-base/libglade-0.17
- >=dev-libs/libxml-1.8.16
- =gnome-base/orbit-0*
- >=media-libs/imlib-1.9.10
- >=x11-libs/gtk+-1.2.10
- >=dev-libs/glib-1.2.10
- >=media-sound/esound-0.2.23
- >=media-libs/audiofile-0.2.1 )"
-SLOT="0"
-LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="~x86 ~sparc ~ppc ~ppc64 ~amd64"
-64-bit || FORTRAN="g77" # No f2c on 64-bit archs anymore.
-
-src_compile() {
- local myconf="--enable-R-profiling --enable-R-shlib --enable-linux-lfs"
-
- if use tcltk; then
- #configure needs to find the files tclConfig.sh and tkConfig.sh
- myconf="${myconf} --with-tcltk --with-tcl-config=/usr/lib/tclConfig.sh --with-tk-config=/usr/lib/tkConfig.sh"
- else
- myconf="${myconf} --without-tcltk"
- fi
-
- econf \
- $(use_enable nls) \
- $(use_with blas) \
- $(use_with bzlib) \
- $(use_with gnome) \
- $(use_with jpeg jpeglib) \
- $(use_with pcre) \
- $(use_with png libpng) \
- $(use_with readline) \
- $(use_with X x) \
- $(use_with zlib) \
- ${myconf} || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- rhome=${D}/usr/$(get_libdir)/R \
- install || die "Installation Failed"
-
- #fix the R wrapper script to have the correct R_HOME_DIR
- #sed regexp borrowed from included debian rules
- sed \
- -e "/^R_HOME_DIR=.*/s::R_HOME_DIR=/usr/$(get_libdir)/R:" \
- -i ${D}/usr/$(get_libdir)/R/bin/R \
- || die "sed failed"
-
- #R installs two identical wrappers under /usr/bin and /usr/lib/R/bin/
- #the 2nd one is corrected by above sed, for the 1st
- #I'll just symlink it into /usr/bin
- cd ${D}/usr/bin/
- rm R
- dosym ../$(get_libdir)/R/bin/R /usr/bin/R
- cd ${S}
-
- dodoc AUTHORS BUGS COPYING* ChangeLog FAQ *NEWS README \
- RESOURCES THANKS VERSION Y2K
-
- #Add rudimentary menu entry if gnome
- if use gnome; then
- insinto /usr/share/gnome/apps/Applications
- doins ${FILESDIR}/R.desktop
- insinto /usr/share/pixmaps
- doins ${FILESDIR}/R-logo.png
- fi
-
-}
diff --git a/dev-lang/R/files/digest-R-1.9.1 b/dev-lang/R/files/digest-R-1.9.1
deleted file mode 100644
index b86d81c3a232..000000000000
--- a/dev-lang/R/files/digest-R-1.9.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 c8201425506e5c077ef1936e19ea2f51 R-1.9.1.tgz 9591217
diff --git a/dev-lang/R/files/digest-R-2.0.0 b/dev-lang/R/files/digest-R-2.0.0
deleted file mode 100644
index 705533e4e0ce..000000000000
--- a/dev-lang/R/files/digest-R-2.0.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3900bca37cabb4b76b8d736d51cc9251 R-2.0.0.tar.gz 10676072
diff --git a/dev-lang/R/files/digest-R-2.1.0 b/dev-lang/R/files/digest-R-2.1.0
deleted file mode 100644
index 615fed6e31c2..000000000000
--- a/dev-lang/R/files/digest-R-2.1.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 270f7a7382e8cb10a353148598f91096 R-2.1.0.tar.gz 12173182