summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-19 18:52:46 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-12-19 18:52:46 +0000
commita999f081f6a6e1a6e54e0a152cdc31f7b2dc5da4 (patch)
tree8d94955155b7c7943fa011bdba2ac2314bacc77a /dev-lang
parentPort perl changes for 1.7.18 to 1.7.19 (diff)
downloadgentoo-2-a999f081f6a6e1a6e54e0a152cdc31f7b2dc5da4.tar.gz
gentoo-2-a999f081f6a6e1a6e54e0a152cdc31f7b2dc5da4.tar.bz2
gentoo-2-a999f081f6a6e1a6e54e0a152cdc31f7b2dc5da4.zip
Make perl5.20.1 a symlink to perl, not the other way around, bug 527380
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/perl/ChangeLog9
-rw-r--r--dev-lang/perl/files/eblits/src_install-v50200001.eblit51
-rw-r--r--dev-lang/perl/perl-5.20.1-r4.ebuild (renamed from dev-lang/perl/perl-5.20.1-r2.ebuild)8
3 files changed, 63 insertions, 5 deletions
diff --git a/dev-lang/perl/ChangeLog b/dev-lang/perl/ChangeLog
index e2e04e6c3940..774540bf11ea 100644
--- a/dev-lang/perl/ChangeLog
+++ b/dev-lang/perl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/perl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.459 2014/11/29 20:57:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/ChangeLog,v 1.460 2014/12/19 18:52:46 dilfridge Exp $
+
+*perl-5.20.1-r4 (19 Dec 2014)
+
+ 19 Dec 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ -perl-5.20.1-r2.ebuild, +perl-5.20.1-r4.ebuild,
+ +files/eblits/src_install-v50200001.eblit:
+ Make perl5.20.1 a symlink to perl, not the other way around, bug 527380
29 Nov 2014; Andreas K. Huettel <dilfridge@gentoo.org> perl-5.18.2-r2.ebuild,
perl-5.20.1-r2.ebuild, perl-5.20.1-r3.ebuild:
diff --git a/dev-lang/perl/files/eblits/src_install-v50200001.eblit b/dev-lang/perl/files/eblits/src_install-v50200001.eblit
new file mode 100644
index 000000000000..1df4296eb332
--- /dev/null
+++ b/dev-lang/perl/files/eblits/src_install-v50200001.eblit
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/files/eblits/src_install-v50200001.eblit,v 1.1 2014/12/19 18:52:46 dilfridge Exp $
+
+eblit-perl-src_install() {
+ local i
+ local coredir="${ARCH_LIB}/CORE"
+
+ emake DESTDIR="${D}" install
+
+ rm -f "${ED}/usr/bin/perl${MY_PV}"
+ ln -s perl "${ED}"/usr/bin/perl${MY_PV} || die
+
+ if ! tc-is-static-only ; then
+ dolib.so "${ED}"${coredir}/${LIBPERL}
+ rm -f "${ED}"${coredir}/${LIBPERL}
+ ln -sf ${LIBPERL} "${ED}"/usr/$(get_libdir)/libperl$(get_libname ${SHORT_PV}) || die
+ ln -sf ${LIBPERL} "${ED}"/usr/$(get_libdir)/libperl$(get_libname) || die
+ ln -sf ../../../../../$(get_libdir)/${LIBPERL} "${ED}"${coredir}/${LIBPERL} || die
+ ln -sf ../../../../../$(get_libdir)/${LIBPERL} "${ED}"${coredir}/libperl$(get_libname ${SHORT_PV}) || die
+ ln -sf ../../../../../$(get_libdir)/${LIBPERL} "${ED}"${coredir}/libperl$(get_libname) || die
+ fi
+
+ rm -rf "${ED}"/usr/share/man/man3 || die "Unable to remove module man pages"
+
+ # This removes ${D} from Config.pm
+ for i in $(find "${D}" -iname "Config.pm" ) ; do
+ einfo "Removing ${D} from ${i}..."
+ sed -i -e "s:${D}::" "${i}" || die "Sed failed"
+ done
+
+ find "${ED}" -type f -name .packlist -delete || die
+
+ dodoc Changes* README AUTHORS
+
+ if use doc ; then
+ # HTML Documentation
+ # We expect errors, warnings, and such with the following.
+
+ dodir /usr/share/doc/${PF}/html
+ LD_LIBRARY_PATH=. ./perl installhtml \
+ --podroot='.' \
+ --podpath='lib:ext:pod:vms' \
+ --recurse \
+ --htmldir="${ED}/usr/share/doc/${PF}/html"
+ fi
+
+ [[ -d ${ED}/usr/local ]] && rm -r "${ED}"/usr/local
+
+ dual_scripts
+}
diff --git a/dev-lang/perl/perl-5.20.1-r2.ebuild b/dev-lang/perl/perl-5.20.1-r4.ebuild
index 7fd2090b2d73..49a3b94411c8 100644
--- a/dev-lang/perl/perl-5.20.1-r2.ebuild
+++ b/dev-lang/perl/perl-5.20.1-r4.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.20.1-r2.ebuild,v 1.2 2014/11/29 20:57:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/perl/perl-5.20.1-r4.ebuild,v 1.1 2014/12/19 18:52:46 dilfridge Exp $
EAPI=5
inherit eutils alternatives flag-o-matic toolchain-funcs multilib multiprocessing
-PATCH_VER=1
+PATCH_VER=2
PERL_OLDVERSEN="5.20.0"
MODULE_AUTHOR=RJBS
@@ -21,7 +21,7 @@ SRC_URI="
mirror://cpan/src/5.0/${MY_P}.tar.bz2
mirror://cpan/authors/id/${MODULE_AUTHOR:0:1}/${MODULE_AUTHOR:0:2}/${MODULE_AUTHOR}/${MY_P}.tar.bz2
mirror://gentoo/${MY_P}-patches-${PATCH_VER}.tar.xz
- http://dev.gentoo.org/~civil/distfiles/${CATEGORY}/${PN}/${MY_P}-patches-${PATCH_VER}.tar.xz
+ http://dev.gentoo.org/~dilfridge/distfiles/${MY_P}-patches-${PATCH_VER}.tar.xz
"
HOMEPAGE="http://www.perl.org/"
@@ -106,7 +106,7 @@ src_prepare() { eblit-run src_prepare v50160001 ; }
src_configure() { eblit-run src_configure v50180002 ; }
#src_compile() { eblit-run src_compile v50160001 ; }
src_test() { eblit-run src_test v50160001 ; }
-src_install() { eblit-run src_install v50160001 ; }
+src_install() { eblit-run src_install v50200001 ; }
# FILESDIR might not be available during binpkg install
# FIXME: version passing