summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-02-15 08:23:59 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-02-15 08:23:59 +0000
commitacb852b7c277aba48dd0e52b6851e76d083fc8a1 (patch)
treede93203681508ccf28124ae2e29863c5253193e5 /dev-lang
parentVersion bump of django-two-factor-auth (diff)
downloadgentoo-2-acb852b7c277aba48dd0e52b6851e76d083fc8a1.tar.gz
gentoo-2-acb852b7c277aba48dd0e52b6851e76d083fc8a1.tar.bz2
gentoo-2-acb852b7c277aba48dd0e52b6851e76d083fc8a1.zip
Bump, remove old
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/parrot/ChangeLog9
-rw-r--r--dev-lang/parrot/parrot-6.2.0-r1.ebuild82
-rw-r--r--dev-lang/parrot/parrot-6.3.0-r1.ebuild82
-rw-r--r--dev-lang/parrot/parrot-6.4.0-r1.ebuild82
-rw-r--r--dev-lang/parrot/parrot-6.5.0-r1.ebuild82
-rw-r--r--dev-lang/parrot/parrot-7.0.2.ebuild (renamed from dev-lang/parrot/parrot-6.6.0-r1.ebuild)6
6 files changed, 12 insertions, 331 deletions
diff --git a/dev-lang/parrot/ChangeLog b/dev-lang/parrot/ChangeLog
index 17d4045c46da..6b6ecc62a5e2 100644
--- a/dev-lang/parrot/ChangeLog
+++ b/dev-lang/parrot/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/parrot
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.90 2015/01/26 04:15:41 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/ChangeLog,v 1.91 2015/02/15 08:23:59 patrick Exp $
+
+*parrot-7.0.2 (15 Feb 2015)
+
+ 15 Feb 2015; Patrick Lauer <patrick@gentoo.org> +parrot-7.0.2.ebuild,
+ -parrot-6.2.0-r1.ebuild, -parrot-6.3.0-r1.ebuild, -parrot-6.4.0-r1.ebuild,
+ -parrot-6.5.0-r1.ebuild, -parrot-6.6.0-r1.ebuild:
+ Bump, remove old
26 Jan 2015; Patrick Lauer <patrick@gentoo.org> parrot-6.11.0.ebuild:
Add libffi dep
diff --git a/dev-lang/parrot/parrot-6.2.0-r1.ebuild b/dev-lang/parrot/parrot-6.2.0-r1.ebuild
deleted file mode 100644
index 12b12ffe9134..000000000000
--- a/dev-lang/parrot/parrot-6.2.0-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-6.2.0-r1.ebuild,v 1.1 2014/10/10 08:24:14 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# weird failures
-RESTRICT="test"
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/devel/${PV}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6:= )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )
- doc? ( dev-perl/JSON )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-6.3.0-r1.ebuild b/dev-lang/parrot/parrot-6.3.0-r1.ebuild
deleted file mode 100644
index 5351615ad6fb..000000000000
--- a/dev-lang/parrot/parrot-6.3.0-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-6.3.0-r1.ebuild,v 1.1 2014/10/10 08:24:14 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# weird failures
-RESTRICT="test"
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/all/${PV}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6:= )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )
- doc? ( dev-perl/JSON )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-6.4.0-r1.ebuild b/dev-lang/parrot/parrot-6.4.0-r1.ebuild
deleted file mode 100644
index 3266369ed397..000000000000
--- a/dev-lang/parrot/parrot-6.4.0-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-6.4.0-r1.ebuild,v 1.1 2014/10/10 08:24:14 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# weird failures
-RESTRICT="test"
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/all/${PV}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6:= )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )
- doc? ( dev-perl/JSON )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-6.5.0-r1.ebuild b/dev-lang/parrot/parrot-6.5.0-r1.ebuild
deleted file mode 100644
index 1b0c509ad1ab..000000000000
--- a/dev-lang/parrot/parrot-6.5.0-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-6.5.0-r1.ebuild,v 1.1 2014/10/10 08:24:14 patrick Exp $
-
-EAPI=5
-
-inherit eutils multilib
-
-# weird failures
-RESTRICT="test"
-
-DESCRIPTION="Virtual machine designed to efficiently compile and execute bytecode for dynamic languages"
-HOMEPAGE="http://www.parrot.org/"
-SRC_URI="ftp://ftp.parrot.org/pub/parrot/releases/all/${PV}/${P}.tar.gz"
-
-LICENSE="Artistic-2"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
-
-RDEPEND="sys-libs/readline
- opengl? ( media-libs/freeglut )
- nls? ( sys-devel/gettext )
- unicode? ( >=dev-libs/icu-2.6:= )
- gdbm? ( >=sys-libs/gdbm-1.8.3-r1 )
- gmp? ( >=dev-libs/gmp-4.1.4 )
- ssl? ( dev-libs/openssl )
- pcre? ( dev-libs/libpcre )
- doc? ( dev-perl/JSON )"
-
-DEPEND="dev-lang/perl[doc?]
- ${RDEPEND}"
-
-src_configure() {
- myconf="--disable-rpath"
- use unicode || myconf+=" --without-icu"
- use ssl || myconf+=" --without-crypto"
- use gdbm || myconf+=" --without-gdbm"
- use nls || myconf+=" --without-gettext"
- use gmp || myconf+=" --without-gmp"
- use opengl || myconf+=" --without-opengl"
- use pcre || myconf+=" --without-pcre"
-
- perl Configure.pl \
- --ccflags="${CFLAGS}" \
- --linkflags="${LDFLAGS}" \
- --prefix="${EPREFIX}"/usr \
- --libdir="${EPREFIX}"/usr/$(get_libdir) \
- --mandir="${EPREFIX}"/usr/share/man \
- --sysconfdir="${EPREFIX}"/etc \
- --sharedstatedir="${EPREFIX}"/var/lib/parrot \
- $myconf || die
-}
-
-src_compile() {
- export LD_LIBRARY_PATH=${LD_LIBRARY_PATH:+$LD_LIBRARY_PATH:}"${S}"/blib/lib
- # occasionally dies in parallel make
- emake -j1 || die
- if use doc ; then
- emake -j1 html || die
- fi
-}
-
-src_test() {
- emake -j1 test || die
-}
-
-src_install() {
- emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
- dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- doins -r examples/* || die
- fi
- if use doc; then
- insinto "/usr/share/doc/${PF}/editor"
- doins -r editor || die
- cd docs/html
- dohtml -r developer.html DONORS.pod.html index.html ops.html parrotbug.html pdds.html \
- pmc.html tools.html docs src tools || die
- fi
-}
diff --git a/dev-lang/parrot/parrot-6.6.0-r1.ebuild b/dev-lang/parrot/parrot-7.0.2.ebuild
index eef0926825d4..ebc14b6eefa1 100644
--- a/dev-lang/parrot/parrot-6.6.0-r1.ebuild
+++ b/dev-lang/parrot/parrot-7.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-6.6.0-r1.ebuild,v 1.1 2014/10/10 08:24:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/parrot/parrot-7.0.2.ebuild,v 1.1 2015/02/15 08:23:59 patrick Exp $
EAPI=5
@@ -19,6 +19,7 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64
IUSE="opengl nls doc examples gdbm gmp ssl +unicode pcre"
RDEPEND="sys-libs/readline
+ dev-libs/libffi
opengl? ( media-libs/freeglut )
nls? ( sys-devel/gettext )
unicode? ( >=dev-libs/icu-2.6:= )
@@ -68,6 +69,7 @@ src_test() {
src_install() {
emake -j1 install-dev DESTDIR="${D}" DOC_DIR="${EPREFIX}/usr/share/doc/${PF}" || die
dodoc CREDITS DONORS.pod PBC_COMPAT PLATFORMS RESPONSIBLE_PARTIES TODO || die
+ dosym /usr/bin/parrot-ops2c /usr/bin/ops2c || die
if use examples; then
insinto "/usr/share/doc/${PF}/examples"
doins -r examples/* || die