summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKeri Harris <keri@gentoo.org>2007-10-04 06:22:39 +0000
committerKeri Harris <keri@gentoo.org>2007-10-04 06:22:39 +0000
commitb8acdffd9793c1cb1d83aed2cf30c7094ba6ae74 (patch)
treef0e7d9ded9d3c745c6a794bd5543cdc8590a39c0 /dev-lang
parentversion bump for GNOME 2.20 (diff)
downloadgentoo-2-b8acdffd9793c1cb1d83aed2cf30c7094ba6ae74.tar.gz
gentoo-2-b8acdffd9793c1cb1d83aed2cf30c7094ba6ae74.tar.bz2
gentoo-2-b8acdffd9793c1cb1d83aed2cf30c7094ba6ae74.zip
Add proper support for emacs. Closes #194604
(Portage version: 2.1.3.11)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mozart/ChangeLog7
-rw-r--r--dev-lang/mozart/files/50mozart-gentoo.el11
-rw-r--r--dev-lang/mozart/mozart-1.3.2.ebuild30
3 files changed, 38 insertions, 10 deletions
diff --git a/dev-lang/mozart/ChangeLog b/dev-lang/mozart/ChangeLog
index 20382dc7ca67..6fdff4de850e 100644
--- a/dev-lang/mozart/ChangeLog
+++ b/dev-lang/mozart/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/mozart
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.8 2007/09/29 05:49:54 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/ChangeLog,v 1.9 2007/10/04 06:22:39 keri Exp $
+
+ 04 Oct 2007; keri <keri@gentoo.org> +files/50mozart-gentoo.el,
+ mozart-1.3.2.ebuild:
+ Add proper support for emacs. Reported and fixed by Ulrich Mueller in bug
+ #194604
29 Sep 2007; keri <keri@gentoo.org> +files/mozart-1.3.2-ri-fpe.patch,
mozart-1.3.2.ebuild:
diff --git a/dev-lang/mozart/files/50mozart-gentoo.el b/dev-lang/mozart/files/50mozart-gentoo.el
new file mode 100644
index 000000000000..64f65c54a682
--- /dev/null
+++ b/dev-lang/mozart/files/50mozart-gentoo.el
@@ -0,0 +1,11 @@
+
+;;; mozart site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'oz-mode "oz" "Major mode for editing Oz code." t)
+(autoload 'oz-gump-mode "oz"
+ "Major mode for editing Oz code with embedded Gump specifications." t)
+(autoload 'ozm-mode "mozart" "Major mode for displaying Oz machine code." t)
+(add-to-list 'auto-mode-alist '("\\.oz$" . oz-mode))
+(add-to-list 'auto-mode-alist '("\\.ozg$" . oz-gump-mode))
+(add-to-list 'auto-mode-alist '("\\.ozm$" . ozm-mode))
diff --git a/dev-lang/mozart/mozart-1.3.2.ebuild b/dev-lang/mozart/mozart-1.3.2.ebuild
index 0606f593e9c5..870f1d4c9449 100644
--- a/dev-lang/mozart/mozart-1.3.2.ebuild
+++ b/dev-lang/mozart/mozart-1.3.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/mozart-1.3.2.ebuild,v 1.6 2007/09/29 05:49:54 keri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mozart/mozart-1.3.2.ebuild,v 1.7 2007/10/04 06:22:39 keri Exp $
-inherit eutils
+inherit elisp-common eutils
MY_P="mozart-${PV}.20060615"
@@ -21,12 +21,15 @@ DEPEND="dev-lang/perl
sys-devel/bison
sys-devel/flex
sys-libs/zlib
+ emacs? ( virtual/emacs )
gdbm? ( sys-libs/gdbm )
tcl? ( tk? (
dev-lang/tk
dev-lang/tcl ) )"
RDEPEND="${DEPEND}"
+SITEFILE=50${PN}-gentoo.el
+
S="${WORKDIR}"/${MY_P}
src_unpack() {
@@ -47,12 +50,6 @@ src_compile() {
--without-global-oz \
--enable-opt=none"
- if use emacs ; then
- myconf="${myconf} --enable-compile-elisp"
- else
- myconf="${myconf} --disable-compile-elisp"
- fi
-
if use tcl && use tk ; then
myconf="${myconf} --enable-wish"
else
@@ -77,22 +74,37 @@ src_compile() {
--disable-doc \
$(use_enable doc contrib-doc) \
$(use_enable gdbm contrib-gdbm) \
+ $(use_enable emacs compile-elisp) \
$(use_enable static link-static) \
$(use_enable threads threaded) \
|| die "econf failed"
- emake bootstrap || die "emake bootstrap failed"
+ emake -j1 bootstrap || die "emake bootstrap failed"
}
src_install() {
emake -j1 \
PREFIX="${D}"/usr/lib/mozart \
BINDIR="${D}"/usr/bin \
+ ELISPDIR="${D}${SITELISP}/${PN}" \
install || die "emake install failed"
+ if use emacs; then
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ fi
+
if use doc ; then
dohtml -r "${WORKDIR}"/mozart/doc/*
fi
dodoc README
}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}