summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-07 18:11:24 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-07 18:11:24 +0000
commitc20f2aec62f0bed7251c1824dbc100096d29e75a (patch)
treea52e2c46df89b25a8f521a17d926761f1ef728b4 /dev-lang
parent*** empty log message *** (diff)
downloadgentoo-2-c20f2aec62f0bed7251c1824dbc100096d29e75a.tar.gz
gentoo-2-c20f2aec62f0bed7251c1824dbc100096d29e75a.tar.bz2
gentoo-2-c20f2aec62f0bed7251c1824dbc100096d29e75a.zip
*** empty log message ***
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/jdk/files/digest1
-rw-r--r--dev-lang/jdk/jdk-1.2.2rc4-r1.ebuild36
-rw-r--r--dev-lang/nasm/files/digest1
-rw-r--r--dev-lang/nasm/nasm-0.98-r1.ebuild32
-rw-r--r--dev-lang/php-4/files/digest2
-rw-r--r--dev-lang/php-4/php-4.0.0-r1.ebuild64
-rw-r--r--dev-lang/php-4/php-4.0.1-r1.ebuild62
-rw-r--r--dev-lang/php-4/php-4.0.1p2-r1.ebuild59
-rw-r--r--dev-lang/python/files/digest1
-rw-r--r--dev-lang/python/python-1.5.2-r1.ebuild46
-rw-r--r--dev-lang/tcl-tk-8.0/files/digest2
-rw-r--r--dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild61
-rw-r--r--dev-lang/tcl-tk-8.1/files/digest2
-rw-r--r--dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild59
14 files changed, 428 insertions, 0 deletions
diff --git a/dev-lang/jdk/files/digest b/dev-lang/jdk/files/digest
new file mode 100644
index 000000000000..1012ce0aef20
--- /dev/null
+++ b/dev-lang/jdk/files/digest
@@ -0,0 +1 @@
+MD5 59f0705cf15d95e83b3a18a76c2b8ca1 jdk-1.2.2-RC4-linux-i386-glibc-2.1.2.tar.bz2
diff --git a/dev-lang/jdk/jdk-1.2.2rc4-r1.ebuild b/dev-lang/jdk/jdk-1.2.2rc4-r1.ebuild
new file mode 100644
index 000000000000..0d466e7940ba
--- /dev/null
+++ b/dev-lang/jdk/jdk-1.2.2rc4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/jdk/jdk-1.2.2rc4-r1.ebuild,v 1.1 2000/08/07 18:11:23 achim Exp $
+
+P=jdk-1.2.2
+A=jdk-1.2.2-RC4-linux-i386-glibc-2.1.2.tar.bz2
+S=${WORKDIR}/jdk1.2.2
+CATEGORY="dev-lang"
+DESCRIPTION="Blackdown JDK 1.2.2"
+SRC_URI="ftp://gd.tuwien.ac.at/opsys/linux/java/JDK-1.2.2/i386/rc4/jdk-1.2.2-RC4-linux-i386-glibc-2.1.2.tar.bz2"
+HOMEPAGE="http://www.blackdown.org/java-linux.html"
+
+src_compile() {
+ cd ${S}
+}
+
+src_install() {
+ dodir /opt/jdk-1.2.2
+ cp -a ${S}/bin ${D}/opt/jdk-1.2.2
+ cp -a ${S}/demo ${D}/opt/jdk-1.2.2
+ cp -a ${S}/include ${D}/opt/jdk-1.2.2
+ cp -a ${S}/lib ${D}/opt/jdk-1.2.2
+ cp -a ${S}/jre ${D}/opt/jdk-1.2.2
+ cp ${S}/src.jar ${D}/opt/jdk-1.2.2
+ into /usr
+ dodoc COPYRIGHT LICENSE README README.PRE-RELEASE README.linux
+ docinto html
+ dodoc README.html
+}
+
+pkg_postinst () {
+ ln -s ${ROOT}/opt/jdk-1.2.2 ${ROOT}/opt/java
+}
+
+
diff --git a/dev-lang/nasm/files/digest b/dev-lang/nasm/files/digest
new file mode 100644
index 000000000000..e100eaea6fd3
--- /dev/null
+++ b/dev-lang/nasm/files/digest
@@ -0,0 +1 @@
+MD5 9b7b0cb51d6b777edcbed7e0447a5f4e nasm-0.98.tar.bz2
diff --git a/dev-lang/nasm/nasm-0.98-r1.ebuild b/dev-lang/nasm/nasm-0.98-r1.ebuild
new file mode 100644
index 000000000000..a5d6f85283b8
--- /dev/null
+++ b/dev-lang/nasm/nasm-0.98-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nasm/nasm-0.98-r1.ebuild,v 1.1 2000/08/07 18:11:23 achim Exp $
+
+P=nasm-0.98
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="groovy little assembler"
+CATEGORY=dev-lang
+SRC_URI="ftp://ftp.kernel.org/pub/software/devel/nasm/source/nasm-0.98.tar.bz2"
+HOMEPAGE="http://nasm.sourceforge.net/"
+
+src_compile() {
+ ./configure --prefix=/usr
+ make
+ cd doc
+ make
+}
+
+src_install() {
+ into /usr
+ dobin nasm ndisasm
+ dobin rdoff/ldrdf rdoff/rdf2bin rdoff/rdfdump rdoff/rdflib rdoff/rdx
+ doman nasm.1 ndisasm.1
+ dodoc COPYING Changes Licence MODIFIED Readme Wishlist doc/nasmdoc.txt
+ docinto html
+ dodoc doc/html/*.html
+ doinfo doc/info/*.info*
+}
+
+
diff --git a/dev-lang/php-4/files/digest b/dev-lang/php-4/files/digest
new file mode 100644
index 000000000000..a6c5de26acfa
--- /dev/null
+++ b/dev-lang/php-4/files/digest
@@ -0,0 +1,2 @@
+MD5 124ef02aa3304f8b0c883e83f60d17e5 php-4.0.1pl2.tar.gz
+MD5 20c64ba8d79665e9bfab052fa5a85eab number4.tar.gz
diff --git a/dev-lang/php-4/php-4.0.0-r1.ebuild b/dev-lang/php-4/php-4.0.0-r1.ebuild
new file mode 100644
index 000000000000..397d59481330
--- /dev/null
+++ b/dev-lang/php-4/php-4.0.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.0-r1.ebuild,v 1.1 2000/08/07 18:11:23 achim Exp $
+
+P=php-4.0.0
+A="php-4.0.0.tar.gz number4.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML embedded scripting languag"
+CATEGORY=dev-lang
+SRC_URI="http://www.php.net/distributions/php-4.0.0.tar.gz
+ http://www.php.net/extra/number4.tar.gz"
+HOMEPAGE="http://www.php.net"
+
+src_compile() {
+
+# FLAGS="-mpentium -march=pentium -O4 -I/usr/include/freetype"
+# export CFLAGS=$FLAGS
+# export CPPFLAGS=$FLAGS
+# export CXXFLAGS=$FLAGS
+ export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
+ ./configure --with-mysql=yes --enable-safe-mode \
+ --enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
+ --with-readline --with-gettext --enable-calendar --with-ldap\
+ --with-gd --with-ttf --with-jpeg-dir=/usr/lib \
+ --with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
+ --with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
+ --enable-versioning --enable-inline-optimization --enable-trans-sid --enable-track-vars
+ make
+}
+
+src_unpack() {
+ unpack php-4.0.0.tar.gz
+ cd ${S}
+ unpack number4.tar.gz
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib/apache
+ cp .libs/libphp4.so ${D}/usr/lib/apache
+ dodir /etc/httpd
+ cp php.ini-dist ${D}/etc/httpd/php.ini
+ into /usr
+ dodoc CODING_STANDARDS FUNCTION_LIST.txt INSTALL LICENSE
+ dodoc MAINTAINERS MODULES_STATUS README.* TODO NEWS
+}
+
+pkg_postinst() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ # Activate PHP-Extension in httpd.conf
+ einfo "Activate PHP in httpd.conf..."
+ cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
+ sed -e "s/^#LoadModule php4_module/LoadModule php4_module/" \
+ -e "s/^#AddModule mod_php4.c/AddModule mod_php4.c/" \
+ -e "s/#AddType application\/x-httpd-php /AddType application\/x-httpd-php /" \
+ -e "s/#AddType application\/x-httpd-php-/AddType application\/x-httpd-php-/" \
+ ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
+
+}
+
+
diff --git a/dev-lang/php-4/php-4.0.1-r1.ebuild b/dev-lang/php-4/php-4.0.1-r1.ebuild
new file mode 100644
index 000000000000..6d76681cd77f
--- /dev/null
+++ b/dev-lang/php-4/php-4.0.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.1-r1.ebuild,v 1.1 2000/08/07 18:11:23 achim Exp $
+
+P=php-4.0.1
+A="php-4.0.1.tar.gz number4.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML embedded scripting language"
+CATEGORY=dev-lang
+SRC_URI="http://www.php.net/distributions/php-4.0.1.tar.gz
+ http://www.php.net/extra/number4.tar.gz"
+HOMEPAGE="http://www.php.net/"
+
+src_compile() {
+
+# FLAGS="-mpentium -march=pentium -O4 -I/usr/include/freetype"
+# export CFLAGS=$FLAGS
+# export CPPFLAGS=$FLAGS
+# export CXXFLAGS=$FLAGS
+ export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
+ ./configure --with-mysql=yes --enable-safe-mode \
+ --enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
+ --with-readline --with-gettext --enable-calendar --with-ldap\
+ --with-gd --with-ttf --with-jpeg-dir=/usr/lib \
+ --with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
+ --with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
+ --enable-versioning --enable-inline-optimization --enable-trans-sid
+ make
+}
+
+src_unpack() {
+ unpack php-4.0.1.tar.gz
+ cd ${S}
+ unpack number4.tar.gz
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib/apache
+ cp .libs/libphp4.so ${D}/usr/lib/apache
+ dodir /etc/httpd
+ cp php.ini-dist ${D}/etc/httpd/php.ini
+ into /usr
+ dodoc CODING_STANDARDS FUNCTION_LIST.txt INSTALL LICENSE
+ dodoc MAINTAINERS MODULES_STATUS README.* TODO NEWS
+}
+
+pkg_postinst() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ # Activate PHP-Extension in httpd.conf
+ einfo "Activate PHP in httpd.conf..."
+ cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
+ sed -e "s/^#LoadModule php4_module/LoadModule php4_module/" \
+ -e "s/^#AddModule mod_php4.c/AddModule mod_php4.c/" \
+ -e "s/#AddType application\/x-httpd-php /AddType application\/x-httpd-php /" \
+ -e "s/#AddType application\/x-httpd-php-/AddType application\/x-httpd-php-/" \
+ ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
+
+}
diff --git a/dev-lang/php-4/php-4.0.1p2-r1.ebuild b/dev-lang/php-4/php-4.0.1p2-r1.ebuild
new file mode 100644
index 000000000000..f2288b9e01e7
--- /dev/null
+++ b/dev-lang/php-4/php-4.0.1p2-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php-4/php-4.0.1p2-r1.ebuild,v 1.1 2000/08/07 18:11:23 achim Exp $
+
+P=php-4.0.1pl2
+A="${P}.tar.gz number4.tar.gz"
+S=${WORKDIR}/${P}
+DESCRIPTION="HTML embedded scripting language"
+CATEGORY=dev-lang
+SRC_URI="http://www.php.net/distributions/${P}.tar.gz
+ http://www.php.net/extra/number4.tar.gz"
+HOMEPAGE="http://www.php.net/"
+
+src_compile() {
+
+ export LD_FLAGS="$LD_FLAGS -ltiff -ljpeg -L/usr/X11R6/lib"
+ ./configure --with-mysql=yes --enable-safe-mode \
+ --enable-sysvsem --enable-sysvshm --with-zlib=yes --enable-bcmath \
+ --with-readline --with-gettext --enable-calendar --with-ldap\
+ --with-gd --with-ttf --with-t1lib --with-jpeg-dir=/usr/lib \
+ --with-config-file-path=`/usr/sbin/apxs -q SYSCONFDIR` \
+ --with-apxs="/usr/sbin/apxs -ltiff" --with-exec-dir="/usr/lib/apache/bin" \
+ --enable-versioning --enable-inline-optimization --enable-trans-sid --enable-track-vars
+ make
+}
+
+src_unpack() {
+ unpack php-4.0.1pl2.tar.gz
+ cd ${S}
+ unpack number4.tar.gz
+}
+
+src_install() {
+ cd ${S}
+ dodir /usr/lib/apache
+ cp .libs/libphp4.so ${D}/usr/lib/apache
+ dodir /etc/httpd
+ cp php.ini-dist ${D}/etc/httpd/php.ini
+ into /usr
+ dodoc CODING_STANDARDS FUNCTION_LIST.txt INSTALL LICENSE
+ dodoc MAINTAINERS MODULES_STATUS README.* TODO NEWS
+}
+
+pkg_postinst() {
+
+ . ${ROOT}/etc/rc.d/config/functions
+
+ # Activate PHP-Extension in httpd.conf
+ einfo "Activate PHP in httpd.conf..."
+ cp ${ROOT}/etc/httpd/httpd.conf ${ROOT}/etc/httpd/httpd.conf.orig
+ sed -e "s/^#LoadModule php4_module/LoadModule php4_module/" \
+ -e "s/^#AddModule mod_php4.c/AddModule mod_php4.c/" \
+ -e "s/#AddType application\/x-httpd-php /AddType application\/x-httpd-php /" \
+ -e "s/#AddType application\/x-httpd-php-/AddType application\/x-httpd-php-/" \
+ ${ROOT}/etc/httpd/httpd.conf.orig > ${ROOT}/etc/httpd/httpd.conf
+
+}
+
diff --git a/dev-lang/python/files/digest b/dev-lang/python/files/digest
new file mode 100644
index 000000000000..aa53151cacee
--- /dev/null
+++ b/dev-lang/python/files/digest
@@ -0,0 +1 @@
+MD5 e9d677ae6d5a3efc6937627ed8a3e752 py152.tgz
diff --git a/dev-lang/python/python-1.5.2-r1.ebuild b/dev-lang/python/python-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..053d3e9e6803
--- /dev/null
+++ b/dev-lang/python/python-1.5.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-1.5.2-r1.ebuild,v 1.1 2000/08/07 18:11:23 achim Exp $
+
+P=python-1.5.2
+A=py152.tgz
+S=${WORKDIR}/Python-1.5.2
+CATEGORY="dev-lang"
+DESCRIPTION="A really great language"
+SRC_URI="http://www.python.org/ftp/python/src/py152.tgz"
+HOMEPAGE="http://www.python.org/"
+
+src_compile() {
+ ./configure --prefix=/usr --with-threads
+ cp Makefile Makefile.orig
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.orig > Makefile
+ make
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/Modules
+ sed -e 's/#readline/readline/' -e 's/-lreadline -ltermcap/-lreadline/' \
+-e 's/#_locale/_locale/' -e 's/#crypt/crypt/' -e 's/# -lcrypt/-lcrypt/' \
+-e 's/#audioop/audioop/' -e 's/#imageop/imageop/' -e 's/#rgbimg/rgbimg/' \
+-e 's/# _tkinter/_tkinter/' -e 's:-DWITH_APPINIT \\:-DWITH_APPINIT -I/usr/X11R6/include -ltk8.1 -ltcl8.1 -L/usr/X11R6/lib -lX11:' \
+-e 's/#syslog/syslog/' -e 's/#curses cursesmodule.c -lcurses -ltermcap/curses cursesmodule.c -lncurses/' \
+-e 's:#gdbm gdbmmodule.c -I/usr/local/include -L/usr/local/lib -lgdbm:gdbm gdbmmodule.c -lgdbm:' \
+-e 's:#zlib zlibmodule.c -I$(prefix)/include -L$(exec_prefix)/lib -lz:zlib zlibmodule.c -lz:' \
+Setup.in > Setup
+}
+
+
+src_install() {
+ dodir /usr
+ make install prefix=${D}/usr
+ prepman
+ strip ${D}/usr/bin/python
+
+#DOC
+
+ dodoc README
+
+}
+
diff --git a/dev-lang/tcl-tk-8.0/files/digest b/dev-lang/tcl-tk-8.0/files/digest
new file mode 100644
index 000000000000..508dd8405b40
--- /dev/null
+++ b/dev-lang/tcl-tk-8.0/files/digest
@@ -0,0 +1,2 @@
+MD5 4247975c801510fb378b76237b2abaaf tcl8.0.5.tar.gz
+MD5 3ae92b86c01ec99a1872697294839e64 tk8.0.5.tar.gz
diff --git a/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild b/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild
new file mode 100644
index 000000000000..23b41fb704a2
--- /dev/null
+++ b/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk-8.0/tcl-tk-8.0.5-r1.ebuild,v 1.1 2000/08/07 18:11:24 achim Exp $
+#
+
+P=tcl-tk-8.0.5
+
+R1=tcl8.0.5
+A1=${R1}.tar.gz
+S1=${WORKDIR}/${R1}
+SRC_URI1="ftp://ftp.scriptics.com/pub/tcl/tcl8_0/tcl8.0.5.tar.gz"
+
+R2=tk8.0.5
+A2=${R2}.tar.gz
+S2=${WORKDIR}/${R2}
+
+SRC_URI2="ftp://ftp.scriptics.com/pub/tcl/tcl8_0/tk8.0.5.tar.gz"
+
+A="${A1} ${A2}"
+SRC_URI="${SRC_URI1} ${SRC_URI2}"
+HOMEPAGE="http:/dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+CATEGORY=dev-lang
+
+# hyper-optimizations untested...
+#
+src_unpack() {
+ unpack ${A1}
+ unpack ${A2}
+ cp ${S1}/unix/configure ${S1}/unix/configure.orig
+ sed -e "s/^CFLAGS_OPTIMIZE=-O$/CFLAGS_OPTIMIZE=\$CFLAGS/" \
+ ${S1}/unix/configure.orig > ${S1}/unix/configure
+}
+
+src_compile() {
+ cd ${S1}/unix
+ ./configure --host=${CHOST} --prefix=/usr --enable-shared
+ make
+ cd ${S2}/unix
+ ./configure --host=${CHOST} --prefix=/usr --with-tcl=${S1}/unix --enable-shared
+ make
+}
+
+src_install() {
+ cd ${S1}/unix
+ make INSTALL_ROOT=${D} install
+ cd ${S2}/unix
+ make INSTALL_ROOT=${D} install
+ strip ${D}/usr/bin/*
+# ln -sf wish8.1 ${D}/usr/bin/wish
+# ln -sf tclsh8.1 ${D}/usr/bin/tclsh
+ cd ${S1}
+ dodoc README changes license.terms
+
+ prepman
+}
+
+
+
diff --git a/dev-lang/tcl-tk-8.1/files/digest b/dev-lang/tcl-tk-8.1/files/digest
new file mode 100644
index 000000000000..e713fc374e13
--- /dev/null
+++ b/dev-lang/tcl-tk-8.1/files/digest
@@ -0,0 +1,2 @@
+MD5 fd85414ffca58be880a40f1e699653b2 tcl8.1.1.tar.gz
+MD5 0677449e344e7720cfa37660d070de8c tk8.1.1.tar.gz
diff --git a/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild b/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild
new file mode 100644
index 000000000000..fe6faa2c6385
--- /dev/null
+++ b/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl-tk-8.1/tcl-tk-8.1.1-r1.ebuild,v 1.1 2000/08/07 18:11:24 achim Exp $
+
+P=tcl-tk-8.1.1
+
+R1=tcl8.1.1
+A1=${R1}.tar.gz
+S1=${WORKDIR}/${R1}
+SRC_URI1="ftp://ftp.scriptics.com/pub/tcl/tcl8_1/tcl8.1.1.tar.gz"
+
+R2=tk8.1.1
+A2=${R2}.tar.gz
+S2=${WORKDIR}/${R2}
+
+SRC_URI2="ftp://ftp.scriptics.com/pub/tcl/tcl8_1/tk8.1.1.tar.gz"
+
+A="${A1} ${A2}"
+SRC_URI="${SRC_URI1} ${SRC_URI2}"
+HOMEPAGE="http:/dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+CATEGORY=dev-lang
+
+# hyper-optimizations untested...
+#
+src_unpack() {
+ unpack ${A1}
+ unpack ${A2}
+ cp ${S1}/unix/configure ${S1}/unix/configure.orig
+ sed -e "s/^CFLAGS_OPTIMIZE=-O$/CFLAGS_OPTIMIZE=\$CFLAGS/" \
+ ${S1}/unix/configure.orig > ${S1}/unix/configure
+}
+
+src_compile() {
+ cd ${S1}/unix
+ ./configure --host=${CHOST} --prefix=/usr --enable-threads
+ make
+ cd ${S2}/unix
+ ./configure --host=${CHOST} --prefix=/usr --with-tcl=${S1}/unix --enable-threads
+ make
+}
+
+src_install() {
+ cd ${S1}/unix
+ make INSTALL_ROOT=${D} install
+ cd ${S2}/unix
+ make INSTALL_ROOT=${D} install
+ strip ${D}/usr/bin/*
+ ln -sf wish8.1 ${D}/usr/bin/wish
+ ln -sf tclsh8.1 ${D}/usr/bin/tclsh
+ cd ${S1}
+ dodoc README changes license.terms
+ prepman
+
+
+}
+