summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-31 14:03:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-31 14:03:29 +0000
commitc646ca2b1cbdd6d5f90ba47ddb1def27213ab6cc (patch)
treec3b13b937a33c6b080432f04497f3d71e6d85d72 /dev-lang
parentFix typo in DEPEND, bug #279797 (diff)
downloadgentoo-2-c646ca2b1cbdd6d5f90ba47ddb1def27213ab6cc.tar.gz
gentoo-2-c646ca2b1cbdd6d5f90ba47ddb1def27213ab6cc.tar.bz2
gentoo-2-c646ca2b1cbdd6d5f90ba47ddb1def27213ab6cc.zip
Skip test_ctypes on systems with PAX (bug #234498).
(Portage version: 13869-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog6
-rw-r--r--dev-lang/python/python-2.5.4-r3.ebuild9
-rw-r--r--dev-lang/python/python-2.6.2-r1.ebuild9
3 files changed, 17 insertions, 7 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index 31743810323a..9fb043a2fc58 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/python
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.395 2009/07/30 23:26:37 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.396 2009/07/31 14:03:29 arfrever Exp $
+
+ 31 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-2.5.4-r3.ebuild, python-2.6.2-r1.ebuild:
+ Skip test_ctypes on systems with PAX (bug #234498).
30 Jul 2009; Jeremy Olexa <darkside@gentoo.org> python-2.6.2-r1.ebuild:
amd64 stable, bug 277645
diff --git a/dev-lang/python/python-2.5.4-r3.ebuild b/dev-lang/python/python-2.5.4-r3.ebuild
index f4d435a92a65..302b67a1776e 100644
--- a/dev-lang/python/python-2.5.4-r3.ebuild
+++ b/dev-lang/python/python-2.5.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.9 2009/07/19 09:30:49 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r3.ebuild,v 1.10 2009/07/31 14:03:29 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -9,7 +9,7 @@
EAPI="1"
-inherit autotools eutils flag-o-matic libtool multilib python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic libtool multilib pax-utils python toolchain-funcs versionator
# We need this so that we don't depends on python.eclass
PYVER_MAJOR=$(get_major_version)
@@ -189,7 +189,10 @@ src_test() {
# test_pow fails on alpha.
# http://bugs.python.org/issue756093
- [[ ${ARCH} == "alpha" ]] && skip_tests="${skip_tests} pow"
+ [[ ${ARCH} == "alpha" ]] && skip_tests+=" pow"
+
+ # test_ctypes fails with PAX kernel (bug #234498).
+ host-is-pax && skip_tests+=" ctypes"
for test in ${skip_tests}; do
mv "${S}"/Lib/test/test_${test}.py "${T}"
diff --git a/dev-lang/python/python-2.6.2-r1.ebuild b/dev-lang/python/python-2.6.2-r1.ebuild
index 189c2b0f9cab..086d11045b84 100644
--- a/dev-lang/python/python-2.6.2-r1.ebuild
+++ b/dev-lang/python/python-2.6.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.2 2009/07/30 23:26:37 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r1.ebuild,v 1.3 2009/07/31 14:03:29 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -9,7 +9,7 @@
EAPI="2"
-inherit autotools eutils flag-o-matic libtool multilib python toolchain-funcs versionator
+inherit autotools eutils flag-o-matic libtool multilib pax-utils python toolchain-funcs versionator
# We need this so that we don't depends on python.eclass
PYVER_MAJOR=$(get_major_version)
@@ -181,7 +181,10 @@ src_test() {
# test_pow fails on alpha.
# http://bugs.python.org/issue756093
- [[ ${ARCH} == "alpha" ]] && skip_tests="${skip_tests} pow"
+ [[ ${ARCH} == "alpha" ]] && skip_tests+=" pow"
+
+ # test_ctypes fails with PAX kernel (bug #234498).
+ host-is-pax && skip_tests+=" ctypes"
for test in ${skip_tests}; do
mv "${S}"/Lib/test/test_${test}.py "${T}"