summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2008-06-20 15:08:24 +0000
committerCaleb Tennis <caleb@gentoo.org>2008-06-20 15:08:24 +0000
commitda498e1225b9cb516753f05bdf1fbe168afd04b4 (patch)
tree1c48fe1e67153df9edaef5594e8505bca4b1683e /dev-lang
parentversion bump (diff)
downloadgentoo-2-da498e1225b9cb516753f05bdf1fbe168afd04b4.tar.gz
gentoo-2-da498e1225b9cb516753f05bdf1fbe168afd04b4.tar.bz2
gentoo-2-da498e1225b9cb516753f05bdf1fbe168afd04b4.zip
nevermind, don't bump this yet
(Portage version: 2.1.5.2)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ruby/ChangeLog5
-rw-r--r--dev-lang/ruby/ruby-1.8.6_p230.ebuild168
2 files changed, 4 insertions, 169 deletions
diff --git a/dev-lang/ruby/ChangeLog b/dev-lang/ruby/ChangeLog
index 4e1c0368107c..cac22aa7a2cb 100644
--- a/dev-lang/ruby/ChangeLog
+++ b/dev-lang/ruby/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lang/ruby
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.336 2008/06/20 15:06:12 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ChangeLog,v 1.337 2008/06/20 15:08:24 caleb Exp $
+
+ 20 Jun 2008; Caleb Tennis <caleb@gentoo.org> -ruby-1.8.6_p230.ebuild:
+ nevermind, don't bump this yet
*ruby-1.8.6_p230 (20 Jun 2008)
diff --git a/dev-lang/ruby/ruby-1.8.6_p230.ebuild b/dev-lang/ruby/ruby-1.8.6_p230.ebuild
deleted file mode 100644
index 65c68fb0f5d0..000000000000
--- a/dev-lang/ruby/ruby-1.8.6_p230.ebuild
+++ /dev/null
@@ -1,168 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ruby/ruby-1.8.6_p230.ebuild,v 1.1 2008/06/20 15:06:12 caleb Exp $
-
-WANT_AUTOCONF="latest"
-WANT_AUTOMAKE="latest"
-
-ONIGURUMA="onigd2_5_9"
-
-inherit autotools eutils flag-o-matic multilib versionator
-
-MY_P="${PN}-$(replace_version_separator 3 '-')"
-S=${WORKDIR}/${MY_P}
-
-SLOT=$(get_version_component_range 1-2)
-MY_SUFFIX=$(delete_version_separator 1 ${SLOT})
-
-DESCRIPTION="An object-oriented scripting language"
-HOMEPAGE="http://www.ruby-lang.org/"
-SRC_URI="ftp://ftp.ruby-lang.org/pub/ruby/${SLOT}/${MY_P}.tar.bz2
- cjk? ( http://www.geocities.jp/kosako3/oniguruma/archive/${ONIGURUMA}.tar.gz )"
-
-LICENSE="Ruby"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="berkdb cjk debug doc emacs examples gdbm ipv6 rubytests socks5 ssl threads tk xemacs"
-
-RDEPEND="
- berkdb? ( sys-libs/db )
- gdbm? ( sys-libs/gdbm )
- ssl? ( dev-libs/openssl )
- socks5? ( >=net-proxy/dante-1.1.13 )
- tk? ( dev-lang/tk )
- >=dev-ruby/ruby-config-0.3.1
- !=dev-lang/ruby-cvs-${SLOT}*
- !dev-ruby/rdoc
- !dev-ruby/rexml"
-DEPEND="${RDEPEND}"
-PDEPEND="emacs? ( app-emacs/ruby-mode )
- xemacs? ( app-xemacs/ruby-modes )"
-
-PROVIDE="virtual/ruby"
-
-src_unpack() {
- unpack ${A}
-
- if use cjk ; then
- einfo "Applying ${ONIGURUMA}"
- pushd "${WORKDIR}/oniguruma"
- econf --with-rubydir="${S}" || die "oniguruma econf failed"
- emake $MY_SUFFIX || die "oniguruma emake failed"
- popd
- fi
-
- cd "${S}/ext/dl"
- epatch "${FILESDIR}/${PN}-1.8.6-memory-leak.diff"
- cd "${S}"
-
- # Fix a hardcoded lib path in configure script
- sed -i -e "s:\(RUBY_LIB_PREFIX=\"\${prefix}/\)lib:\1$(get_libdir):" \
- configure.in || die "sed failed"
-
- eautoreconf
-}
-
-src_compile() {
- # -fomit-frame-pointer makes ruby segfault, see bug #150413.
- filter-flags -fomit-frame-pointer
- # In many places aliasing rules are broken; play it safe
- # as it's risky with newer compilers to leave it as it is.
- append-flags -fno-strict-aliasing
-
- # Socks support via dante
- if use socks5 ; then
- # Socks support can't be disabled as long as SOCKS_SERVER is
- # set and socks library is present, so need to unset
- # SOCKS_SERVER in that case.
- unset SOCKS_SERVER
- fi
-
- # Increase GC_MALLOC_LIMIT if set (default is 8000000)
- if [ -n "${RUBY_GC_MALLOC_LIMIT}" ] ; then
- append-flags "-DGC_MALLOC_LIMIT=${RUBY_GC_MALLOC_LIMIT}"
- fi
-
- econf --program-suffix=$MY_SUFFIX --enable-shared \
- $(use_enable socks5 socks) \
- $(use_enable doc install-doc) \
- $(use_enable threads pthread) \
- $(use_enable ipv6) \
- $(use_enable debug) \
- $(use_with berkdb dbm) \
- $(use_with gdbm) \
- $(use_with ssl openssl) \
- $(use_with tk) \
- ${myconf} \
- --with-sitedir=/usr/$(get_libdir)/ruby/site_ruby \
- || die "econf failed"
-
- emake EXTLDFLAGS="${LDFLAGS}" || die "emake failed"
-}
-
-src_test() {
- emake -j1 test || die "make test failed"
-
- elog "Ruby's make test has been run. Ruby also ships with a make check"
- elog "that cannot be run until after ruby has been installed."
- elog
- if use rubytests; then
- elog "You have enabled rubytests, so they will be installed to"
- elog "/usr/share/${PN}-${SLOT}/test. To run them you must be a user other"
- elog "than root, and you must place them into a writeable directory."
- elog "Then call: "
- elog
- elog "ruby -C /location/of/tests runner.rb"
- else
- elog "Enable the rubytests USE flag to install the make check tests"
- fi
-}
-
-src_install() {
- LD_LIBRARY_PATH="${D}/usr/$(get_libdir)"
- RUBYLIB="${S}:${D}/usr/$(get_libdir)/ruby/${SLOT}"
- for d in $(find "${S}/ext" -type d) ; do
- RUBYLIB="${RUBYLIB}:$d"
- done
- export LD_LIBRARY_PATH RUBYLIB
-
- emake DESTDIR="${D}" install || die "make install failed"
-
- MINIRUBY=$(echo -e 'include Makefile\ngetminiruby:\n\t@echo $(MINIRUBY)'|make -f - getminiruby)
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitelibdir']")
- keepdir $(${MINIRUBY} -rrbconfig -e "print Config::CONFIG['sitearchdir']")
-
- if use doc; then
- make DESTDIR="${D}" install-doc || die "make install-doc failed"
- fi
-
- if use examples; then
- dodir /usr/share/doc/${PF}
- cp -pPR sample "${D}/usr/share/doc/${PF}"
- fi
-
- dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%.*})
- dosym libruby$MY_SUFFIX$(get_libname ${PV%_*}) /usr/$(get_libdir)/libruby$(get_libname ${PV%_*})
-
- dodoc ChangeLog NEWS README* ToDo
-
- if use rubytests; then
- dodir /usr/share/${PN}-${SLOT}
- cp -pPR test "${D}/usr/share/${PN}-${SLOT}"
- fi
-}
-
-pkg_postinst() {
-
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
- fi
- elog
- elog "You can change the default ruby interpreter by ${ROOT}usr/sbin/ruby-config"
- elog
-}
-
-pkg_postrm() {
- if [[ ! -n $(readlink "${ROOT}"usr/bin/ruby) ]] ; then
- "${ROOT}usr/sbin/ruby-config" ruby$MY_SUFFIX
- fi
-}