summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-02-22 02:50:49 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-02-22 02:50:49 +0000
commitdad30e0f0d59346539ae97853c49a6a77772042d (patch)
tree63c6b6c016fa4cf1962e66682432f2a97e8e7c09 /dev-lang
parentAdd proper dependencies for IUSE=xephyr, bug 528230. (diff)
downloadgentoo-2-dad30e0f0d59346539ae97853c49a6a77772042d.tar.gz
gentoo-2-dad30e0f0d59346539ae97853c49a6a77772042d.tar.bz2
gentoo-2-dad30e0f0d59346539ae97853c49a6a77772042d.zip
Bump
(Portage version: 2.2.17/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/nqp/ChangeLog7
-rw-r--r--dev-lang/nqp/nqp-2015.02.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-lang/nqp/ChangeLog b/dev-lang/nqp/ChangeLog
index 74080b7f6ee3..371c2ec18bc4 100644
--- a/dev-lang/nqp/ChangeLog
+++ b/dev-lang/nqp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/nqp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.61 2015/01/31 15:53:57 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/ChangeLog,v 1.62 2015/02/22 02:50:49 patrick Exp $
+
+*nqp-2015.02 (22 Feb 2015)
+
+ 22 Feb 2015; Patrick Lauer <patrick@gentoo.org> +nqp-2015.02.ebuild:
+ Bump
31 Jan 2015; Mikle Kolyada <zlogene@gentoo.org> -nqp-2014.07.ebuild,
-nqp-2014.08.ebuild, -nqp-2014.09.ebuild, -nqp-2014.10.ebuild,
diff --git a/dev-lang/nqp/nqp-2015.02.ebuild b/dev-lang/nqp/nqp-2015.02.ebuild
new file mode 100644
index 000000000000..dcdde1c32ee4
--- /dev/null
+++ b/dev-lang/nqp/nqp-2015.02.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/nqp/nqp-2015.02.ebuild,v 1.1 2015/02/22 02:50:49 patrick Exp $
+
+EAPI=5
+
+# still not working
+RESTRICT="test"
+
+inherit eutils multilib versionator
+
+GITCRAP=48279f9
+PARROT_VERSION="6.7.0"
+
+DESCRIPTION="Not Quite Perl, a Perl 6 bootstrapping compiler"
+HOMEPAGE="http://rakudo.org/"
+SRC_URI="http://github.com/perl6/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="doc +parrot java moar"
+REQUIRED_USE="|| ( parrot java moar )"
+
+RDEPEND="parrot? ( >=dev-lang/parrot-${PARROT_VERSION}:=[unicode] )
+ java? ( >=virtual/jre-1.7 )
+ moar? ( =dev-lang/moarvm-${PV} )
+ dev-libs/libffi"
+DEPEND="${RDEPEND}
+ java? ( >=virtual/jdk-1.7 )
+ dev-lang/perl"
+
+S=${WORKDIR}/perl6-nqp-${GITCRAP}
+
+src_configure() {
+ use java && myconf+="jvm,"
+ use parrot && myconf+="parrot,"
+ use moar && myconf+="moar,"
+ perl Configure.pl --backend=${myconf} --prefix=/usr || die
+ # dirty hack to make dyncall not fail
+ sed -i -e 's/-Werror=missing-prototypes//' Makefile || die
+ sed -i -e 's/-Werror=missing-declarations//' Makefile || die
+ sed -i -e 's/-Werror=strict-prototypes//' Makefile || die
+
+ # more dirty hack to allow building with newer gcc
+ sed -i -e 's/-Werror=implicit-function-declaration//' Makefile || die
+ sed -i -e 's/-Werror=nested-externs//' Makefile || die
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_test() {
+ emake -j1 test || die
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install || die
+
+ dodoc CREDITS README.pod || die
+
+ if use doc; then
+ dodoc -r docs/* || die
+ fi
+}