summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2003-10-21 18:37:26 +0000
committerMartin Holzer <mholzer@gentoo.org>2003-10-21 18:37:26 +0000
commite04bf4ad2f29596262a2f15028f13a2e0f7e97c9 (patch)
tree6ad4be59576c30795cbd103cff4aa6b10bcfd410 /dev-lang
parentVersion bumped. Closes #28633. (diff)
downloadgentoo-2-e04bf4ad2f29596262a2f15028f13a2e0f7e97c9.tar.gz
gentoo-2-e04bf4ad2f29596262a2f15028f13a2e0f7e97c9.tar.bz2
gentoo-2-e04bf4ad2f29596262a2f15028f13a2e0f7e97c9.zip
Version bumped. Closes #28633.
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/tcl/ChangeLog6
-rw-r--r--dev-lang/tcl/Manifest4
-rw-r--r--dev-lang/tcl/files/digest-tcl-8.4.41
-rw-r--r--dev-lang/tcl/tcl-8.4.4.ebuild81
4 files changed, 89 insertions, 3 deletions
diff --git a/dev-lang/tcl/ChangeLog b/dev-lang/tcl/ChangeLog
index afe9e81fd705..147b0a9dfb2c 100644
--- a/dev-lang/tcl/ChangeLog
+++ b/dev-lang/tcl/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-lang/tcl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.17 2003/09/30 20:32:33 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/ChangeLog,v 1.18 2003/10/21 18:37:21 mholzer Exp $
+*tcl-8.4.4 (22 Oct 2003)
+
+ 22 Oct 2003; Martin Holzer <mholzer@gentoo.org> tcl-8.4.4.ebuild:
+ Version bumped. Closes #28633.
*tcl-8.4.3 (30 Jun 2003)
diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index 206dd855e55d..1be285b4b0e3 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,11 +1,11 @@
-MD5 0696fdca2543418920f2e0940aa154e6 ChangeLog 2664
+MD5 5df4bd81741bf9c37d64baa1797cd824 ChangeLog 2793
MD5 efce7f63c18f3658617fda1b3f7d5838 tcl-8.3.3-r1.ebuild 2065
MD5 08cf84b54506f74693dfb290bcb9ed09 tcl-8.3.3-r3.ebuild 2168
MD5 c707fdc5fe0d20eba094a599d22c832a tcl-8.3.4.ebuild 2181
MD5 294413bdc33e50063240be6ae9914276 tcl-8.4.2-r1.ebuild 2655
MD5 8c2b1fbfbd6a363e66afa121c021bb0b tcl-8.4.2.ebuild 2649
MD5 636747d6923c84e00d83f62540b6f140 tcl-8.4.3.ebuild 2662
-MD5 636747d6923c84e00d83f62540b6f140 tcl-8.4.4.ebuild 2662
+MD5 b6377e04869dc6f39ab9a6de61a82a4b tcl-8.4.4.ebuild 2611
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r1 61
MD5 ee8221e881e685cb7836325e4021881e files/digest-tcl-8.3.3-r3 61
MD5 d7d05b473cf799a637baaa9f321b070f files/digest-tcl-8.3.4 121
diff --git a/dev-lang/tcl/files/digest-tcl-8.4.4 b/dev-lang/tcl/files/digest-tcl-8.4.4
new file mode 100644
index 000000000000..63852333b10a
--- /dev/null
+++ b/dev-lang/tcl/files/digest-tcl-8.4.4
@@ -0,0 +1 @@
+MD5 e503db5f1d762c2a3bbe7cb02c630659 tcl8.4.4-src.tar.gz 3370796
diff --git a/dev-lang/tcl/tcl-8.4.4.ebuild b/dev-lang/tcl/tcl-8.4.4.ebuild
new file mode 100644
index 000000000000..3c4f260aeb4d
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.4.4.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tcl/tcl-8.4.4.ebuild,v 1.1 2003/10/21 18:37:21 mholzer Exp $
+
+
+S=${WORKDIR}/${PN}${PV}
+SRC_URI="ftp://ftp.scriptics.com/pub/tcl/tcl8_4/${PN}${PV}-src.tar.gz"
+HOMEPAGE="http://dev.scriptics.com/software/tcltk/"
+
+DESCRIPTION="Tool Command Language"
+
+DEPEND="virtual/glibc
+ >=app-portage/gentoolkit-0.1.22"
+RDEPEND="virtual/glibc"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~sparc ~mips"
+IUSE=""
+
+# hyper-optimizations untested...
+#
+
+src_compile() {
+ cd ${S}/unix
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || die
+ # threading is not recommended as it breaks some packages
+ # --enable-threads \
+
+ emake CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ #short version number
+ local v1
+ v1=${PV%.*}
+
+ cd ${S}/unix
+ S= make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
+
+ # fix the tclConfig.sh to eliminate refs to the build directory
+ sed -e "s,^TCL_BUILD_LIB_SPEC='-L${S}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_SRC_DIR='${S}',TCL_SRC_DIR='/usr/lib/tcl${v1}/include'," \
+ -e "s,^TCL_BUILD_STUB_LIB_SPEC='-L${S}/unix,TCL_BUILD_STUB_LIB_SPEC='-L/usr/lib," \
+ -e "s,^TCL_BUILD_STUB_LIB_PATH='${S}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
+ -e "s,^TCL_LIB_FILE='libtcl8.4..TCL_DBGX..so',TCL_LIB_FILE=\"libtcl8.4\$\{TCL_DBGX\}.so\"," \
+ ${D}/usr/lib/tclConfig.sh > ${D}/usr/lib/tclConfig.sh.new
+ mv ${D}/usr/lib/tclConfig.sh.new ${D}/usr/lib/tclConfig.sh
+
+ # install private headers
+ dodir /usr/lib/tcl${v1}/include/unix
+ install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tcl${v1}/include/unix
+ dodir /usr/lib/tcl${v1}/include/generic
+ install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tcl${v1}/include/generic
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tcl.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclDecls.h
+ rm -f ${D}/usr/lib/tcl${v1}/include/generic/tclPlatDecls.h
+
+ # install symlink for libraries
+ dosym /usr/lib/libtcl${v1}.so /usr/lib/libtcl.so
+ dosym /usr/lib/libtclstub${v1}.a /usr/lib/libtclstub.a
+
+ ln -sf tclsh${v1} ${D}/usr/bin/tclsh
+
+ cd ${S}
+ dodoc README changes license.terms
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you're upgrading from tcl-8.3, you must recompile the other"
+ ewarn "packages on your system that link with tcl after the upgrade"
+ ewarn "completes. To perform this action, please run revdep-rebuild."
+ ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+ ewarn "upgrade them before this recompilation, too,"
+ ewarn
+ sleep 5
+}