summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-06-20 16:12:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-06-20 16:12:58 +0000
commited35c56d6e2db00a93e7c327e29b1a687905a978 (patch)
treef6d33d6a5fe4054be847f1bb66521175bf9f81c4 /dev-lang
parentRemove old versions. (diff)
downloadgentoo-2-ed35c56d6e2db00a93e7c327e29b1a687905a978.tar.gz
gentoo-2-ed35c56d6e2db00a93e7c327e29b1a687905a978.tar.bz2
gentoo-2-ed35c56d6e2db00a93e7c327e29b1a687905a978.zip
use CHOST prefixed toolchain for building, this does not give us cross compile support though
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.11.1.ebuild8
2 files changed, 11 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index c8e0e1c27084..4a463e5c637e 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lang/ocaml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.167 2009/06/20 14:54:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.168 2009/06/20 16:12:58 aballier Exp $
+
+ 20 Jun 2009; Alexis Ballier <aballier@gentoo.org> ocaml-3.11.1.ebuild:
+ use CHOST prefixed toolchain for building, this does not give us cross
+ compile support though
20 Jun 2009; Alexis Ballier <aballier@gentoo.org>
-files/ocaml-3.11.0_beta1-configure.patch,
diff --git a/dev-lang/ocaml/ocaml-3.11.1.ebuild b/dev-lang/ocaml/ocaml-3.11.1.ebuild
index 9bd975e9c29d..a0ba2b86a2b3 100644
--- a/dev-lang/ocaml/ocaml-3.11.1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.11.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.1.ebuild,v 1.2 2009/06/20 14:54:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.11.1.ebuild,v 1.3 2009/06/20 16:12:58 aballier Exp $
EAPI="1"
@@ -47,7 +47,7 @@ src_unpack() {
src_compile() {
export LC_ALL=C
- local myconf="--host ${CHOST}"
+ local myconf=""
# It doesn't compile on alpha without this LDFLAGS
use alpha && append-ldflags "-Wl,--no-relax"
@@ -62,6 +62,10 @@ src_compile() {
--bindir /usr/bin \
--libdir /usr/$(get_libdir)/ocaml \
--mandir /usr/share/man \
+ -host "${CHOST}" \
+ -cc "$(tc-getCC)" \
+ -as "$(tc-getAS)" \
+ -aspp "$(tc-getCC) -c" \
--with-pthread ${myconf} || die "configure failed!"
make world || die "make world failed!"